aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-08-28 16:17:37 +0800
committerpav <pav@FreeBSD.org>2006-08-28 16:17:37 +0800
commit72236417eee9fd1a5233443e1f0c4802d47b73c3 (patch)
tree4bf8abf6f9d4f9dcb74648c43c10e3bb12dde4c7 /x11
parent004b7bf16fd6d40e4010a61f5a43a27922975567 (diff)
downloadfreebsd-ports-gnome-72236417eee9fd1a5233443e1f0c4802d47b73c3.tar.gz
freebsd-ports-gnome-72236417eee9fd1a5233443e1f0c4802d47b73c3.tar.zst
freebsd-ports-gnome-72236417eee9fd1a5233443e1f0c4802d47b73c3.zip
dmenu is a minimalistic X11 menu. It reads a newline separated list of items
from stdin and shows them as a menu on the top of the screen. When the user selects one item or types any text and presses Enter, his choice is printed to stdout. dmenu was developed as an addition to the dwm window manager, but can be used in any X11-environment. WWW: http://10kloc.org/dwm/ PR: ports/101573 Submitted by: Jeroen Schot <schot@a-eskwadraat.nl>
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/dmenu/Makefile22
-rw-r--r--x11/dmenu/distinfo3
-rw-r--r--x11/dmenu/files/patch-config.mk30
-rw-r--r--x11/dmenu/pkg-descr9
5 files changed, 65 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index e4a91e7b1298..8ad35892dfd1 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -35,6 +35,7 @@
SUBDIR += decurs
SUBDIR += deskmenu
SUBDIR += dgs
+ SUBDIR += dmenu
SUBDIR += docker
SUBDIR += dxpc
SUBDIR += dynamag
diff --git a/x11/dmenu/Makefile b/x11/dmenu/Makefile
new file mode 100644
index 000000000000..7556bbf5b454
--- /dev/null
+++ b/x11/dmenu/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: dmenu
+# Date created: August 4, 2006
+# Whom: Jeroen Schot <schot@a-eskwadraat.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dmenu
+PORTVERSION= 0.3
+CATEGORIES= x11
+MASTER_SITES= http://10kloc.org/download/ \
+ http://schot.a-eskwadraat.nl/files/
+
+MAINTAINER= schot@a-eskwadraat.nl
+COMMENT= X11 menu application (not only) for the dwm window manager
+
+USE_XLIB= yes
+
+MAN1= dmenu.1
+PLIST_FILES= bin/dmenu
+
+.include <bsd.port.mk>
diff --git a/x11/dmenu/distinfo b/x11/dmenu/distinfo
new file mode 100644
index 000000000000..78c36f1a79e4
--- /dev/null
+++ b/x11/dmenu/distinfo
@@ -0,0 +1,3 @@
+MD5 (dmenu-0.3.tar.gz) = bce526e3fab2d4bd3c513b5b378ca425
+SHA256 (dmenu-0.3.tar.gz) = c85fdd759c8b703818e15e45702cdfb2b5dbb503dd15470b8b5aab8b69ef931d
+SIZE (dmenu-0.3.tar.gz) = 6959
diff --git a/x11/dmenu/files/patch-config.mk b/x11/dmenu/files/patch-config.mk
new file mode 100644
index 000000000000..653de7caf423
--- /dev/null
+++ b/x11/dmenu/files/patch-config.mk
@@ -0,0 +1,30 @@
+--- config.mk.orig Mon Aug 7 13:34:51 2006
++++ config.mk Mon Aug 7 13:35:50 2006
+@@ -4,21 +4,21 @@
+ # Customize below to fit your system
+
+ # paths
+-PREFIX = /usr/local
+-MANPREFIX = ${PREFIX}/share/man
++PREFIX ?= /usr/local
++MANPREFIX = ${PREFIX}/man
+
+-X11INC = /usr/X11R6/include
+-X11LIB = /usr/X11R6/lib
++X11INC = $(X11BASE)/include
++X11LIB = $(X11BASE)/lib
+
+ # includes and libs
+ INCS = -I/usr/lib -I${X11INC}
+ LIBS = -L/usr/lib -lc -L${X11LIB} -lX11
+
+ # flags
+-CFLAGS = -Os ${INCS} -DVERSION=\"${VERSION}\"
++CFLAGS+= ${INCS} -DVERSION=\"${VERSION}\"
+ LDFLAGS = ${LIBS}
+ #CFLAGS = -g -Wall -O2 ${INCS} -DVERSION=\"${VERSION}\"
+ #LDFLAGS = -g ${LIBS}
+
+ # compiler
+-CC = cc
++CC?= cc
diff --git a/x11/dmenu/pkg-descr b/x11/dmenu/pkg-descr
new file mode 100644
index 000000000000..d36e104234fa
--- /dev/null
+++ b/x11/dmenu/pkg-descr
@@ -0,0 +1,9 @@
+dmenu is a minimalistic X11 menu. It reads a newline separated list of items
+from stdin and shows them as a menu on the top of the screen. When the user
+selects one item or types any text and presses Enter, his choice is printed to
+stdout.
+
+dmenu was developed as an addition to the dwm window manager, but can be used
+in any X11-environment.
+
+WWW: http://10kloc.org/dwm/