aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-01-29 22:50:51 +0800
committermiwi <miwi@FreeBSD.org>2011-01-29 22:50:51 +0800
commit814d907442307eb47d12edf46dbb439dd53d7e9e (patch)
treec9b1c429d2119265c99e299954c1236feeec178e /x11
parent160225d310536b99ff3bff1e3d888630564e0632 (diff)
downloadfreebsd-ports-gnome-814d907442307eb47d12edf46dbb439dd53d7e9e.tar.gz
freebsd-ports-gnome-814d907442307eb47d12edf46dbb439dd53d7e9e.tar.zst
freebsd-ports-gnome-814d907442307eb47d12edf46dbb439dd53d7e9e.zip
- Update to 1.0.0
PR: 153428 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com> Feature safe: yes
Diffstat (limited to 'x11')
-rw-r--r--x11/xfce4-verve-plugin/Makefile42
-rw-r--r--x11/xfce4-verve-plugin/distinfo5
-rw-r--r--x11/xfce4-verve-plugin/pkg-plist80
3 files changed, 81 insertions, 46 deletions
diff --git a/x11/xfce4-verve-plugin/Makefile b/x11/xfce4-verve-plugin/Makefile
index de70661000a7..c91bd78541cd 100644
--- a/x11/xfce4-verve-plugin/Makefile
+++ b/x11/xfce4-verve-plugin/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= verve-plugin
-PORTVERSION= 0.3.6
-PORTREVISION= 8
+PORTVERSION= 1.0.0
CATEGORIES= x11 xfce
-MASTER_SITES= http://goodies.xfce.org/releases/xfce4-verve-plugin/
+MASTER_SITES= ${MASTER_SITE_XFCE}
+MASTER_SITE_SUBDIR= src/panel-plugins/${DISTNAME:S/-${PORTVERSION}//}/${PORTVERSION:R}
PKGNAMEPREFIX= xfce4-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= xfce4
@@ -17,14 +17,38 @@ DIST_SUBDIR= xfce4
MAINTAINER= miwi@FreeBSD.org
COMMENT= A command line plugin for xfce4
-RUN_DEPENDES= dbus-daemon:${PORTSDIR}/devel/dbus
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
-USE_XFCE= configenv panel libexo libutil
+USE_GNOME= gnomehack glib20 intltool intlhack pkgconfig
+USE_XFCE= configenv panel libexo libgui libutil
+
+CONFIGURE_ARGS= --disable-debug
+
+OPTIONS= NLS "Enable Native Language Support" on \
+ DBUS "Enable D-BUS support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if !defined(WITHOUT_DBUS)
+LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+CONFIGURE_ARGS+=--enable-dbus
+PLIST_SUB+= DBUS=""
+.else
+CONFIGURE_ARGS+=--disable-dbus
+PLIST_SUB+= DBUS="@comment "
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/xfce4-verve-plugin/distinfo b/x11/xfce4-verve-plugin/distinfo
index f06d64ff572a..6df137da362e 100644
--- a/x11/xfce4-verve-plugin/distinfo
+++ b/x11/xfce4-verve-plugin/distinfo
@@ -1,3 +1,2 @@
-MD5 (xfce4/xfce4-verve-plugin-0.3.6.tar.bz2) = 1dee60c7c4e11130226cab381fcb945c
-SHA256 (xfce4/xfce4-verve-plugin-0.3.6.tar.bz2) = a36991328ce4080b615f2e603628f397feb03848a5cabbedf0f5a8f4d701239f
-SIZE (xfce4/xfce4-verve-plugin-0.3.6.tar.bz2) = 283337
+SHA256 (xfce4/xfce4-verve-plugin-1.0.0.tar.bz2) = d011a47ed3b075afdb9673342537fae5deeedc7834daf64b95bc0b541545f1a3
+SIZE (xfce4/xfce4-verve-plugin-1.0.0.tar.bz2) = 324945
diff --git a/x11/xfce4-verve-plugin/pkg-plist b/x11/xfce4-verve-plugin/pkg-plist
index eb4839a3b156..dae7bd20e46d 100644
--- a/x11/xfce4-verve-plugin/pkg-plist
+++ b/x11/xfce4-verve-plugin/pkg-plist
@@ -1,40 +1,52 @@
-bin/verve-focus
+%%DBUS%%bin/verve-focus
libexec/xfce4/panel-plugins/xfce4-verve-plugin
-share/locale/ar/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/ca/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/cs/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/da/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/de/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/el/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/en_GB/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/eo/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/es/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/eu/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/fi/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/fr/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/gl/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/hu/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/id/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/it/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/ja/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/lv/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/nb_NO/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/nl/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/pa/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/pl/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/pt_BR/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/pt_PT/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/ru/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/uk/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/ur/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/vi/LC_MESSAGES/xfce4-verve-plugin.mo
-share/locale/zh_TW/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/el/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/id/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/ur_PK/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfce4-verve-plugin.mo
share/xfce4/panel-plugins/xfce4-verve-plugin.desktop
@dirrmtry share/xfce4/panel-plugins
@dirrmtry share/xfce4
-@dirrmtry share/locale/ur/LC_MESSAGES
-@dirrmtry share/locale/ur
-@dirrmtry share/locale/nb_NO/LC_MESSAGES
-@dirrmtry share/locale/nb_NO
+%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur_PK
+%%NLS%%@dirrmtry share/locale/ur/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur
+%%NLS%%@dirrmtry share/locale/ug/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ug
+%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ast
@dirrmtry libexec/xfce4/panel-plugins
@dirrmtry libexec/xfce4