aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorkmoore <kmoore@FreeBSD.org>2010-12-21 04:06:38 +0800
committerkmoore <kmoore@FreeBSD.org>2010-12-21 04:06:38 +0800
commit898a4a9054d2abafd9c73b54ed6d451ffe69b359 (patch)
tree7fa1d9692c62f68bc9ee1bb38e10b034da533f12 /x11
parente8d0fe2236a08f6213dcc5325720d9823eaf4c12 (diff)
downloadfreebsd-ports-gnome-898a4a9054d2abafd9c73b54ed6d451ffe69b359.tar.gz
freebsd-ports-gnome-898a4a9054d2abafd9c73b54ed6d451ffe69b359.tar.zst
freebsd-ports-gnome-898a4a9054d2abafd9c73b54ed6d451ffe69b359.zip
Fix lx_alarm bug which also caused issue compiling on 8.x and bump PORTREVISION.
Diffstat (limited to 'x11')
-rw-r--r--x11/lxpanel/Makefile2
-rw-r--r--x11/lxpanel/files/patch-src__plugins__batt__batt.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index 3ad0b9bdfb6d..c22b8795bd61 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lxpanel
PORTVERSION= 0.5.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= SF/lxde/LXPanel%20%28desktop%20panel%29/LXPanel%20${PORTVERSION}
diff --git a/x11/lxpanel/files/patch-src__plugins__batt__batt.c b/x11/lxpanel/files/patch-src__plugins__batt__batt.c
index f94f9f493fa3..34a4d5526bd8 100644
--- a/x11/lxpanel/files/patch-src__plugins__batt__batt.c
+++ b/x11/lxpanel/files/patch-src__plugins__batt__batt.c
@@ -76,7 +76,7 @@
if (alarmCanRun) {
- alarm *a = (alarm *) malloc(sizeof(alarm));
-+ lx_alarm *a = (lx_alarm *) malloc(sizeof(alarm));
++ lx_alarm *a = (lx_alarm *) malloc(sizeof(lx_alarm));
a->command = lx_b->alarmCommand;
a->lock = &(lx_b->alarmProcessLock);