aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-12-31 19:32:50 +0800
committerpawel <pawel@FreeBSD.org>2014-12-31 19:32:50 +0800
commit94c7b6dfc4a4a448a28c19b54a26b438a6b068ee (patch)
tree760d698503ba3fcb33820357e55b41cbd480503c /x11
parent68eecdd731d561ad0f6ead8d8b843cb95e255c64 (diff)
downloadfreebsd-ports-gnome-94c7b6dfc4a4a448a28c19b54a26b438a6b068ee.tar.gz
freebsd-ports-gnome-94c7b6dfc4a4a448a28c19b54a26b438a6b068ee.tar.zst
freebsd-ports-gnome-94c7b6dfc4a4a448a28c19b54a26b438a6b068ee.zip
slop (Select Operation) is an application that collects a screen selection
from the user and prints the selection's coordinates to stdout. WWW: http://www.github.com/naelstrof/slop PR: 195199 Submitted by: Neel Chauhan <neel@neelc.org>
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/slop/Makefile24
-rw-r--r--x11/slop/distinfo2
-rw-r--r--x11/slop/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index cba90cb44936..a0d3f0407e98 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -260,6 +260,7 @@
SUBDIR += sisctrl
SUBDIR += slim
SUBDIR += slock
+ SUBDIR += slop
SUBDIR += smproxy
SUBDIR += sselp
SUBDIR += stalonetray
diff --git a/x11/slop/Makefile b/x11/slop/Makefile
new file mode 100644
index 000000000000..1e2bf7f3f237
--- /dev/null
+++ b/x11/slop/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= slop
+PORTVERSION= 4.1.15
+CATEGORIES= x11
+
+MAINTAINER= neel@neelc.org
+COMMENT= Make a screen selection and print the selection coordinates to stdout
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= naelstrof
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= cbc1856
+
+USES= cmake
+USE_XORG= x11 xext
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/slop ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/slop/distinfo b/x11/slop/distinfo
new file mode 100644
index 000000000000..870f3890a99d
--- /dev/null
+++ b/x11/slop/distinfo
@@ -0,0 +1,2 @@
+SHA256 (slop-4.1.15.tar.gz) = fd7c1a7564c228a0a78954559bfd6b0f1f55730e6461891900dd7912e2eaf9b8
+SIZE (slop-4.1.15.tar.gz) = 35302
diff --git a/x11/slop/pkg-descr b/x11/slop/pkg-descr
new file mode 100644
index 000000000000..a344d7d79afc
--- /dev/null
+++ b/x11/slop/pkg-descr
@@ -0,0 +1,4 @@
+slop (Select Operation) is an application that collects a screen selection
+from the user and prints the selection's coordinates to stdout.
+
+WWW: http://www.github.com/naelstrof/slop