aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2012-12-06 18:19:32 +0800
committerrene <rene@FreeBSD.org>2012-12-06 18:19:32 +0800
commitb4b842fe2c26b7b8118a1d27c987504c17f49a09 (patch)
tree9e8adc02b5f0f3d6b856c73a45e79fa3758181c2 /x11
parent09a1c6e127fe773662aeaf504a223962241f2196 (diff)
downloadfreebsd-ports-gnome-b4b842fe2c26b7b8118a1d27c987504c17f49a09.tar.gz
freebsd-ports-gnome-b4b842fe2c26b7b8118a1d27c987504c17f49a09.tar.zst
freebsd-ports-gnome-b4b842fe2c26b7b8118a1d27c987504c17f49a09.zip
- Convert to optionsNG
- Strip library versions Feature safe: yes
Diffstat (limited to 'x11')
-rw-r--r--x11/aterm/Makefile36
1 files changed, 19 insertions, 17 deletions
diff --git a/x11/aterm/Makefile b/x11/aterm/Makefile
index e96f69b314c9..52c34f173923 100644
--- a/x11/aterm/Makefile
+++ b/x11/aterm/Makefile
@@ -1,5 +1,4 @@
# Created by: Jim Mock <jim@FreeBSD.org>
-#
# $FreeBSD$
PORTNAME= aterm
@@ -23,13 +22,14 @@ CONFIGURE_ARGS= --enable-wtmp \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= TRANS "Transparency support" on \
- BSDEL "BSD-style backspace and delete" on \
- MOUSE "Mousewheel support" on \
- BGIMG "XPM, JPEG, PNG backgrounds" off \
- KANJI "Kanji (EUC-JP or SJIS) support" off \
- BIG5S "Chinese character support (BIG5)" off \
- GREEK "Greek keyboard support" off
+OPTIONS_DEFINE= TRANS BSDEL MOUSE BGIMG KANJI BIG5S GREEK
+OPTIONS_DEFAULT= TRANS BSDEL MOUSE
+TRANS_DESC= Transparency support
+BSDEL_DESC= BSD-style backspace and delete
+BGIMG_DESC= XPM, JPEG, PNG backgrounds
+KANJI_DESC= Kanji (EUC-JP or SJIS) support
+BIG5S_DESC= Chinese character (BIG5) support
+GREEK_DESC= Greek keyboard support
MAN1= aterm.1
@@ -42,42 +42,44 @@ CONFIGURE_ARGS+= --disable-utmp
CONFIGURE_ARGS+= --enable-utmp
.endif
-.if !defined(WITHOUT_TRANS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTRANS}
CONFIGURE_ARGS+= --enable-transparency
.else
CONFIGURE_ARGS+= --disable-transparency
.endif
-.if !defined(WITHOUT_BSDEL)
+.if ${PORT_OPTIONS:MBSDEL}
CONFIGURE_ARGS+= --disable-backspace-key --disable-delete-key
.else
CONFIGURE_ARGS+= --enable-backspace-key --enable-delete-key
.endif
-.if !defined(WITHOUT_MOUSE)
+.if ${PORT_OPTIONS:MMOUSE}
CONFIGURE_ARGS+= --enable-mousewheel
.else
CONFIGURE_ARGS+= --disable-mousewheel
.endif
-.if defined(WITH_BGIMG)
-LIB_DEPENDS+= AfterImage.0:${PORTSDIR}/graphics/libafterimage \
+.if ${PORT_OPTIONS:MBGIMG}
+LIB_DEPENDS+= AfterImage:${PORTSDIR}/graphics/libafterimage \
png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+ jpeg:${PORTSDIR}/graphics/jpeg
CONFIGURE_ARGS+= --with-afterimage-config --with-png --with-jpeg
.else
CONFIGURE_ARGS+= --without-afterimage-config --with-png=no --with-jpeg=no
.endif
-.if defined(WITH_KANJI)
+.if ${PORT_OPTIONS:MKANJI}
CONFIGURE_ARGS+= --enable-kanji
.endif
-.if defined(WITH_BIG5S)
+.if ${PORT_OPTIONS:MBIG5S}
CONFIGURE_ARGS+= --enable-big5
.endif
-.if defined(WITH_GREEK)
+.if ${PORT_OPTIONS:MGREEK}
CONFIGURE_ARGS+= --enable-greek
.endif