aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2010-12-20 19:13:44 +0800
committerflz <flz@FreeBSD.org>2010-12-20 19:13:44 +0800
commitb4fb18a56808e6542d1d8d8a1f7201f5c5e37f27 (patch)
treec7bb77faf2eabbe63740815579d6cc4366343646 /x11
parent1cfba75369b1e5b07ca38f83b0aee7694457297c (diff)
downloadfreebsd-ports-gnome-b4fb18a56808e6542d1d8d8a1f7201f5c5e37f27.tar.gz
freebsd-ports-gnome-b4fb18a56808e6542d1d8d8a1f7201f5c5e37f27.tar.zst
freebsd-ports-gnome-b4fb18a56808e6542d1d8d8a1f7201f5c5e37f27.zip
Fix -d on openbox.
PR: ports/152731 Submitted by: vermaden <vermaden@interia.pl>
Diffstat (limited to 'x11')
-rw-r--r--x11/wmctrl/Makefile2
-rw-r--r--x11/wmctrl/files/patch-main.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/x11/wmctrl/Makefile b/x11/wmctrl/Makefile
index 8e84d1b12f4c..b0e00ddf55e3 100644
--- a/x11/wmctrl/Makefile
+++ b/x11/wmctrl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wmctrl
PORTVERSION= 1.07
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11
MASTER_SITES= http://sweb.cz/tripie/utils/wmctrl/dist/
diff --git a/x11/wmctrl/files/patch-main.c b/x11/wmctrl/files/patch-main.c
new file mode 100644
index 000000000000..4af039d3cd07
--- /dev/null
+++ b/x11/wmctrl/files/patch-main.c
@@ -0,0 +1,12 @@
+--- main.c.orig 2005-01-29 03:31:33.000000000 +0000
++++ main.c 2010-12-20 11:09:11.000000000 +0000
+@@ -1441,6 +1441,9 @@
+
+ /* null terminate the result to make string handling easier */
+ tmp_size = (ret_format / 8) * ret_nitems;
++ /* Correct 64 Architecture implementation of 32 bit data */
++ if (ret_format == 32)
++ tmp_size *= sizeof(long)/4;
+ ret = g_malloc(tmp_size + 1);
+ memcpy(ret, ret_prop, tmp_size);
+ ret[tmp_size] = '\0';