aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-12-07 23:43:46 +0800
committerpetef <petef@FreeBSD.org>2001-12-07 23:43:46 +0800
commitd75d003553129c7fd9bba07f50e70566f86565a8 (patch)
treef99e7681282bd12c0571708c0b003331e535f1d1 /x11
parenteb027758c13ba5ff81f0ce847f84d0e003869754 (diff)
downloadfreebsd-ports-gnome-d75d003553129c7fd9bba07f50e70566f86565a8.tar.gz
freebsd-ports-gnome-d75d003553129c7fd9bba07f50e70566f86565a8.tar.zst
freebsd-ports-gnome-d75d003553129c7fd9bba07f50e70566f86565a8.zip
Fix a problem with auto{conf,make}: some build magic was introduced to
make sure that the "autoconf" and "automake" binaries KDE looked for were found and were autoconf213 and automake14 (as there are issues with the latest versions), but the logic in setting $PATH was wrong. This puts ${WRKSRC}/auto-bin before the rest of the users $PATH. This fixes KDE auto* problems if automake14 and automake-1.5 are both installed. PR: 32512 Submitted by: Alan Eldridge <alane@geeksrus.net> Approved by: will
Diffstat (limited to 'x11')
-rw-r--r--x11/kde4-baseapps/Makefile2
-rw-r--r--x11/kde4-runtime/Makefile2
-rw-r--r--x11/kde4-workspace/Makefile2
-rw-r--r--x11/kdebase2/Makefile2
-rw-r--r--x11/kdebase3/Makefile2
-rw-r--r--x11/kdebase4-runtime/Makefile2
-rw-r--r--x11/kdebase4-workspace/Makefile2
-rw-r--r--x11/kdebase4/Makefile2
-rw-r--r--x11/kdelibs2/Makefile2
-rw-r--r--x11/kdelibs3/Makefile2
-rw-r--r--x11/kdelibs4/Makefile2
11 files changed, 11 insertions, 11 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index f8e6c70e010f..3e2388979c98 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -70,7 +70,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s@version-info 3:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/libkonq/Makefile.in
${PERL} -pi -e "s@version-info 1:0:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/khelpcenter/Makefile.in
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index f8e6c70e010f..3e2388979c98 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -70,7 +70,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s@version-info 3:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/libkonq/Makefile.in
${PERL} -pi -e "s@version-info 1:0:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/khelpcenter/Makefile.in
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index f8e6c70e010f..3e2388979c98 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -70,7 +70,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s@version-info 3:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/libkonq/Makefile.in
${PERL} -pi -e "s@version-info 1:0:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/khelpcenter/Makefile.in
diff --git a/x11/kdebase2/Makefile b/x11/kdebase2/Makefile
index f8e6c70e010f..3e2388979c98 100644
--- a/x11/kdebase2/Makefile
+++ b/x11/kdebase2/Makefile
@@ -70,7 +70,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s@version-info 3:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/libkonq/Makefile.in
${PERL} -pi -e "s@version-info 1:0:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/khelpcenter/Makefile.in
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index f8e6c70e010f..3e2388979c98 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -70,7 +70,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s@version-info 3:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/libkonq/Makefile.in
${PERL} -pi -e "s@version-info 1:0:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/khelpcenter/Makefile.in
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index f8e6c70e010f..3e2388979c98 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -70,7 +70,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s@version-info 3:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/libkonq/Makefile.in
${PERL} -pi -e "s@version-info 1:0:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/khelpcenter/Makefile.in
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index f8e6c70e010f..3e2388979c98 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -70,7 +70,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s@version-info 3:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/libkonq/Makefile.in
${PERL} -pi -e "s@version-info 1:0:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/khelpcenter/Makefile.in
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index f8e6c70e010f..3e2388979c98 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -70,7 +70,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s@version-info 3:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/libkonq/Makefile.in
${PERL} -pi -e "s@version-info 1:0:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/khelpcenter/Makefile.in
diff --git a/x11/kdelibs2/Makefile b/x11/kdelibs2/Makefile
index 0db309ff14e8..c601297c86c3 100644
--- a/x11/kdelibs2/Makefile
+++ b/x11/kdelibs2/Makefile
@@ -85,7 +85,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s@-O2@-O0@g; s@\"-lfam@\"-L${LOCALBASE}/lib -lfam@g" ${WRKSRC}/configure
${PERL} -pi -e "s@kspell api@@g" ${WRKSRC}/doc/Makefile.in
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index 0db309ff14e8..c601297c86c3 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -85,7 +85,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s@-O2@-O0@g; s@\"-lfam@\"-L${LOCALBASE}/lib -lfam@g" ${WRKSRC}/configure
${PERL} -pi -e "s@kspell api@@g" ${WRKSRC}/doc/Makefile.in
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 0db309ff14e8..c601297c86c3 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -85,7 +85,7 @@ pre-configure:
.for AM in automake aclocal
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
.endfor
- cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s@-O2@-O0@g; s@\"-lfam@\"-L${LOCALBASE}/lib -lfam@g" ${WRKSRC}/configure
${PERL} -pi -e "s@kspell api@@g" ${WRKSRC}/doc/Makefile.in