aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-08-24 05:24:06 +0800
committerlioux <lioux@FreeBSD.org>2001-08-24 05:24:06 +0800
commitd97d8d8e9a994fb0c464750abf4cfc13daa9bdf5 (patch)
tree31a0f7a5ab733182e3415b4794d0e34e65418ca9 /x11
parentce08354ff3c37820a3aa9bc5689e723c86600635 (diff)
downloadfreebsd-ports-gnome-d97d8d8e9a994fb0c464750abf4cfc13daa9bdf5.tar.gz
freebsd-ports-gnome-d97d8d8e9a994fb0c464750abf4cfc13daa9bdf5.tar.zst
freebsd-ports-gnome-d97d8d8e9a994fb0c464750abf4cfc13daa9bdf5.zip
o Add a buffer overflow patch in sync with rxvt port Makefile rev
1.49 o Bump PORTREVISION Obtained from: OpenBSD
Diffstat (limited to 'x11')
-rw-r--r--x11/rxvt-devel/Makefile1
-rw-r--r--x11/rxvt-devel/files/patch-src::command.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11/rxvt-devel/Makefile b/x11/rxvt-devel/Makefile
index d7185cfa0c58..ec508610e534 100644
--- a/x11/rxvt-devel/Makefile
+++ b/x11/rxvt-devel/Makefile
@@ -10,6 +10,7 @@
PORTNAME= rxvt-devel
PORTVERSION= 2.7.6
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ftp://ftp.rxvt.org/pub/rxvt/%SUBDIR%/ \
ftp://mason.primenet.com.au/pub/rxvt/%SUBDIR%/ \
diff --git a/x11/rxvt-devel/files/patch-src::command.c b/x11/rxvt-devel/files/patch-src::command.c
new file mode 100644
index 000000000000..6f3e7e9a7bcb
--- /dev/null
+++ b/x11/rxvt-devel/files/patch-src::command.c
@@ -0,0 +1,11 @@
+--- src/command.c.orig Thu Apr 5 03:52:39 2001
++++ src/command.c Fri Jun 22 13:36:57 2001
+@@ -2796,7 +2796,7 @@ rxvt_tt_printf(rxvt_t *r, const char *fm
+ unsigned char buf[256];
+
+ va_start(arg_ptr, fmt);
+- vsprintf(buf, fmt, arg_ptr);
++ vsnprintf(buf, sizeof(buf), fmt, arg_ptr);
+ va_end(arg_ptr);
+ rxvt_tt_write(r, buf, STRLEN(buf));
+ }