aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2015-08-27 20:03:27 +0800
committerehaupt <ehaupt@FreeBSD.org>2015-08-27 20:03:27 +0800
commitef670293de4cd02f015938caaf90de436a3d4c10 (patch)
tree6227901de5550c86a7d958caedaea1ceb154db7a /x11
parentbc196486ae6d98fce28e5d0578baf1b1a5a3d84c (diff)
downloadfreebsd-ports-gnome-ef670293de4cd02f015938caaf90de436a3d4c10.tar.gz
freebsd-ports-gnome-ef670293de4cd02f015938caaf90de436a3d4c10.tar.zst
freebsd-ports-gnome-ef670293de4cd02f015938caaf90de436a3d4c10.zip
Fix utmpx registration
Notified by: Christian Jachmann <Jachmann@unitix.org> Submitted by: Thomas Dickey <dickey@his.com> (author)
Diffstat (limited to 'x11')
-rw-r--r--x11/xterm/Makefile1
-rw-r--r--x11/xterm/files/patch-main.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11/xterm/Makefile b/x11/xterm/Makefile
index 43194de820c6..6977a7443fda 100644
--- a/x11/xterm/Makefile
+++ b/x11/xterm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xterm
PORTVERSION= 319
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ftp://invisible-island.net/xterm/:src1 \
LOCAL/ehaupt:src1 LOCAL/ehaupt:src2
diff --git a/x11/xterm/files/patch-main.c b/x11/xterm/files/patch-main.c
new file mode 100644
index 000000000000..786afabf9593
--- /dev/null
+++ b/x11/xterm/files/patch-main.c
@@ -0,0 +1,11 @@
+--- main.c.orig 2015-08-27 11:22:17 UTC
++++ main.c
+@@ -3679,7 +3679,7 @@ spawnXTerm(XtermWidget xw)
+ added_utmp_entry = False;
+ #if defined(USE_UTEMPTER)
+ #undef UTMP
+- if (xw->misc.login_shell && !resource.utmpInhibit) {
++ if ((xw->misc.login_shell || !command_to_exec) && !resource.utmpInhibit) {
+ struct UTMP_STR dummy;
+
+ /* Note: utempter may trim it anyway */
/+1 * Made math/scilab building on -current againedwin2002-11-151-3/+50 * Substitute PVM_ROOT after patchingpat2002-03-031-0/+2 * - add patches from NetBSD (fixes for ascii(), fft() and the online help)pat2002-01-3016-14/+184 * New ports for scilab 2.6 .sada2001-10-03