aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2010-01-21 17:51:57 +0800
committergarga <garga@FreeBSD.org>2010-01-21 17:51:57 +0800
commit0c2d97fde1074ed6c33de31094622086ec0d2b07 (patch)
tree9a26cfb601646177735e03c029c52bcab0074953 /x11
parent37650080afc0387a83b9bfef57e55c25e6a7b47b (diff)
downloadfreebsd-ports-gnome-0c2d97fde1074ed6c33de31094622086ec0d2b07.tar.gz
freebsd-ports-gnome-0c2d97fde1074ed6c33de31094622086ec0d2b07.tar.zst
freebsd-ports-gnome-0c2d97fde1074ed6c33de31094622086ec0d2b07.zip
Fix build on OSVERSION < 900006
Submitted by: Yuri Pankov <yuri.pankov@gmail.com>
Diffstat (limited to 'x11')
-rw-r--r--x11/gmrun/Makefile10
-rw-r--r--x11/gmrun/files/patch-src__gtkcompletionline.cc9
2 files changed, 10 insertions, 9 deletions
diff --git a/x11/gmrun/Makefile b/x11/gmrun/Makefile
index fbcbd72ca318..767a07f8dc20 100644
--- a/x11/gmrun/Makefile
+++ b/x11/gmrun/Makefile
@@ -30,6 +30,16 @@ PLIST_DIRS= %%DATADIR%%
.include <bsd.port.pre.mk>
+post-patch:
+.if ${OSVERSION} >= 900006
+ @${REINPLACE_CMD} -e '/my_alphasort/s#const void\*#const struct dirent**#g' \
+ ${WRKSRC}/src/gtkcompletionline.cc
+.else
+ @${REINPLACE_CMD} -e '/select_executables_only(const /s#const ##' \
+ ${WRKSRC}/src/gtkcompletionline.cc
+.endif
+
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/x11/gmrun/files/patch-src__gtkcompletionline.cc b/x11/gmrun/files/patch-src__gtkcompletionline.cc
index 9626af5786b5..347dcaab7b7b 100644
--- a/x11/gmrun/files/patch-src__gtkcompletionline.cc
+++ b/x11/gmrun/files/patch-src__gtkcompletionline.cc
@@ -26,15 +26,6 @@
sizeof(GtkCompletionLine),
sizeof(GtkCompletionLineClass),
(GtkClassInitFunc)gtk_completion_line_class_init,
-@@ -376,7 +377,7 @@
- return 0;
- }
-
--int my_alphasort(const void* va, const void* vb) {
-+int my_alphasort(const struct dirent** va, const struct dirent** vb) {
- const struct dirent** a = (const struct dirent**)va;
- const struct dirent** b = (const struct dirent**)vb;
-
@@ -551,10 +552,10 @@
{
string text = gtk_entry_get_text(GTK_ENTRY(object));