aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
commit1ca518c98321627ea34bdaae84c439a2f0df0cdf (patch)
tree526d65e6697f1e03c06ab0d0f901688aa2c4e18d /x11
parent81215f7fb03620d52b441a5714e6af1fb655c743 (diff)
downloadfreebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.gz
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.zst
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.zip
Rely on bsdtar to autodetermine the format of the distfiles when possible
For a while now bsdtar is able to autotermine compression and archive format. Let's then use tar directly instead of piping to tar. Now USE_BZIP2 and USE_XZ only set EXTRACT_SUFX to the right format
Diffstat (limited to 'x11')
-rw-r--r--x11/qt4-graphicssystems-opengl/Makefile1
-rw-r--r--x11/qt4-inputmethods/Makefile1
-rw-r--r--x11/qt4-opengl/Makefile1
3 files changed, 0 insertions, 3 deletions
diff --git a/x11/qt4-graphicssystems-opengl/Makefile b/x11/qt4-graphicssystems-opengl/Makefile
index 34cb8ea9f825..2c104162db26 100644
--- a/x11/qt4-graphicssystems-opengl/Makefile
+++ b/x11/qt4-graphicssystems-opengl/Makefile
@@ -31,7 +31,6 @@ DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
src/3rdparty/clucene src/3rdparty/freetype \
src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
index db24250f1ee9..ec4e34a7dce9 100644
--- a/x11/qt4-inputmethods/Makefile
+++ b/x11/qt4-inputmethods/Makefile
@@ -29,7 +29,6 @@ DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
src/3rdparty/clucene src/3rdparty/freetype \
src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index 5e6bde1b1556..75e747c8039b 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -33,7 +33,6 @@ DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
src/3rdparty/clucene src/3rdparty/freetype \
src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor