aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2010-01-16 02:34:34 +0800
committeroliver <oliver@FreeBSD.org>2010-01-16 02:34:34 +0800
commit2652cd24fd0237da1c6b94c65dec475f136ed616 (patch)
treec16b6ae13b83d77898cfd49fcd97b80b1536a789 /x11
parentff248b85b549ef33d0bac1c455b5ca6a8905855b (diff)
downloadfreebsd-ports-gnome-2652cd24fd0237da1c6b94c65dec475f136ed616.tar.gz
freebsd-ports-gnome-2652cd24fd0237da1c6b94c65dec475f136ed616.tar.zst
freebsd-ports-gnome-2652cd24fd0237da1c6b94c65dec475f136ed616.zip
fix build for FreeBSD 6
Noted By: tabthorpe
Diffstat (limited to 'x11')
-rw-r--r--x11/libexo/Makefile4
-rw-r--r--x11/libexo/files/patch-configure12
-rw-r--r--x11/libexo/files/patch-exo-mount-point.c12
3 files changed, 24 insertions, 4 deletions
diff --git a/x11/libexo/Makefile b/x11/libexo/Makefile
index 5049018b7da3..dd2e6653fed5 100644
--- a/x11/libexo/Makefile
+++ b/x11/libexo/Makefile
@@ -66,8 +66,4 @@ CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|FALSE;;|FALSE;|' ${WRKSRC}/exo/exo-icon-view.c
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
-
.include <bsd.port.post.mk>
diff --git a/x11/libexo/files/patch-configure b/x11/libexo/files/patch-configure
new file mode 100644
index 000000000000..290827fa9ebb
--- /dev/null
+++ b/x11/libexo/files/patch-configure
@@ -0,0 +1,12 @@
+--- configure.orig 2010-01-14 17:33:27.000000000 +0100
++++ configure 2010-01-14 17:35:47.000000000 +0100
+@@ -746,6 +746,9 @@
+ #endif
+ #ifdef HAVE_UNISTD_H
+ # include <unistd.h>
++#endif
++#ifdef __FreeBSD__
++# include <sys/param.h>
+ #endif"
+
+ ac_header_list=
diff --git a/x11/libexo/files/patch-exo-mount-point.c b/x11/libexo/files/patch-exo-mount-point.c
new file mode 100644
index 000000000000..249cbb8c673f
--- /dev/null
+++ b/x11/libexo/files/patch-exo-mount-point.c
@@ -0,0 +1,12 @@
+--- exo/exo-mount-point.c.orig 2010-01-14 17:36:19.000000000 +0100
++++ exo/exo-mount-point.c 2010-01-14 17:36:41.000000000 +0100
+@@ -38,6 +38,9 @@
+ #include <sys/ucred.h>
+ #endif
+ #ifdef HAVE_SYS_MOUNT_H
++#ifdef __FreeBSD__
++#include <sys/param.h>
++#endif
+ #include <sys/mount.h>
+ #endif
+