aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorstefan <stefan@FreeBSD.org>2008-12-27 21:11:29 +0800
committerstefan <stefan@FreeBSD.org>2008-12-27 21:11:29 +0800
commit299ce9cf86794be3d98b6e447d72645567c7b3cf (patch)
tree6b4b487d3926ad4d82717ace07f32fd9aa3ce60d /x11
parentb5718ff7f1840139eb5370c54deb9bcfe2140314 (diff)
downloadfreebsd-ports-gnome-299ce9cf86794be3d98b6e447d72645567c7b3cf.tar.gz
freebsd-ports-gnome-299ce9cf86794be3d98b6e447d72645567c7b3cf.tar.zst
freebsd-ports-gnome-299ce9cf86794be3d98b6e447d72645567c7b3cf.zip
Add xorg-minimal, a meta-port for installing only the necessary part of the
X.Org distribution. PR: 128384 Submitted by: Eitan Adler <EitanAdlerList@gmail.com>
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xorg-minimal/Makefile39
-rw-r--r--x11/xorg-minimal/pkg-descr6
3 files changed, 46 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 38e12979d313..87bf80acb198 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -423,6 +423,7 @@
SUBDIR += xorg-docs
SUBDIR += xorg-edit
SUBDIR += xorg-libraries
+ SUBDIR += xorg-minimal
SUBDIR += xorg-protos
SUBDIR += xphelloworld
SUBDIR += xplsprinters
diff --git a/x11/xorg-minimal/Makefile b/x11/xorg-minimal/Makefile
new file mode 100644
index 000000000000..51dbb257c19b
--- /dev/null
+++ b/x11/xorg-minimal/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: xorg-minimal
+# Date created: 19 Jun 2008
+# Whom: Eitan Adler
+#
+# $FreeBSD$
+#
+
+PORTNAME= xorg
+PORTVERSION= 7.3
+CATEGORIES= x11 x11-servers
+MASTER_SITES= # none
+PKGNAMESUFFIX= -minimal
+DISTFILES= # none
+EXTRACT_ONLY= # none
+
+MAINTAINER= EitanAdlerList@gmail.com
+COMMENT= X.Org minimal distribution metaport
+
+NO_BUILD= yes
+
+RUN_DEPENDS+= ${LOCALBASE}/bin/Xorg:${PORTSDIR}/x11-servers/xorg-server \
+ ${LOCALBASE}/lib/xorg/modules/drivers/vesa_drv.so:${PORTSDIR}/x11-drivers/xf86-video-vesa \
+ ${LOCALBASE}/lib/xorg/modules/input/mouse_drv.so:${PORTSDIR}/x11-drivers/xf86-input-mouse \
+ ${LOCALBASE}/lib/xorg/modules/input/kbd_drv.so:${PORTSDIR}/x11-drivers/xf86-input-keyboard \
+ xinit:${PORTSDIR}/x11/xinit \
+ xauth:${PORTSDIR}/x11/xauth \
+ ${LOCALBASE}/lib/X11/fonts/misc/fonts.alias:${PORTSDIR}/x11-fonts/font-alias \
+ ${LOCALBASE}/lib/X11/fonts/misc/cursor.pcf.gz:${PORTSDIR}/x11-fonts/font-cursor-misc \
+ ${LOCALBASE}/lib/X11/fonts/misc/10x20.pcf.gz:${PORTSDIR}/x11-fonts/font-misc-misc
+
+do-install:
+
+pre-everything::
+ @${ECHO_MSG} "This is a meta-port, meaning that it just depends on its subparts of the port."
+ @${ECHO_MSG} "It won't build and install all the parts until you have typed make install"
+ @${ECHO_MSG} "This port does not ensure things are upgraded; use portmaster if you want to"
+ @${ECHO_MSG} "upgrade X.Org."
+
+.include <bsd.port.mk>
diff --git a/x11/xorg-minimal/pkg-descr b/x11/xorg-minimal/pkg-descr
new file mode 100644
index 000000000000..224a4edf2ae1
--- /dev/null
+++ b/x11/xorg-minimal/pkg-descr
@@ -0,0 +1,6 @@
+This is a metaport for least amount of ports needed to run a X.Org server.
+
+WWW: http://www.x.org/
+
+- Eitan Adler
+EitanAdlerList@gmail.com