aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-07-26 05:33:26 +0800
committermarcus <marcus@FreeBSD.org>2003-07-26 05:33:26 +0800
commit33a3580d8a272aadf46c6909319aafea5a7850c0 (patch)
treebfdd2ddf351d07e869b7a9edb63a0573a29985c4 /x11
parent7ccaaf18a542ca45684c5f04e3b1827c752d9b70 (diff)
downloadfreebsd-ports-gnome-33a3580d8a272aadf46c6909319aafea5a7850c0.tar.gz
freebsd-ports-gnome-33a3580d8a272aadf46c6909319aafea5a7850c0.tar.zst
freebsd-ports-gnome-33a3580d8a272aadf46c6909319aafea5a7850c0.zip
Allow yelp to work when a manpage has been cached into catman.
PR: 54808
Diffstat (limited to 'x11')
-rw-r--r--x11/libgnome/Makefile1
-rw-r--r--x11/libgnome/files/patch-help-converters_man_gnome-man2html.c51
2 files changed, 52 insertions, 0 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index 2c7f51cd54e6..6cae8c0fcb08 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libgnome
PORTVERSION= 2.2.3
+PORTREVISION= 1
CATEGORIES?= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.2
diff --git a/x11/libgnome/files/patch-help-converters_man_gnome-man2html.c b/x11/libgnome/files/patch-help-converters_man_gnome-man2html.c
new file mode 100644
index 000000000000..cdfbd7ca485f
--- /dev/null
+++ b/x11/libgnome/files/patch-help-converters_man_gnome-man2html.c
@@ -0,0 +1,51 @@
+--- help-converters/man/gnome-man2html.c.orig Thu Jul 24 14:06:36 2003
++++ help-converters/man/gnome-man2html.c Thu Jul 24 14:06:06 2003
+@@ -129,6 +129,7 @@
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <dirent.h>
++#include <sys/param.h>
+ #include <sys/types.h>
+ #include <time.h>
+ #include <sys/time.h>
+@@ -3727,6 +3728,9 @@
+ main(int argc, char **argv)
+ {
+ char *t=NULL;
++#ifdef __FreeBSD__
++ char *source=NULL;
++#endif
+ int i,len;
+ char *buf;
+ char *h = '\0';
+@@ -3845,6 +3849,20 @@
+ * right.
+ */
+
++#ifdef __FreeBSD__
++ if ((source = strstr(output, "source: ")) != NULL)
++ {
++ int j;
++ for(i = 8, j = 0; i < strlen(source); i++)
++ {
++ if (!g_ascii_isspace((unsigned char)source[i]) && source[i] != ')')
++ {
++ output[j++] = source[i];
++ }
++ }
++ output[j] = '\0';
++ }
++#else
+ len = strlen(output);
+ for(i = 0; i < len; i++)
+ {
+@@ -3855,8 +3873,7 @@
+ i = strlen(output) - 1;
+ while (g_ascii_isspace((unsigned char)output[i]))
+ output[i--] = '\0';
+-
+-
++#endif
+ if (output[0]) {
+ #ifdef HAVE_LIBBZ2
+ if(strstr(output,".bz2"))