aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-06-06 04:43:07 +0800
committeradamw <adamw@FreeBSD.org>2003-06-06 04:43:07 +0800
commit3b6c3ef7881953c3204d0cb1b21da8ee7d85a0e3 (patch)
treed50b7be012da123d72140920b3239516522543d1 /x11
parent3e9536fa659210c154bb3043ba5355ed82a11d13 (diff)
downloadfreebsd-ports-gnome-3b6c3ef7881953c3204d0cb1b21da8ee7d85a0e3.tar.gz
freebsd-ports-gnome-3b6c3ef7881953c3204d0cb1b21da8ee7d85a0e3.tar.zst
freebsd-ports-gnome-3b6c3ef7881953c3204d0cb1b21da8ee7d85a0e3.zip
Add docker.
Docker is a WindowMaker dockapp that houses GNOME2 and KDE tray icons. The cool thing about docker is that, as a dockapp, it can be used by GNOME2 and KDE also, allowing you to have tray icons without needing the whole GNOME2 or KDE panel. Submitted by: Samy <samy@kerneled.com>
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/docker/Makefile24
-rw-r--r--x11/docker/distinfo1
-rw-r--r--x11/docker/files/patch-Makefile19
-rw-r--r--x11/docker/pkg-descr9
-rw-r--r--x11/docker/pkg-plist1
6 files changed, 55 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index a46306dae51c..483027bc92c1 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -22,6 +22,7 @@
SUBDIR += decurs
SUBDIR += deskmenu
SUBDIR += dgs
+ SUBDIR += docker
SUBDIR += dxpc
SUBDIR += dynamag
SUBDIR += ebuttons
diff --git a/x11/docker/Makefile b/x11/docker/Makefile
new file mode 100644
index 000000000000..bb8b5b119dc7
--- /dev/null
+++ b/x11/docker/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: docker
+# Date created: March 15, 2003
+# Whom: Samy <samy@kerneled.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= docker
+PORTVERSION= 1.5
+CATEGORIES= x11
+MASTER_SITES= http://www.kerneled.com/projects/docker/ \
+ http://icculus.org/openbox/docker/
+
+MAINTAINER= samy@kerneled.com
+COMMENT= A dockapp with support for GNOME2 and KDE3 tray icons
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= glib20
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/docker/distinfo b/x11/docker/distinfo
new file mode 100644
index 000000000000..8387ec62a7d5
--- /dev/null
+++ b/x11/docker/distinfo
@@ -0,0 +1 @@
+MD5 (docker-1.5.tar.gz) = 349320bebd43babb8b43e11c7aae0293
diff --git a/x11/docker/files/patch-Makefile b/x11/docker/files/patch-Makefile
new file mode 100644
index 000000000000..ab9406fa051e
--- /dev/null
+++ b/x11/docker/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig Wed Nov 20 02:20:49 2002
++++ Makefile Thu Jun 5 13:30:53 2003
+@@ -4,13 +4,12 @@
+ # #
+ #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
+
+-# Change this PREFIX to where you want docker to be installed
+-PREFIX=/usr/local
+ # Change this XLIBPATH to point to your X11 development package's installation
+-XLIBPATH=/usr/X11R6/lib
++XLIBPATH=${PREFIX}/lib
++XINC=${PREFIX}/include
+
+ # Sets some flags for stricter compiling
+-CFLAGS=-pedantic -Wall -W -O
++CFLAGS=-Wall -W -I${XINC}
+
+ #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
+ # #
diff --git a/x11/docker/pkg-descr b/x11/docker/pkg-descr
new file mode 100644
index 000000000000..2d7f73c53477
--- /dev/null
+++ b/x11/docker/pkg-descr
@@ -0,0 +1,9 @@
+Docker is a docking application (WindowMaker dock app)
+which acts as a system tray for KDE3 and GNOME2. It can
+be used to replace the panel in either environment,
+allowing you to have a system tray without running the
+KDE/GNOME panel.
+
+WWW: http://icculus.org/openbox/docker/
+
+- Samy <samy@kerneled.com>
diff --git a/x11/docker/pkg-plist b/x11/docker/pkg-plist
new file mode 100644
index 000000000000..0cd79764254c
--- /dev/null
+++ b/x11/docker/pkg-plist
@@ -0,0 +1 @@
+bin/docker