aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-03 20:24:26 +0800
committerbapt <bapt@FreeBSD.org>2013-05-03 20:24:26 +0800
commit4532ccba9560b1cd75495ea05019a3dbb42b8328 (patch)
tree8750231324508086cb75cdcadc02339d878c0c5d /x11
parentc776742e15ddb00f889861d8fe57194744d8863e (diff)
downloadfreebsd-ports-gnome-4532ccba9560b1cd75495ea05019a3dbb42b8328.tar.gz
freebsd-ports-gnome-4532ccba9560b1cd75495ea05019a3dbb42b8328.tar.zst
freebsd-ports-gnome-4532ccba9560b1cd75495ea05019a3dbb42b8328.zip
Fix build with bmake by using gmake if make is bmake
Diffstat (limited to 'x11')
-rw-r--r--x11/ecore-imf_evas/Makefile3
-rw-r--r--x11/ecore-input/Makefile3
-rw-r--r--x11/ecore-input_evas/Makefile3
-rw-r--r--x11/ecore-x11/Makefile3
4 files changed, 12 insertions, 0 deletions
diff --git a/x11/ecore-imf_evas/Makefile b/x11/ecore-imf_evas/Makefile
index 029ba4584dfd..d8ee0b9a9c39 100644
--- a/x11/ecore-imf_evas/Makefile
+++ b/x11/ecore-imf_evas/Makefile
@@ -20,6 +20,9 @@ GNU_CONFIGURE= yes
USE_EFL= ecore evas libtool_hack
USE_EFL_ECORE= imf
USES= pkgconfig
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
USE_LDCONFIG= yes
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_imf_evas
INSTALL_WRKSRC= ${BUILD_WRKSRC}
diff --git a/x11/ecore-input/Makefile b/x11/ecore-input/Makefile
index 51d866c9b5e5..2cddc0806aac 100644
--- a/x11/ecore-input/Makefile
+++ b/x11/ecore-input/Makefile
@@ -23,6 +23,9 @@ USES= pkgconfig
USE_GMAKE= yes
.endif
USE_LDCONFIG= yes
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_input
INSTALL_WRKSRC= ${BUILD_WRKSRC}
diff --git a/x11/ecore-input_evas/Makefile b/x11/ecore-input_evas/Makefile
index b3b0dc78dcbe..125f7357892f 100644
--- a/x11/ecore-input_evas/Makefile
+++ b/x11/ecore-input_evas/Makefile
@@ -20,6 +20,9 @@ GNU_CONFIGURE= yes
USE_EFL= ecore evas libtool_hack
USE_EFL_ECORE= input
USES= pkgconfig
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
USE_LDCONFIG= yes
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_input_evas
INSTALL_WRKSRC= ${BUILD_WRKSRC}
diff --git a/x11/ecore-x11/Makefile b/x11/ecore-x11/Makefile
index fae55a29cb50..5994642e2af0 100644
--- a/x11/ecore-x11/Makefile
+++ b/x11/ecore-x11/Makefile
@@ -17,6 +17,9 @@ LICENSE= BSD
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
USE_EFL= ecore libtool_hack
USE_EFL_ECORE= input
USE_LDCONFIG= yes