aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-06 16:25:43 +0800
committerbapt <bapt@FreeBSD.org>2014-01-06 16:25:43 +0800
commit468ac114a417ff7ed610c98a1dcd3af8f0e9748d (patch)
treed7d6756b6065753f53ad76f8bd2b6cb103de0552 /x11
parent9e01ff2b0b96aa5e48d0ff852ad9961d25878c9c (diff)
downloadfreebsd-ports-gnome-468ac114a417ff7ed610c98a1dcd3af8f0e9748d.tar.gz
freebsd-ports-gnome-468ac114a417ff7ed610c98a1dcd3af8f0e9748d.tar.zst
freebsd-ports-gnome-468ac114a417ff7ed610c98a1dcd3af8f0e9748d.zip
Support stage
Diffstat (limited to 'x11')
-rw-r--r--x11/apwal/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/x11/apwal/Makefile b/x11/apwal/Makefile
index e5ab995440b0..1f0773a707ad 100644
--- a/x11/apwal/Makefile
+++ b/x11/apwal/Makefile
@@ -11,21 +11,19 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Simple and powerful application launcher
USE_GNOME= gtk20 libxml2
-USE_GMAKE= yes
-USES= pkgconfig
+USES= gmake pkgconfig
WRKSRC= ${WRKDIR}/${PORTNAME}/src
PLIST_FILES= bin/apwal bin/apwal-editor
-NO_STAGE= yes
post-patch:
@${CP} ${FILESDIR}/group_member.c ${WRKSRC}
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
${WRKSRC}/cereimg.c ${WRKSRC}/../example/apwalrc.xml
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/apwal ${PREFIX}/bin
- ${LN} -sf ${PREFIX}/bin/apwal ${PREFIX}/bin/apwal-editor
+ ${INSTALL_PROGRAM} ${WRKSRC}/apwal ${STAGEDIR}${PREFIX}/bin
+ ${LN} -sf apwal ${STAGEDIR}${PREFIX}/bin/apwal-editor
.include <bsd.port.mk>