aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-01-05 10:29:15 +0800
committerwill <will@FreeBSD.org>2002-01-05 10:29:15 +0800
commit505481ccf3bef290cc1f4bc479f1301fcdf862b6 (patch)
tree91d4e03368661bbc9e9b31f090129fb7c61b5839 /x11
parent6197c75904d4e9a34849cea83c831f9290990e21 (diff)
downloadfreebsd-ports-gnome-505481ccf3bef290cc1f4bc479f1301fcdf862b6.tar.gz
freebsd-ports-gnome-505481ccf3bef290cc1f4bc479f1301fcdf862b6.tar.zst
freebsd-ports-gnome-505481ccf3bef290cc1f4bc479f1301fcdf862b6.zip
Conditionalize use of objprelink based on whether we're running on
MACHINE_ARCH=i386 *and* whether NO_KDE_OBJPRELINK is defined. Requested by: several
Diffstat (limited to 'x11')
-rw-r--r--x11/kde4-baseapps/Makefile11
-rw-r--r--x11/kde4-runtime/Makefile11
-rw-r--r--x11/kde4-workspace/Makefile11
-rw-r--r--x11/kdebase2/Makefile11
-rw-r--r--x11/kdebase3/Makefile11
-rw-r--r--x11/kdebase4-runtime/Makefile11
-rw-r--r--x11/kdebase4-workspace/Makefile11
-rw-r--r--x11/kdebase4/Makefile11
-rw-r--r--x11/kdelibs2/Makefile12
-rw-r--r--x11/kdelibs3/Makefile12
-rw-r--r--x11/kdelibs4/Makefile12
11 files changed, 88 insertions, 36 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index 1bcf8e3a0c03..017ed4c05b81 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -16,8 +16,10 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -30,7 +32,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
- --without-ldap --disable-closure --enable-objprelink
+ --without-ldap --disable-closure
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 1bcf8e3a0c03..017ed4c05b81 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -16,8 +16,10 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -30,7 +32,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
- --without-ldap --disable-closure --enable-objprelink
+ --without-ldap --disable-closure
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 1bcf8e3a0c03..017ed4c05b81 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -16,8 +16,10 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -30,7 +32,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
- --without-ldap --disable-closure --enable-objprelink
+ --without-ldap --disable-closure
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/x11/kdebase2/Makefile b/x11/kdebase2/Makefile
index 1bcf8e3a0c03..017ed4c05b81 100644
--- a/x11/kdebase2/Makefile
+++ b/x11/kdebase2/Makefile
@@ -16,8 +16,10 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -30,7 +32,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
- --without-ldap --disable-closure --enable-objprelink
+ --without-ldap --disable-closure
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index 1bcf8e3a0c03..017ed4c05b81 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -16,8 +16,10 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -30,7 +32,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
- --without-ldap --disable-closure --enable-objprelink
+ --without-ldap --disable-closure
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index 1bcf8e3a0c03..017ed4c05b81 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -16,8 +16,10 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -30,7 +32,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
- --without-ldap --disable-closure --enable-objprelink
+ --without-ldap --disable-closure
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index 1bcf8e3a0c03..017ed4c05b81 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -16,8 +16,10 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -30,7 +32,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
- --without-ldap --disable-closure --enable-objprelink
+ --without-ldap --disable-closure
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index 1bcf8e3a0c03..017ed4c05b81 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -16,8 +16,10 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=2
@@ -30,7 +32,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-qt-dir=${X11BASE} \
- --without-ldap --disable-closure --enable-objprelink
+ --without-ldap --disable-closure
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/x11/kdelibs2/Makefile b/x11/kdelibs2/Makefile
index c601297c86c3..535555273fed 100644
--- a/x11/kdelibs2/Makefile
+++ b/x11/kdelibs2/Makefile
@@ -15,8 +15,10 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= automake14:${PORTSDIR}/devel/automake14 \
- autoconf213:${PORTSDIR}/devel/autoconf213 \
- objprelink:${PORTSDIR}/devel/objprelink
+ autoconf213:${PORTSDIR}/devel/autoconf213
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
fam.0:${PORTSDIR}/devel/fam \
@@ -35,8 +37,10 @@ SOMINOR= 0
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--enable-cups --disable-ltdl-install \
- --enable-objprelink
+CONFIGURE_ARGS+=--enable-cups --disable-ltdl-install
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index c601297c86c3..535555273fed 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -15,8 +15,10 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= automake14:${PORTSDIR}/devel/automake14 \
- autoconf213:${PORTSDIR}/devel/autoconf213 \
- objprelink:${PORTSDIR}/devel/objprelink
+ autoconf213:${PORTSDIR}/devel/autoconf213
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
fam.0:${PORTSDIR}/devel/fam \
@@ -35,8 +37,10 @@ SOMINOR= 0
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--enable-cups --disable-ltdl-install \
- --enable-objprelink
+CONFIGURE_ARGS+=--enable-cups --disable-ltdl-install
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index c601297c86c3..535555273fed 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -15,8 +15,10 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= automake14:${PORTSDIR}/devel/automake14 \
- autoconf213:${PORTSDIR}/devel/autoconf213 \
- objprelink:${PORTSDIR}/devel/objprelink
+ autoconf213:${PORTSDIR}/devel/autoconf213
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
fam.0:${PORTSDIR}/devel/fam \
@@ -35,8 +37,10 @@ SOMINOR= 0
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--enable-cups --disable-ltdl-install \
- --enable-objprelink
+CONFIGURE_ARGS+=--enable-cups --disable-ltdl-install
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif