aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-01 13:27:46 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-01 13:27:46 +0800
commit7bdbfd99da4fc2baae80c9663843ec6299df5c0f (patch)
tree99c39a302c8e06f1a8bf3e119e586520fbcf0117 /x11
parent09fe516169f13f9c072476b3ca1c482175f61daa (diff)
downloadfreebsd-ports-gnome-7bdbfd99da4fc2baae80c9663843ec6299df5c0f.tar.gz
freebsd-ports-gnome-7bdbfd99da4fc2baae80c9663843ec6299df5c0f.tar.zst
freebsd-ports-gnome-7bdbfd99da4fc2baae80c9663843ec6299df5c0f.zip
x11/antimicro: unbreak with clang 4.0
src/mainwindow.cpp:367:19: error: ordered comparison between pointer and zero ('QMap<SDL_JoystickID, InputDevice *> *' (aka 'QMap<int, InputDevice *> *') and 'int') if (joysticks > 0) ~~~~~~~~~ ^ ~ PR: 216358 Reported by: antoine (via exp-run)
Diffstat (limited to 'x11')
-rw-r--r--x11/antimicro/Makefile1
-rw-r--r--x11/antimicro/files/patch-src_mainwindow.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11/antimicro/Makefile b/x11/antimicro/Makefile
index 13db9cbcb24c..4e2280b93904 100644
--- a/x11/antimicro/Makefile
+++ b/x11/antimicro/Makefile
@@ -3,6 +3,7 @@
PORTNAME= antimicro
PORTVERSION= 2.23
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= ports@FreeBSD.org
diff --git a/x11/antimicro/files/patch-src_mainwindow.cpp b/x11/antimicro/files/patch-src_mainwindow.cpp
new file mode 100644
index 000000000000..f6142e195cb0
--- /dev/null
+++ b/x11/antimicro/files/patch-src_mainwindow.cpp
@@ -0,0 +1,11 @@
+--- src/mainwindow.cpp.orig 2016-11-06 01:23:03 UTC
++++ src/mainwindow.cpp
+@@ -364,7 +364,7 @@ void MainWindow::makeJoystickTabs()
+ ui->tabWidget->addTab(tabwidget, joytabName);
+ }
+
+- if (joysticks > 0)
++ if (joysticks->size() > 0)
+ {
+ ui->tabWidget->setCurrentIndex(0);
+ ui->stackedWidget->setCurrentIndex(1);