aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-03-20 22:20:32 +0800
committermiwi <miwi@FreeBSD.org>2010-03-20 22:20:32 +0800
commit8f8385125ddfcf06ce4371ad8f512aeeedb0bccb (patch)
tree0d81245af6ff3929205cda3b458d31553bfe62f4 /x11
parentb9ef8a77931f95fa56367fa0285966fc0082055d (diff)
downloadfreebsd-ports-gnome-8f8385125ddfcf06ce4371ad8f512aeeedb0bccb.tar.gz
freebsd-ports-gnome-8f8385125ddfcf06ce4371ad8f512aeeedb0bccb.tar.zst
freebsd-ports-gnome-8f8385125ddfcf06ce4371ad8f512aeeedb0bccb.zip
- Mark BROKEN on HEAD: fails to build with new utmpx
Reported by: pointyhat
Diffstat (limited to 'x11')
-rw-r--r--x11/aterm/Makefile8
-rw-r--r--x11/e17-module-uptime/Makefile8
-rw-r--r--x11/emu/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/x11/aterm/Makefile b/x11/aterm/Makefile
index 01d82b9d7560..58c32d4061e0 100644
--- a/x11/aterm/Makefile
+++ b/x11/aterm/Makefile
@@ -23,6 +23,12 @@ CONFIGURE_ARGS+= --enable-transparency \
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if !defined(WITHOUT_BACKGROUND_IMAGE)
LIB_DEPENDS+= AfterImage.0:${PORTSDIR}/graphics/libafterimage
CONFIGURE_ARGS+= --enable-background-image
@@ -71,4 +77,4 @@ MAN1= aterm.1
post-install:
@${CHMOD} 4711 ${PREFIX}/bin/aterm
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/e17-module-uptime/Makefile b/x11/e17-module-uptime/Makefile
index b98d0395315b..21059067e9fa 100644
--- a/x11/e17-module-uptime/Makefile
+++ b/x11/e17-module-uptime/Makefile
@@ -25,6 +25,12 @@ USE_GMAKE= yes
USE_GNOME= gnometarget pkgconfig
USE_EFL= edje
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
@@ -33,4 +39,4 @@ CONFIGURE_ARGS= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/emu/Makefile b/x11/emu/Makefile
index 0a6e29ae0ea1..ba6dc3fcd647 100644
--- a/x11/emu/Makefile
+++ b/x11/emu/Makefile
@@ -24,6 +24,12 @@ USE_DISPLAY= yes
WRKSRC= ${WRKDIR}/emu
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if (!defined(DISPLAY) || ${DISPLAY} == "") && !defined(PACKAGE_BUILDING)
IGNORE= requires an active X session (and DISPLAY variable) to run xrdb. Please compile this while running X
.endif
@@ -33,4 +39,4 @@ MAN1= emu.1
pre-configure:
cd ${WRKSRC}/client ; ${LN} -s ../doc/emu.man .
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>