aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorstefan <stefan@FreeBSD.org>2013-05-15 00:16:40 +0800
committerstefan <stefan@FreeBSD.org>2013-05-15 00:16:40 +0800
commit986d6b765b51f1b290777e64a969a1b05889f1f7 (patch)
tree088ca9febeb4f50305688844e119588f6757e6af /x11
parente6571a3d012b4a71dce695ac49cc91257e6263be (diff)
downloadfreebsd-ports-gnome-986d6b765b51f1b290777e64a969a1b05889f1f7.tar.gz
freebsd-ports-gnome-986d6b765b51f1b290777e64a969a1b05889f1f7.tar.zst
freebsd-ports-gnome-986d6b765b51f1b290777e64a969a1b05889f1f7.zip
- Fix conflict/build failure with png by using libgfx from the ports tree
instead of the bundled one. - Fix build with new compilers. - Remove gmake dependency. PR: 178600 Submitted by: "Mikhail T." <mi@aldan.algebra.com>
Diffstat (limited to 'x11')
-rw-r--r--x11/fireflies/Makefile13
-rw-r--r--x11/fireflies/files/patch-Make.include.in4
-rw-r--r--x11/fireflies/files/patch-Makefile22
-rw-r--r--x11/fireflies/files/patch-src-main.cc13
-rw-r--r--x11/fireflies/files/patch-warnings43
5 files changed, 64 insertions, 31 deletions
diff --git a/x11/fireflies/Makefile b/x11/fireflies/Makefile
index fbe65c947d6d..4155efabc742 100644
--- a/x11/fireflies/Makefile
+++ b/x11/fireflies/Makefile
@@ -3,18 +3,19 @@
PORTNAME= fireflies
PORTVERSION= 2.07
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11
MASTER_SITES= http://somewhere.fscked.org/proj/fireflies/files/
MAINTAINER= umeno@rr.iij4u.or.jp
COMMENT= Extension of xscreensaver
-CONFLICTS= png-[0-9]*
+LIB_DEPENDS= gfx:${PORTSDIR}/graphics/libgfx
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_GL= yes
+EXTRACT_AFTER_ARGS=--exclude '${DISTNAME}/libgfx*'
+MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/GL
LDFLAGS+= -L${LOCALBASE}/lib
@@ -26,10 +27,4 @@ MAKE_ARGS= CONFIGURE_ENV=${CONFIGURE_ENV:Q} \
CONFIGURE_SCRIPT=${CONFIGURE_SCRIPT:Q} \
CONFIGURE_ARGS=${CONFIGURE_ARGS:Q}
-post-extract:
- @(cd ${WRKSRC}; ${TAR} zxpf libgfx-1.0.1.tar.gz)
-
-post-patch:
- @${REINPLACE_CMD} -e 's|fltk|ignored-&|' ${WRKSRC}/libgfx/configure
-
.include <bsd.port.mk>
diff --git a/x11/fireflies/files/patch-Make.include.in b/x11/fireflies/files/patch-Make.include.in
index 059278411157..d7a8817262d8 100644
--- a/x11/fireflies/files/patch-Make.include.in
+++ b/x11/fireflies/files/patch-Make.include.in
@@ -6,8 +6,8 @@
-CFLAGS = -Wall -I../libgfx/include/ $(SDL_CFLAGS) @CFLAGS@
-LIBS = ../libgfx/src/libgfx.a $(GL_LIBS) $(SDL_LIBS) $(OPT_LIBS) @LIBS@
-+CFLAGS = -Wall -I$(LOCALBASE)/include -I../libgfx/include/ $(SDL_CFLAGS) @CFLAGS@
-+LIBS = ../libgfx/src/libgfx.a $(SDL_LIBS) $(OPT_LIBS) -L$(LOCALBASE)/lib $(GL_LIBS) @LIBS@
++CFLAGS = -Wall -I$(LOCALBASE)/include $(SDL_CFLAGS) @CFLAGS@
++LIBS = $(SDL_LIBS) $(OPT_LIBS) -L$(LOCALBASE)/lib -lgfx $(GL_LIBS) @LIBS@ -lX11
OBJECTS = arrow.o bait.o firefly.o scene.o tail.o utils.o modes.o @OPT_OBJS@
PROGRAM = @PROGRAM@
diff --git a/x11/fireflies/files/patch-Makefile b/x11/fireflies/files/patch-Makefile
index e69b95afcfa1..eacff238ea51 100644
--- a/x11/fireflies/files/patch-Makefile
+++ b/x11/fireflies/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig Tue May 6 15:00:40 2003
+--- Makefile Tue May 6 15:00:40 2003
+++ Makefile Tue Dec 5 16:44:03 2006
@@ -1,4 +1,4 @@
-include Make.include
@@ -6,26 +6,12 @@
DISTFILES=\
add-xscreensaver \
-@@ -21,18 +21,17 @@
+@@ -21,6 +21,6 @@
win32/
- all: libgfx/src/libgfx.a
+-all: libgfx/src/libgfx.a
- cd src && make
++all:
+ cd src && ${MAKE}
libgfx/src/libgfx.a:
-- gunzip -c libgfx-1.0.1.tar.gz | tar x
-- cd libgfx && ./configure && cd src && make
-+ cd libgfx && ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS} && cd src && ${MAKE}
-
- install: all
- sh ./installit $(DESTDIR)
-
- clean:
-- make -C src clean
-- make -C win32 clean
-+ ${MAKE} -C src clean
-+ ${MAKE} -C win32 clean
-
- dist:
- rm -rf fireflies-$(VERSION)
diff --git a/x11/fireflies/files/patch-src-main.cc b/x11/fireflies/files/patch-src-main.cc
index ac5a0404043b..5462ba66cb26 100644
--- a/x11/fireflies/files/patch-src-main.cc
+++ b/x11/fireflies/files/patch-src-main.cc
@@ -1,5 +1,5 @@
---- src/main.cc.orig Tue Jun 24 05:55:04 2003
-+++ src/main.cc Wed Feb 15 02:32:39 2006
+--- src/main.cc 2003-06-23 16:55:04.000000000 -0400
++++ src/main.cc 2013-05-13 14:24:28.000000000 -0400
@@ -15,8 +15,10 @@
#ifdef WIN32
#include <windows.h>
@@ -20,3 +20,12 @@
// mingw doesn't have argp. implement half-assed version
#define OPTION_HIDDEN 1
+@@ -187,7 +189,7 @@
+ #define OPT_FPS 2
+ #define OPT_FASTFORWARD 3
+
+-char *mode_help =
++const char *mode_help =
+ "\n"
+ "Per-swarm modes and their default probabilities:\n"
+ " 1: normal p=20\n"
diff --git a/x11/fireflies/files/patch-warnings b/x11/fireflies/files/patch-warnings
new file mode 100644
index 000000000000..17fee0115455
--- /dev/null
+++ b/x11/fireflies/files/patch-warnings
@@ -0,0 +1,43 @@
+--- src/canvas_sdl.h 2003-04-26 14:01:42.000000000 -0400
++++ src/canvas_sdl.h 2013-05-13 14:28:04.000000000 -0400
+@@ -10,11 +10,11 @@
+ protected:
+ SDL_Surface *surface;
+- char *wm_title;
+- char *wm_class;
++ const char *wm_title;
++ const char *wm_class;
+
+ // create the window (either SDL or GLX)
+ virtual int create_window();
+ public:
+- CanvasSDL(Scene *s, bool full_screen, int mspf, char *wm_title, char *wm_class);
++ CanvasSDL(Scene *s, bool full_screen, int mspf, const char *wm_title, const char *wm_class);
+ virtual ~CanvasSDL() {}
+
+--- src/canvas_sdl.cc 2004-02-05 16:58:24.000000000 -0500
++++ src/canvas_sdl.cc 2013-05-13 14:27:03.000000000 -0400
+@@ -10,5 +10,5 @@
+ using namespace std;
+
+-CanvasSDL::CanvasSDL(Scene *s, bool fs, int m, char *t, char *c)
++CanvasSDL::CanvasSDL(Scene *s, bool fs, int m, const char *t, const char *c)
+ : CanvasBase(s, fs, m), wm_title(t), wm_class(c)
+ {
+--- src/vroot.h 2005-12-08 22:07:30.000000000 -0500
++++ src/vroot.h 2013-05-13 14:30:56.000000000 -0400
+@@ -82,4 +82,5 @@
+ #include <X11/Xatom.h>
+ #include <X11/Xlib.h>
++#include <stdio.h> /* For sscanf */
+
+ static Window
+@@ -96,7 +97,6 @@
+ Display *dpy = DisplayOfScreen(screen);
+ Atom __SWM_VROOT = None;
+- int i;
+ Window rootReturn, parentReturn, *children;
+- unsigned int numChildren;
++ unsigned int i, numChildren;
+
+ /* first check for a hex or decimal window ID in the environment */