aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2015-03-09 01:33:11 +0800
committerolivierd <olivierd@FreeBSD.org>2015-03-09 01:33:11 +0800
commitaa72cb0c20e394a49ae3be7a5b4dd1f68a4a7743 (patch)
tree4d7a6814044f4ee0c003c03740a1f77641e726cb /x11
parent00d87313494612dbda0c283aa417161a11d8c3f4 (diff)
downloadfreebsd-ports-gnome-aa72cb0c20e394a49ae3be7a5b4dd1f68a4a7743.tar.gz
freebsd-ports-gnome-aa72cb0c20e394a49ae3be7a5b4dd1f68a4a7743.tar.zst
freebsd-ports-gnome-aa72cb0c20e394a49ae3be7a5b4dd1f68a4a7743.zip
- Fix missing Gtk stock icons
- Bump PORTREVISION
Diffstat (limited to 'x11')
-rw-r--r--x11/xfce4-dashboard/Makefile6
-rw-r--r--x11/xfce4-dashboard/files/patch-src_applications-view.c11
-rw-r--r--x11/xfce4-dashboard/files/patch-src_search-view.c11
-rw-r--r--x11/xfce4-dashboard/files/patch-src_windows-view.c11
4 files changed, 38 insertions, 1 deletions
diff --git a/x11/xfce4-dashboard/Makefile b/x11/xfce4-dashboard/Makefile
index 098c777c8c11..bdc0f454d0aa 100644
--- a/x11/xfce4-dashboard/Makefile
+++ b/x11/xfce4-dashboard/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dashboard
PORTVERSION= 0.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 xfce
MASTER_SITES= http://xfdashboard.froevel.de/releases/
PKGNAMEPREFIX= xfce4-
@@ -28,4 +28,8 @@ USE_XORG= x11 xcomposite xdamage
USE_GL= gl
INSTALLS_ICONS= yes
+post-patch:
+ ${FIND} ${WRKSRC}/data/themes -type f -name '*.css' \
+ | ${XARGS} ${REINPLACE_CMD} -i "" 's|gtk-home|go-home|'
+
.include <bsd.port.mk>
diff --git a/x11/xfce4-dashboard/files/patch-src_applications-view.c b/x11/xfce4-dashboard/files/patch-src_applications-view.c
new file mode 100644
index 000000000000..b065a61c2633
--- /dev/null
+++ b/x11/xfce4-dashboard/files/patch-src_applications-view.c
@@ -0,0 +1,11 @@
+--- src/applications-view.c.orig 2014-08-26 15:48:00 UTC
++++ src/applications-view.c
+@@ -949,7 +949,7 @@ static void xfdashboard_applications_vie
+ /* Set up view */
+ xfdashboard_view_set_internal_name(XFDASHBOARD_VIEW(self), "applications");
+ xfdashboard_view_set_name(XFDASHBOARD_VIEW(self), _("Applications"));
+- xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), GTK_STOCK_HOME);
++ xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), "go-home");
+
+ /* Set up actor */
+ xfdashboard_actor_set_can_focus(XFDASHBOARD_ACTOR(self), TRUE);
diff --git a/x11/xfce4-dashboard/files/patch-src_search-view.c b/x11/xfce4-dashboard/files/patch-src_search-view.c
new file mode 100644
index 000000000000..b0a22208012c
--- /dev/null
+++ b/x11/xfce4-dashboard/files/patch-src_search-view.c
@@ -0,0 +1,11 @@
+--- src/search-view.c.orig 2014-08-26 15:48:00 UTC
++++ src/search-view.c
+@@ -1052,7 +1052,7 @@ static void xfdashboard_search_view_init
+ /* Set up view (Note: Search view is disabled by default!) */
+ xfdashboard_view_set_internal_name(XFDASHBOARD_VIEW(self), "search");
+ xfdashboard_view_set_name(XFDASHBOARD_VIEW(self), _("Search"));
+- xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), GTK_STOCK_FIND);
++ xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), "edit-find");
+ xfdashboard_view_set_enabled(XFDASHBOARD_VIEW(self), FALSE);
+
+ /* Set up actor */
diff --git a/x11/xfce4-dashboard/files/patch-src_windows-view.c b/x11/xfce4-dashboard/files/patch-src_windows-view.c
new file mode 100644
index 000000000000..6f4c0e305ba5
--- /dev/null
+++ b/x11/xfce4-dashboard/files/patch-src_windows-view.c
@@ -0,0 +1,11 @@
+--- src/windows-view.c.orig 2014-08-26 15:48:01 UTC
++++ src/windows-view.c
+@@ -87,7 +87,7 @@ static XfdashboardLiveWindow* _xfdashboa
+ static void _xfdashboard_windows_view_set_active_workspace(XfdashboardWindowsView *self, XfdashboardWindowTrackerWorkspace *inWorkspace);
+
+ /* IMPLEMENTATION: Private variables and methods */
+-#define DEFAULT_VIEW_ICON GTK_STOCK_FULLSCREEN
++#define DEFAULT_VIEW_ICON "view-fullscreen"
+ #define DEFAULT_DRAG_HANDLE_SIZE 32.0f
+
+ /* Check if window should be shown */