aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2013-05-09 00:05:21 +0800
committerolivierd <olivierd@FreeBSD.org>2013-05-09 00:05:21 +0800
commitb361f56db83ce9748463f9175d17796a5e4fd5b0 (patch)
treec26ffb804332112a7d1e11a92de398c5b69a2462 /x11
parentccc38469f37cea6408376875be95f9ff4f72f328 (diff)
downloadfreebsd-ports-gnome-b361f56db83ce9748463f9175d17796a5e4fd5b0.tar.gz
freebsd-ports-gnome-b361f56db83ce9748463f9175d17796a5e4fd5b0.tar.zst
freebsd-ports-gnome-b361f56db83ce9748463f9175d17796a5e4fd5b0.zip
- Bump PORTREVISION after update of x11/libxfce4util, and x11-wm/xfce4-panel
While I'm here, - Finish to convert USES - Trim Makefile header - Remove ABI version in LIB_DEPENDS - Remove desktopfileutils, because MimeType entry is not present in desktop file
Diffstat (limited to 'x11')
-rw-r--r--x11/xfce4-clipman-plugin/Makefile13
-rw-r--r--x11/xfce4-clipman-plugin/pkg-plist2
-rw-r--r--x11/xfce4-quicklauncher-plugin/Makefile13
-rw-r--r--x11/xfce4-screenshooter-plugin/Makefile2
-rw-r--r--x11/xfce4-verve-plugin/Makefile2
-rw-r--r--x11/xfce4-wmdock-plugin/Makefile11
6 files changed, 16 insertions, 27 deletions
diff --git a/x11/xfce4-clipman-plugin/Makefile b/x11/xfce4-clipman-plugin/Makefile
index 850a4ad22ec1..8773235964ae 100644
--- a/x11/xfce4-clipman-plugin/Makefile
+++ b/x11/xfce4-clipman-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xfce4-clipman-plugin
PORTVERSION= 1.2.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -21,14 +21,14 @@ UNIQUE_DESC= Enable Unique (single instance) support
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gtk20 intltool intlhack glib20 desktopfileutils
+USE_GNOME= gtk20 intltool intlhack glib20
USE_XFCE= configenv libexo libmenu libutil panel xfconf
USE_XORG= xtst
-USES= pkgconfig gettext
+USES= pkgconfig gettext pathfix
INSTALLS_ICONS= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MUNIQUE}
LIB_DEPENDS+= unique-1:${PORTSDIR}/x11-toolkits/unique
@@ -37,7 +37,4 @@ CONFIGURE_ARGS+= --enable-unique
CONFIGURE_ARGS+= --disable-unique
.endif
-post-install:
- @-update-desktop-database
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/xfce4-clipman-plugin/pkg-plist b/x11/xfce4-clipman-plugin/pkg-plist
index 6d2615c090db..16bcf17af090 100644
--- a/x11/xfce4-clipman-plugin/pkg-plist
+++ b/x11/xfce4-clipman-plugin/pkg-plist
@@ -129,5 +129,3 @@ share/xfce4/panel/plugins/xfce4-clipman-plugin.desktop
@dirrmtry lib/xfce4/panel
@dirrmtry etc/xdg/xfce4/panel
@dirrmtry etc/xdg/xfce4
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
diff --git a/x11/xfce4-quicklauncher-plugin/Makefile b/x11/xfce4-quicklauncher-plugin/Makefile
index 216f3f91033f..2b517f2a2628 100644
--- a/x11/xfce4-quicklauncher-plugin/Makefile
+++ b/x11/xfce4-quicklauncher-plugin/Makefile
@@ -1,16 +1,13 @@
-# New ports collection makefile for: quicklauncher plugin for xfce4
-# Date created: 29 April 2006
-# Whom: Martin Wilke (miwi@FreeBSD.org)
-#
+# Created by: Martin Wilke (miwi@FreeBSD.org)
# $FreeBSD$
#
PORTNAME= xfce4-quicklauncher-plugin
PORTVERSION= 1.9.4
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR=/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITE_SUBDIR=src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
@@ -18,9 +15,9 @@ COMMENT= Quicklauncher plugin for Xfce
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USES= gettext
+USES= gettext pkgconfig
USE_GMAKE= yes
-USE_GNOME= gtk20 intltool intlhack pkgconfig
+USE_GNOME= gtk20 intltool intlhack
USE_XFCE= configenv libgui panel
.include <bsd.port.mk>
diff --git a/x11/xfce4-screenshooter-plugin/Makefile b/x11/xfce4-screenshooter-plugin/Makefile
index 85f2c8d570b0..6760ecbd63ab 100644
--- a/x11/xfce4-screenshooter-plugin/Makefile
+++ b/x11/xfce4-screenshooter-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xfce4-screenshooter-plugin
PORTVERSION= 1.8.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=src/apps/xfce4-screenshooter/${PORTVERSION:R}
diff --git a/x11/xfce4-verve-plugin/Makefile b/x11/xfce4-verve-plugin/Makefile
index f61194d9b24a..abce467dbb0d 100644
--- a/x11/xfce4-verve-plugin/Makefile
+++ b/x11/xfce4-verve-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= verve-plugin
PORTVERSION= 1.0.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=src/panel-plugins/${PKGNAMEPREFIX}${PORTNAME}/${PORTVERSION:R}
diff --git a/x11/xfce4-wmdock-plugin/Makefile b/x11/xfce4-wmdock-plugin/Makefile
index a57a0d595553..995637b5f437 100644
--- a/x11/xfce4-wmdock-plugin/Makefile
+++ b/x11/xfce4-wmdock-plugin/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: xfce4-wmdock-plugin
-# Date created: 7 September 2007
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
#
PORTNAME= xfce4-wmdock-plugin
PORTVERSION= 0.3.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 xfce
MASTER_SITES= http://www.ibh.de/~ellguth/develop/
@@ -16,10 +13,10 @@ COMMENT= WMdock plugin for Xfce
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USES= gettext
+USES= gettext pkgconfig
INSTALLS_ICONS= yes
USE_GMAKE= yes
-USE_GNOME= gtk20 intltool intlhack pkgconfig libwnck
+USE_GNOME= gtk20 intltool intlhack libwnck
USE_XFCE= configenv libgui panel
INSTALLS_ICONS= yes