aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-02-12 22:20:32 +0800
committermiwi <miwi@FreeBSD.org>2010-02-12 22:20:32 +0800
commitbd3eed898b037c62b5e780eb6870a1593b2b5373 (patch)
tree32daaa186403fcc477e05e1eaf6d3ada7028673d /x11
parent8af982196d85c15c8b206f0f85c981daf360da64 (diff)
downloadfreebsd-ports-gnome-bd3eed898b037c62b5e780eb6870a1593b2b5373.tar.gz
freebsd-ports-gnome-bd3eed898b037c62b5e780eb6870a1593b2b5373.tar.zst
freebsd-ports-gnome-bd3eed898b037c62b5e780eb6870a1593b2b5373.zip
- Update to 0.8.0
PR: 143818 Submitted by: Ports Fury
Diffstat (limited to 'x11')
-rw-r--r--x11/stalonetray/Makefile3
-rw-r--r--x11/stalonetray/distinfo6
-rw-r--r--x11/stalonetray/files/patch-src__main.c16
3 files changed, 20 insertions, 5 deletions
diff --git a/x11/stalonetray/Makefile b/x11/stalonetray/Makefile
index dcc31438c594..59f925694275 100644
--- a/x11/stalonetray/Makefile
+++ b/x11/stalonetray/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= stalonetray
-PORTVERSION= 0.7.6
+PORTVERSION= 0.8.0
CATEGORIES= x11
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -15,7 +15,6 @@ COMMENT= STAnd-aLONE system tray
USE_BZIP2= yes
USE_XORG= xpm
-USE_GNOME= gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-native-kde \
--disable-debug
diff --git a/x11/stalonetray/distinfo b/x11/stalonetray/distinfo
index 65a7193c1520..87e11abaa9e7 100644
--- a/x11/stalonetray/distinfo
+++ b/x11/stalonetray/distinfo
@@ -1,3 +1,3 @@
-MD5 (stalonetray-0.7.6.tar.bz2) = eebb46182b64d75b89776bbfc867f470
-SHA256 (stalonetray-0.7.6.tar.bz2) = 35043df77437b66ade4a07b69f31aaa8c157ddc2833899eeb8a4794399a9e061
-SIZE (stalonetray-0.7.6.tar.bz2) = 133973
+MD5 (stalonetray-0.8.0.tar.bz2) = b2ce0d8044f7dc76ac9971def1faab37
+SHA256 (stalonetray-0.8.0.tar.bz2) = 6a561117b6de83c708d3773c98d9546e2227d9dbe404dabbd196c6aa6fa59431
+SIZE (stalonetray-0.8.0.tar.bz2) = 147004
diff --git a/x11/stalonetray/files/patch-src__main.c b/x11/stalonetray/files/patch-src__main.c
new file mode 100644
index 000000000000..6e7a13fbbfc6
--- /dev/null
+++ b/x11/stalonetray/files/patch-src__main.c
@@ -0,0 +1,16 @@
+--- src/main.c.orig 2009-10-21 23:07:11.000000000 +0900
++++ src/main.c 2010-01-21 01:15:42.000000000 +0900
+@@ -323,9 +323,13 @@
+ #endif
+ /* React on WM (re)starts */
+ if (ev.atom == XInternAtom(tray_data.dpy, _NET_SUPPORTING_WM_CHECK, False)) {
++#ifdef DEBUG
+ ewmh_list_supported_atoms(tray_data.dpy);
++#endif
+ tray_set_wm_hints();
++#ifndef NO_NATIVE_KDE
+ kde_tray_update_fallback_mode(tray_data.dpy);
++#endif
+ }
+ /* React on _XEMBED_INFO changes of embedded icons
+ * (currently used to track icon visibility status) */
>- needs XWindowServerKitdinoex2012-02-191-0/+3 * - fix build with gcc46dinoex2012-02-191-0/+10 * Remove gratitutous version number from LIB_DEPENDS where not required.eadler2012-02-191-1/+1 * Fix docbook dependency - s/docbook-450/docbook-xml-450/garga2012-02-181-1/+2 * After just 7 short years, a new release of WindowMaker, 0.95.2dougb2012-02-1820-1054/+126 * - Add missing imlib2 dependency and add a knob WITHOUT_IMLIB tonovel2012-02-171-0/+7 * - Bump PORTREVISION to chase the update of multimedia/libvpxashish2012-02-162-0/+2 * - Update to 6.0jgh2012-02-152-5/+5 * - Please welcome GHC 7.0.4pgj2012-02-132-2/+2 * - convert to using PYTHON_SITELIBDIR (non-functional change)rm2012-02-131-85/+85 * - Update to 0.11.0jgh2012-02-106-44/+38 * Add distfiles sources.cy2012-02-081-1/+5 * - Chase libmpd shlib bumpmiwi2012-02-061-1/+2 * Update 2.6.3 --> 2.6.4.cy2012-02-032-3/+3 * Remove expired port:rene2012-02-038-812/+0 * Add file I forgot to add in the last commiteadler2012-01-291-0/+73 * - Enable XINERAMA by default - it has no extra dependseadler2012-01-291-4/+14 * - Update to 4.1.2dhn2012-01-292-4/+3 * Move these ports from libungif to giflib since that seems to be the consensusdougb2012-01-282-2/+2 * - Update WWWnovel2012-01-251-2/+2 * update lang/sbcl to 1.0.55, and adjust dependent portsbf2012-01-241-1/+1 * At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450eadler2012-01-223-3/+3 * Remove license infodougb2012-01-202-4/+0 * - fix runtime by correcting typorm2012-01-182-2/+4 * - Pass maintainership to submittercrees2012-01-1710-34/+60 * - Remove X11BASEpav2012-01-172-6/+6 * Adjust necesary ports to build with xcb-util 0.3.8garga2012-01-156-10/+181 * - Update to 4.8.3miwi2012-01-153-9/+7 * - update to 0.1.14bapt2012-01-102-3/+3 * - patch potential amd64 problem with assuming long is 32bitsscheidell2012-01-102-0/+12 * - update to 3.8.1rm2012-01-083-33/+4 * - Remove this tray port, a product of repocopy from x11-wm/stumpwm.pav2012-01-044-284/+0 * - Fix build with gcc46crees2011-12-292-27/+22 * - Fix build on 7.xdhn2011-12-282-4/+25 * - X11BASE is going away. Hack the last few ports that depend on X11BASE to no...eadler2011-12-261-0/+1 * - Update to 4.1.1dhn2011-12-252-4/+3 * Mark as broken on sparc64 as well (and, presumably, ia64).linimon2011-12-221-2/+2 * Mark as broke on sparc64-9: fails to compile.linimon2011-12-221-1/+7 * - Bump PORTREVISION for x11/libxdg-basedir shlib changesunpoet2011-12-151-2/+2 * Fix build with clang.novel2011-12-152-3/+23 * - Fix runtime crash on amd64novel2011-12-131-2/+11 * Remove according to deprecation schedule: Abandonware: no more upstream,linimon2011-12-104-53/+0 * update lang/sbcl to 1.0.54, and adjust dependent ports (this allows sbcl tobf2011-12-092-2/+2 * - Mark BROKEN on FreeBSD 7.X: fails to compile fully, fails to install laterpav2011-12-091-0/+4 * - Fix do-installdhn2011-11-281-3/+11 * Upgrade yajl to 2.0.1 (mirror it my self as upstream still not provide real s...bapt2011-11-271-1/+2 * - Update to 0.10pgj2011-11-266-33/+22 * - Update to 20111124miwi2011-11-263-7/+5 * update lang/sbcl to 1.0.53, and adjust dependent portsbf2011-11-232-2/+2 * - Update to 4.1dhn2011-11-194-15/+45 * - Unbreak - fix build with latest x11-toolkits/fltkgahr2011-11-172-16/+2 * - Add docbook-xml-450 explicit as a dependencygarga2011-11-171-4/+5 * Remove CMAKE_USE_PTHREAD from the ports using it.rakuco2011-11-141-1/+0 * Mark as broken on powerpc: does not compile.linimon2011-11-111-0/+3 * - fix WWW in pkg-descreadler2011-11-091-2/+0 * Standardize WWW: tags a bit more:dougb2011-11-071-4/+3 * - Deprecate (abandoned upstream) and set expiration date to 2012-02-01rene2011-11-072-4/+6 * - Mark BROKEN: does not compile with new fltkpav2011-11-051-0/+2 * back to the pool the maintainer has to time to maintain it anymorebapt2011-11-041-1/+4 * - Fix plistmiwi2011-11-022-6/+6 * Remove references to unsupported FreeBSD versions. Mostly of the form:dougb2011-11-021-7/+1 * - Update to 1.3.2beat2011-11-013-29/+29 * audio/mp3butler Depends on audio/p5-MusicBrainz-Client which is DEPRECATEDdougb2011-11-0134-1626/+0 * - Fix buildmiwi2011-10-312-0/+2 * Fix spelling of "Xfce" for x11-wm/xfce4 too.rene2011-10-302-3/+3 * - x11-wm/xfce4-wm update to 4.8.2miwi2011-10-288-66/+108 * - Update to 4.8.2miwi2011-10-286-11/+25 * Consistify spelling of "Xfce", and some other projects while there.rene2011-10-273-3/+3 * x11-wm/fvwm-devel is gone, no longer supported by upline. Use fvwm instead.cy2011-10-261-2/+2 * - Update to 1.0.10gahr2011-10-262-3/+3 * Fvwm2-devel is no longer supported by fvwm.org, expiry date has passed.cy2011-10-261-1/+0 * The FVWM development branch is no longer supported by upline (fvwm.org).cy2011-10-267-702/+0 * The vast majority of pkg-descr files had the following format when theydougb2011-10-246-16/+0 * Remove more tags from pkg-descr files fo the form:dougb2011-10-2410-23/+2 * - Return my ports back to the pool. I was unable to make any fixes tostas2011-10-2415-15/+15 * Re-assign to the Xfce team.rene2011-10-236-6/+6 * Fix the build with libX11 > 1.40.danfe2011-10-201-2/+4 * Update to 1.8.2ehaupt2011-10-192-7/+9 * Replace dead mirror with working onepawel2011-10-181-1/+1 * For ports that have an EXPIRATION_DATE which has already passed, butdougb2011-10-092-0/+6 * - Mark BROKEN: does not compilepav2011-10-031-0/+2 * Fvwm.org no longer distutes a development branch.cy2011-10-021-0/+3 * Update 2.6.2 --> 2.6.3.cy2011-10-012-3/+3 * As previously advertised, remove ports that previously had beendougb2011-09-308-571/+0 * Merge upstream fix for config path handling bug for obconf invoked withnovel2011-09-242-1/+19 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-2430-58/+53 * - Update to 1.1.0.rakuco2011-09-202-10/+13 * - Chase libev shlib bumppav2011-09-202-2/+4 * - update mkfontscale to 1.0.9eadler2011-09-182-3/+3 * Fix build with clangpawel2011-09-182-0/+22 * - Track dependencies after databases/gdbm updategabor2011-09-121-2/+2 * - Add runtime dependency on shells/bashashish2011-09-082-1/+14 * 2011-09-01 x11-wm/epiwm: Abandonwarebapt2011-09-078-105/+0 * - Update MASTER_SITESnovel2011-09-071-2/+2 * - Update to 0.4.7dhn2011-09-034-14/+32 * s/EXPIRATION/EXPIRATION_DATE/dougb2011-09-031-1/+1 * Add EXPIRATION to ports marked DEPRECATED that do not already have it. [1]dougb2011-09-031-0/+1 * - Update to 5.9dhn2011-09-023-14/+15 * Unbreak (hopefully) by partially merging upstream codenovel2011-08-313-12/+1065 * - Mark BROKEN: bad depobjpav2011-08-301-0/+2 * Update to 20110818zi2011-08-242-3/+5 * Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where ...kwm2011-08-243-4/+16 * - change the email address I use to maintain portseadler2011-08-221-1/+1 * - change the email address I use to maintain portseadler2011-08-221-1/+1 * Update to 3.5.0.novel2011-08-213-28/+41 * Update to 0.9.34zi2011-08-176-18/+22 * Bump PORTREVISION: rebuild ports that depend on devel/cl-asdf.olgeni2011-08-171-1/+1 * Update to 0.0.6ehaupt2011-08-137-303/+397 * Remove USE_GNOME=gnometarget from ports. It has been a empty keyword sincekwm2011-08-1262-62/+56 * Update to 0.90.2ehaupt2011-08-115-27/+14 * - use MASTER_SITE_LOCALdinoex2011-08-081-2/+2 * - cleanup MASTER_SITESdinoex2011-08-081-2/+1 * Update to 0.9.33arved2011-08-074-6/+6 * Update 2.6.1 --> 2.6.2.cy2011-08-073-15/+3 * Remove WWW entries from unmaintained ports that return 404 or where the domainehaupt2011-08-0310-20/+0 * Mark BROKEN: Does not fetchbapt2011-08-031-0/+2 * Fix master_sitebapt2011-08-033-3/+3 * - update to 1.0.9gahr2011-08-022-4/+4 * Deprecate some abandonwaresbapt2011-08-021-0/+3 * - Sort SUBDIRssunpoet2011-08-011-1/+1 * Fix build issues with GNOMEarved2011-07-302-3/+2 * update x11/libexo to 0.6.2oliver2011-07-273-5/+5 * - Make portlint happierdhn2011-07-241-3/+3 * - Update to 3.e-bf3dhn2011-07-244-19/+5 * - Update to 20110721dhn2011-07-244-16/+20 * My mistake. Previous commit backed out due to maintainers request.cy2011-07-201-2/+1 * Mark BROKEN when GNOMEDESKTOP is selected.cy2011-07-191-1/+2 * - Fix compiz-manager script to work with Nvidia graphics card.stephen2011-07-123-6/+6 * - update to 0.1.13bapt2011-07-113-4/+6 * Update description after recent changes.danfe2011-07-081-3/+7 * Remove `x11-wm/boxtools' port and provide an OPTION to install tools only.danfe2011-07-085-63/+22 * Add two patches to Blackbox:danfe2011-07-082-0/+35 * Reset maintainership de jure. In fact KDE 3 has not been maintained by our teammakc2011-07-081-1/+1 * - Update to 0.9.32dhn2011-07-068-34/+72 * - Reassign to the heaptabthorpe2011-07-0511-11/+11 * - Update to 1.8.1miwi2011-07-034-4225/+4220 * Reconnect the following ports which were brought back out of the Attic:linimon2011-07-011-0/+1 * - Fix PLISTgahr2011-06-271-0/+2 * Fix build with clangdougb2011-06-261-0/+11 * - Update to 1.3.4miwi2011-06-254-115/+55 * This is the MS Windows like taskbar module for Enlightenment.miwi2011-06-25