aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2011-08-03 04:19:45 +0800
committercy <cy@FreeBSD.org>2011-08-03 04:19:45 +0800
commitdb4d1b1d86575d6e92acc76ed1910c96b00de7e2 (patch)
treeee53293632ed21901c530e1583b69c1be46c5f9d /x11
parent3b9d4bb91f63fa32eea6aa893fee213f3119c303 (diff)
downloadfreebsd-ports-gnome-db4d1b1d86575d6e92acc76ed1910c96b00de7e2.tar.gz
freebsd-ports-gnome-db4d1b1d86575d6e92acc76ed1910c96b00de7e2.tar.zst
freebsd-ports-gnome-db4d1b1d86575d6e92acc76ed1910c96b00de7e2.zip
Resurrect the XView application props and assume maintainership.
Diffstat (limited to 'x11')
-rw-r--r--x11/props/Makefile29
-rw-r--r--x11/props/distinfo2
-rw-r--r--x11/props/files/patch-aa12
-rw-r--r--x11/props/files/patch-ab32
-rw-r--r--x11/props/files/patch-ac11
-rw-r--r--x11/props/pkg-descr3
-rw-r--r--x11/props/pkg-plist10
7 files changed, 99 insertions, 0 deletions
diff --git a/x11/props/Makefile b/x11/props/Makefile
new file mode 100644
index 000000000000..407d3391ce73
--- /dev/null
+++ b/x11/props/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: props
+# Date created: 3 January 1998
+# Whom: jraynard
+#
+# $FreeBSD$
+#
+
+PORTNAME= props
+PORTVERSION= 1.0
+PORTREVISION= 2
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= cy
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= The OpenLook props application
+
+LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
+
+WRKSRC= ${WRKDIR}/props
+USE_IMAKE= yes
+USE_XORG= x11 xext
+MAKE_ARGS= INFOFILES=""
+
+post-install:
+ ${MKDIR} ${PREFIX}/lib/X11/locale/C/props; \
+ ${INSTALL_DATA} ${WRKSRC}/C/* ${PREFIX}/lib/X11/locale/C/props
+
+.include <bsd.port.mk>
diff --git a/x11/props/distinfo b/x11/props/distinfo
new file mode 100644
index 000000000000..883c53c33e4b
--- /dev/null
+++ b/x11/props/distinfo
@@ -0,0 +1,2 @@
+SHA256 (props-1.0.tar.gz) = b466898959e021594d8c669c3b0bb777213644041d5acba1ffea4bc9bf66c0be
+SIZE (props-1.0.tar.gz) = 28699
diff --git a/x11/props/files/patch-aa b/x11/props/files/patch-aa
new file mode 100644
index 000000000000..fe1c81f27fd8
--- /dev/null
+++ b/x11/props/files/patch-aa
@@ -0,0 +1,12 @@
+--- l10n_props.h.orig Tue Nov 4 20:36:07 1997
++++ l10n_props.h Tue Nov 4 20:36:31 1997
+@@ -13,6 +13,9 @@
+ */
+ #define LOCALE_NAME_LEN 20
+
++#ifndef LC_MESSAGES
++#define LC_MESSAGES 0
++#endif
+
+ typedef struct _l10n_config_list_item {
+ /*
diff --git a/x11/props/files/patch-ab b/x11/props/files/patch-ab
new file mode 100644
index 000000000000..cad9fb899fda
--- /dev/null
+++ b/x11/props/files/patch-ab
@@ -0,0 +1,32 @@
+--- l10n_read.c.orig Fri Nov 7 17:21:25 1997
++++ l10n_read.c Mon Oct 21 03:29:17 2002
+@@ -18,15 +18,17 @@
+ #include "l10n_props.h"
+
+
+-#define MAX_LINE_LENGTH 256
++#define MAX_LINE_LENGTH 2560
+
+ #define NAME_SEPARATOR '='
+ #define FIELD_SEPARATOR '|'
+ #define ITEM_SEPARATOR ';'
+
+
++#if !defined(__FreeBSD__)
+ extern char *malloc();
+ extern char *calloc();
++#endif
+
+
+ /*
+@@ -72,8 +74,9 @@
+ /*
+ * Find path for localization configuration files under
+ * $OPENWINHOME/share/locale/<locale>/props
++ * $OPENWINHOME/lib/X11/locale/<locale>/props
+ */
+- sprintf(fullpath, "%s/share/locale/%s/props/%s",
++ sprintf(fullpath, "%s/lib/X11/locale/%s/props/%s",
+ getenv("OPENWINHOME"), locale, file_name);
+
+ if ((config_file = fopen(fullpath, "r")) == NULL)
diff --git a/x11/props/files/patch-ac b/x11/props/files/patch-ac
new file mode 100644
index 000000000000..686095e402c9
--- /dev/null
+++ b/x11/props/files/patch-ac
@@ -0,0 +1,11 @@
+--- props.c.orig Sun Nov 9 01:18:50 1997
++++ props.c Sun Nov 9 01:24:50 1997
+@@ -816,7 +816,7 @@
+ else
+ {
+ strcpy(localepath, openwin_dir);
+- strcat(localepath, "/lib/locale/");
++ strcat(localepath, "/lib/X11/locale/C/");
+ bindtextdomain("props", localepath);
+ }
+
diff --git a/x11/props/pkg-descr b/x11/props/pkg-descr
new file mode 100644
index 000000000000..16f6f6214f7a
--- /dev/null
+++ b/x11/props/pkg-descr
@@ -0,0 +1,3 @@
+The XView properties editor allows the user to customise and
+configure many workspace properties (colour, icons, menus,
+mouse and localisation).
diff --git a/x11/props/pkg-plist b/x11/props/pkg-plist
new file mode 100644
index 000000000000..acea2efedaf8
--- /dev/null
+++ b/x11/props/pkg-plist
@@ -0,0 +1,10 @@
+bin/props
+lib/X11/locale/C/props/C
+lib/X11/locale/C/props/basic_setting
+lib/X11/locale/C/props/en_AU
+lib/X11/locale/C/props/en_CA
+lib/X11/locale/C/props/en_UK
+lib/X11/locale/C/props/en_US
+@dirrm lib/X11/locale/C/props
+@dirrm lib/X11/locale/C
+@dirrm lib/X11/locale