aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-09-28 02:47:36 +0800
committerpawel <pawel@FreeBSD.org>2012-09-28 02:47:36 +0800
commitdc9ade51aa201468e422c08b23d705dc9f262cde (patch)
tree3e1b8f60aca360d2f76efff9307d8c58cb0e2823 /x11
parent98c12f9ff08aa2a3033d66f7a08d8c394eaebee4 (diff)
downloadfreebsd-ports-gnome-dc9ade51aa201468e422c08b23d705dc9f262cde.tar.gz
freebsd-ports-gnome-dc9ade51aa201468e422c08b23d705dc9f262cde.tar.zst
freebsd-ports-gnome-dc9ade51aa201468e422c08b23d705dc9f262cde.zip
- Fix build with OpenSSL >= 1.0
- Trim Makefile header
Diffstat (limited to 'x11')
-rw-r--r--x11/kdebase3/Makefile8
-rw-r--r--x11/kdebase3/files/patch-kcontrol-crypto-crypto.cpp38
2 files changed, 39 insertions, 7 deletions
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index 112ebf5fe4a1..1a16b1cd74c6 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -1,14 +1,8 @@
-# -*-mode: makefile-*-
-# New ports collection makefile for: kdebase3.1
-# Date created: 29 November 2002
-# Whom: kde@freebsd.org
-#
# $FreeBSD$
-#
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdebase3/files/patch-kcontrol-crypto-crypto.cpp b/x11/kdebase3/files/patch-kcontrol-crypto-crypto.cpp
new file mode 100644
index 000000000000..0ece543364a2
--- /dev/null
+++ b/x11/kdebase3/files/patch-kcontrol-crypto-crypto.cpp
@@ -0,0 +1,38 @@
+--- kcontrol/crypto/crypto.cpp.orig 2012-09-26 18:12:48.000000000 +0200
++++ kcontrol/crypto/crypto.cpp 2012-09-26 20:33:56.000000000 +0200
+@@ -2321,7 +2321,11 @@
+ unsigned int i;
+ SSL_CTX *ctx;
+ SSL *ssl;
++#if OPENSSL_VERSION_NUMBER >= 0x10000000L
++const SSL_METHOD *meth;
++#else
+ SSL_METHOD *meth;
++#endif
+
+ SSLv2Box->clear();
+ SSLv3Box->clear();
+@@ -2337,7 +2341,11 @@
+ CipherItem *item;
+ for (i=0; ; i++) {
+ int j, k;
++#if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_CIPHER *sc;
++#else
+ SSL_CIPHER *sc;
++#endif
+ sc = (meth->get_cipher)(i);
+ if (!sc)
+ break;
+@@ -2365,7 +2373,11 @@
+
+ for (i=0; ; i++) {
+ int j, k;
++#if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_CIPHER *sc;
++#else
+ SSL_CIPHER *sc;
++#endif
+ sc = (meth->get_cipher)(i);
+ if (!sc)
+ break;