aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
commitfd50192ea7567a034b59dfc96a1d112f8ccfa573 (patch)
tree6975c46330f04e77b17cb4d014c9d66ceb4f7a68 /x11
parent54d69c112debb52b84b6d174bd59479eec834fb7 (diff)
downloadfreebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.gz
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.zst
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.zip
${PERL} -> ${REINPLACE_CMD}
PR: 40784 Submitted by: corecode@corecode.ath.cx Reviewed by: flynn@energyhq.homeip.net
Diffstat (limited to 'x11')
-rw-r--r--x11/imwheel/Makefile3
-rw-r--r--x11/tycoon/Makefile3
-rw-r--r--x11/wdm/Makefile3
-rw-r--r--x11/xbanner/Makefile3
-rw-r--r--x11/xstroke/Makefile7
5 files changed, 12 insertions, 7 deletions
diff --git a/x11/imwheel/Makefile b/x11/imwheel/Makefile
index da702eecb51e..896de2f0d629 100644
--- a/x11/imwheel/Makefile
+++ b/x11/imwheel/Makefile
@@ -12,6 +12,7 @@ MASTER_SITES= http://jonatkins.org/imwheel/files/
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_GMAKE= YES
USE_X_PREFIX= YES
GNU_CONFIGURE= YES
@@ -21,7 +22,7 @@ MAN1= imwheel.1
post-patch:
.for i in imwheel.1 util.c
- @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/${i}
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/${i}
.endfor
post-install:
diff --git a/x11/tycoon/Makefile b/x11/tycoon/Makefile
index 98b32093526d..c52317ef860a 100644
--- a/x11/tycoon/Makefile
+++ b/x11/tycoon/Makefile
@@ -15,12 +15,13 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= xforms:${PORTSDIR}/x11-toolkits/xforms
+USE_REINPLACE= yes
USE_IMAKE= yes
USE_XPM= yes
post-build:
${RM} -f ${WRKSRC}/xbackdrop/backdrops/index~ ;\
- ${PERL} -pi -e 's,/usr/lib,${PREFIX}/lib,' \
+ ${REINPLACE_CMD} -e 's,/usr/lib,${PREFIX}/lib,' \
${WRKSRC}/xbackdrop/backdrops/index
.include <bsd.port.mk>
diff --git a/x11/wdm/Makefile b/x11/wdm/Makefile
index 24648c7446fe..db896a2fc69c 100644
--- a/x11/wdm/Makefile
+++ b/x11/wdm/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS= wraster.4:${PORTSDIR}/x11-wm/windowmaker \
PropList.2:${PORTSDIR}/devel/libPropList
DIST_SUBDIR= wdm
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_AUTOMAKE_VER=14
AUTOMAKE_ARGS= --include-deps
@@ -62,7 +63,7 @@ pre-everything::
.endif
post-patch:
- @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/doc/*.man
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/doc/*.man
pre-install:
@if [ -e ${PREFIX}/lib/X11/wdm/wdm-config ]; then \
diff --git a/x11/xbanner/Makefile b/x11/xbanner/Makefile
index 6a1edf5f5d4d..c2e7ff0e5998 100644
--- a/x11/xbanner/Makefile
+++ b/x11/xbanner/Makefile
@@ -14,12 +14,13 @@ DISTNAME= XBanner${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_XPM= yes
#USE_IMAKE= yes
post-patch:
- @${PERL} -pi -e 's|%%X11BASE%%|${X11BASE}|g' \
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/xres.c ${WRKSRC}/samples/XBanner.ad
post-install:
diff --git a/x11/xstroke/Makefile b/x11/xstroke/Makefile
index 3adb3c26fdaa..4dba512c6179 100644
--- a/x11/xstroke/Makefile
+++ b/x11/xstroke/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+USE_REINPLACE= yes
USE_BISON= yes
USE_IMAKE= yes
CFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
@@ -24,10 +25,10 @@ LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lgnugetopt
MAN1= xstroke.1
post-patch:
- @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g ; \
+ @${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g ; \
s,%%CFLAGS%%,${CFLAGS},g ; \
s,%%LDFLAGS%%,${LDFLAGS},g" ${WRKSRC}/Imakefile
- @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/etc/Imakefile
- @${PERL} -pi -e "s,etc/,${PREFIX}/etc/,g" ${WRKSRC}/args.h
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/etc/Imakefile
+ @${REINPLACE_CMD} -e "s,etc/,${PREFIX}/etc/,g" ${WRKSRC}/args.h
.include <bsd.port.mk>