aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorrodrigo <rodrigo@FreeBSD.org>2017-12-07 17:46:41 +0800
committerrodrigo <rodrigo@FreeBSD.org>2017-12-07 17:46:41 +0800
commit03fb4809df61d579f49fefcb4b23ee7ab06dba14 (patch)
tree9e0a99470783b9c28877b8a794a486a12e46b26e /x11
parent1a7acfc324ae1b23b2b557d4f583d97eb9def1c1 (diff)
downloadfreebsd-ports-gnome-03fb4809df61d579f49fefcb4b23ee7ab06dba14.tar.gz
freebsd-ports-gnome-03fb4809df61d579f49fefcb4b23ee7ab06dba14.tar.zst
freebsd-ports-gnome-03fb4809df61d579f49fefcb4b23ee7ab06dba14.zip
Tilda uses wrong ps flag on start
Replace ps call by pgrep Bump PORTREVISION
Diffstat (limited to 'x11')
-rw-r--r--x11/tilda/Makefile1
-rw-r--r--x11/tilda/files/patch-tilda.c13
2 files changed, 12 insertions, 2 deletions
diff --git a/x11/tilda/Makefile b/x11/tilda/Makefile
index 320587d5e7e4..f91da3c5d2a6 100644
--- a/x11/tilda/Makefile
+++ b/x11/tilda/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tilda
PORTVERSION= 1.3.3
DISTVERSIONPREFIX= ${PORTNAME}-
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= rodrigo@FreeBSD.org
diff --git a/x11/tilda/files/patch-tilda.c b/x11/tilda/files/patch-tilda.c
index 87f7cca00a83..c215f05d14d5 100644
--- a/x11/tilda/files/patch-tilda.c
+++ b/x11/tilda/files/patch-tilda.c
@@ -1,5 +1,5 @@
---- src/tilda.c.orig 2015-12-16 12:11:58 UTC
-+++ src/tilda.c
+--- src/tilda.c.orig 2017-09-08 22:19:35.318278000 +0300
++++ src/tilda.c 2017-09-08 22:21:22.752550000 +0300
@@ -12,6 +12,7 @@
* You should have received a copy of the GNU Library General Public
* License along with this library. If not, see <http://www.gnu.org/licenses/>.
@@ -8,3 +8,12 @@
#define _POSIX_SOURCE /* feature test macro for signal functions */
#define _XOPEN_SOURCE /* feature test macro for popen */
+@@ -230,7 +231,7 @@
+ static GSList *getPids() {
+ GSList *pids = NULL;
+ FILE *ps_output;
+- const gchar ps_command[] = "ps -C tilda -o pid=";
++ const gchar ps_command[] = "pgrep tilda";
+ gchar buf[16]; /* Really shouldn't need more than 6 */
+
+ if ((ps_output = popen (ps_command, "r")) == NULL) {