aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoradridg <adridg@FreeBSD.org>2017-09-15 05:02:51 +0800
committeradridg <adridg@FreeBSD.org>2017-09-15 05:02:51 +0800
commit09b73d7ce3bed9ff760b2d8c786bd0baa67d6e45 (patch)
tree570aeb8e9fcad4efb19711621999d3df8296b6b9 /x11
parent738d9f9aaaf7e78224386120cc5ea2b44702376f (diff)
downloadfreebsd-ports-gnome-09b73d7ce3bed9ff760b2d8c786bd0baa67d6e45.tar.gz
freebsd-ports-gnome-09b73d7ce3bed9ff760b2d8c786bd0baa67d6e45.tar.zst
freebsd-ports-gnome-09b73d7ce3bed9ff760b2d8c786bd0baa67d6e45.zip
Update CMake to 3.9, merge devel/cmake-modules into devel/cmake
Thanks to antoine@ for the exp-run. Approved by: rakuco (mentor) Reviewed by: tcberner (mentor) Reviewed by: mat PR: 222000 (exp-run) Differential Revision: https://reviews.freebsd.org/D12299
Diffstat (limited to 'x11')
-rw-r--r--x11/kdelibs4/files/patch-git_57eaf6533
1 files changed, 33 insertions, 0 deletions
diff --git a/x11/kdelibs4/files/patch-git_57eaf65 b/x11/kdelibs4/files/patch-git_57eaf65
new file mode 100644
index 000000000000..19f5b5abc5fc
--- /dev/null
+++ b/x11/kdelibs4/files/patch-git_57eaf65
@@ -0,0 +1,33 @@
+From 57eaf65accb8d058644dc8eee7332e0ec0c1952f Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Thu, 20 Jul 2017 20:12:10 +0200
+Subject: [PATCH] [cmake]: De-duplicate "else" to fix build with cmake-3.9
+
+Otherwise it errors out with:
+"CMake Error at kdeui/CMakeLists.txt:316 (else): A duplicate ELSE
+command was found inside an IF block."
+Also adjust the indentation to match the surrounding lines and remove
+the arguments from else() and endif().
+---
+ kdeui/CMakeLists.txt | 8 +++-----
+ 1 file changed, 3 insertions(+), 5 deletions(-)
+
+diff --git kdeui/CMakeLists.txt kdeui/CMakeLists.txt
+index d6ec8b47e9..cadb52e713 100644
+--- kdeui/CMakeLists.txt
++++ kdeui/CMakeLists.txt
+@@ -311,11 +311,9 @@ if (Q_WS_MAC AND MAC_USE_OSXKEYCHAIN)
+ FIND_LIBRARY(SECURITY_LIBRARY Security)
+ set(kdeui_LIB_SRCS ${kdeui_LIB_SRCS} util/kwallet_mac.cpp util/qosxkeychain.cpp)
+ add_definitions(-DMAC_USE_OSXKEYCHAIN)
+-else(Q_WS_MAC AND MAC_USE_OSXKEYCHAIN)
+- set(kdeui_LIB_SRCS ${kdeui_LIB_SRCS} util/kwallet.cpp)
+-else(Q_WS_MAC AND MAC_USE_OSXKEYCHAIN)
+- set(kdeui_LIB_SRCS ${kdeui_LIB_SRCS} util/kwallet.cpp)
+-endif(Q_WS_MAC AND MAC_USE_OSXKEYCHAIN)
++else()
++ set(kdeui_LIB_SRCS ${kdeui_LIB_SRCS} util/kwallet.cpp)
++endif()
+
+ if(NOT WINCE)
+ set(kdeui_LIB_SRCS