aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-07-29 07:58:25 +0800
committerrafan <rafan@FreeBSD.org>2007-07-29 07:58:25 +0800
commit1ac0cd2a36730e7769891a5d5a441f99d58c96c9 (patch)
tree9df0cfdac5e38e3c6243062506897e03e85f9b98 /x11
parente81373fb5fbf4d555a9f2bff417ba60b80caf717 (diff)
downloadfreebsd-ports-gnome-1ac0cd2a36730e7769891a5d5a441f99d58c96c9.tar.gz
freebsd-ports-gnome-1ac0cd2a36730e7769891a5d5a441f99d58c96c9.tar.zst
freebsd-ports-gnome-1ac0cd2a36730e7769891a5d5a441f99d58c96c9.zip
- Fix build on 5.x by using texinfo from ports
Reported by: pointyhat via kris
Diffstat (limited to 'x11')
-rw-r--r--x11/xnee/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/x11/xnee/Makefile b/x11/xnee/Makefile
index a02fdca6a91f..076ff3128a4c 100644
--- a/x11/xnee/Makefile
+++ b/x11/xnee/Makefile
@@ -36,6 +36,13 @@ PLIST_DIRS= %%DATADIR%%/pixmaps %%DATADIR%%
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 600000
+BUILD_DEPENDS+= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
+MAKEINFO= ${LOCALBASE}/bin/makeinfo
+.else
+MAKEINFO= /usr/bin/makeinfo
+.endif
+
.if defined(WITH_GNEE)
USE_GNOME+= gtk20
PLIST_FILES+= bin/gnee
@@ -73,8 +80,8 @@ post-patch:
's|cp $$(PNEE)|$$(INSTALL_PROGRAM) $$(PNEE)|g' ${WRKSRC}/pnee/src/Makefile.in
post-build:
- cd ${WRKSRC}/cnee/src && /usr/bin/makeinfo --no-split cnee.texi
- cd ${WRKSRC}/doc && /usr/bin/makeinfo --no-split xnee.texi
+ cd ${WRKSRC}/cnee/src && ${MAKEINFO} --no-split cnee.texi
+ cd ${WRKSRC}/doc && ${MAKEINFO} --no-split xnee.texi
post-install:
${INSTALL_DATA} ${WRKSRC}/cnee/src/cnee.info ${PREFIX}/${INFO_PATH}