aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2011-09-08 04:37:00 +0800
committerstas <stas@FreeBSD.org>2011-09-08 04:37:00 +0800
commit39bac3bcea5b57aae2d06aebd6743477da709ed4 (patch)
treeee19892cf93ab1a14448d04ccf72598d8bf7a682 /x11
parent36bafaab0cb8235697f3a89716f74b20834e7a95 (diff)
downloadfreebsd-ports-gnome-39bac3bcea5b57aae2d06aebd6743477da709ed4.tar.gz
freebsd-ports-gnome-39bac3bcea5b57aae2d06aebd6743477da709ed4.tar.zst
freebsd-ports-gnome-39bac3bcea5b57aae2d06aebd6743477da709ed4.zip
- Resurrect a useful port.
- Provide another mirror, as the original one seems to be down temporarly.
Diffstat (limited to 'x11')
-rw-r--r--x11/xvattr/Makefile53
-rw-r--r--x11/xvattr/distinfo2
-rw-r--r--x11/xvattr/pkg-descr4
3 files changed, 59 insertions, 0 deletions
diff --git a/x11/xvattr/Makefile b/x11/xvattr/Makefile
new file mode 100644
index 000000000000..dbfe283875f6
--- /dev/null
+++ b/x11/xvattr/Makefile
@@ -0,0 +1,53 @@
+# ex:ts=8
+# Ports collection makefile for: xvattr
+# Date created: Jan 15, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xvattr
+PORTVERSION= 1.3
+PORTREVISION= 7
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/ \
+ http://www.dtek.chalmers.se/groups/dvd/dist/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Getting and setting Xv attributes
+
+OPTIONS= GTK1 "GTK1 support (Default is GTK2)" off
+
+USE_XORG= x11 xv
+WANT_GNOME= yes
+
+MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME} bin/g${PORTNAME}
+
+CFLAGS+= -DVERSION=\"${PORTVERSION}\"
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GTK1)
+USE_GNOME+= gtk12
+GTK_PC= gtk+
+.else
+USE_GNOME+= gtk20
+GTK_PC= gtk+-2.0
+.endif
+
+post-extract:
+ @${RM} -f ${WRKSRC}/getopt.h
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${PORTNAME}.c -o ${PORTNAME} \
+ `pkg-config --cflags --libs xv`
+ cd ${WRKSRC} && ${CC} ${CFLAGS} g${PORTNAME}.c -o g${PORTNAME} \
+ `pkg-config --cflags --libs ${GTK_PC} xv`
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/g${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/x11/xvattr/distinfo b/x11/xvattr/distinfo
new file mode 100644
index 000000000000..40719eef8ac6
--- /dev/null
+++ b/x11/xvattr/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xvattr-1.3.tar.gz) = 1cedc0b4795e6f4234b1d52172f74d7163ecb8142fbb35dc86c905df5478d8fa
+SIZE (xvattr-1.3.tar.gz) = 82263
diff --git a/x11/xvattr/pkg-descr b/x11/xvattr/pkg-descr
new file mode 100644
index 000000000000..6dbf9694db76
--- /dev/null
+++ b/x11/xvattr/pkg-descr
@@ -0,0 +1,4 @@
+xvattr lets you list the available attributes associated with the Xv
+extension to XFree86. It also allows you to change the values of the
+attributes. This can be used to change brightness and so on for programs
+that use Xv overlays.