aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-01-01 02:24:10 +0800
committernetchild <netchild@FreeBSD.org>2005-01-01 02:24:10 +0800
commit41aa99b87f1fc1de75ee54ee38b4782ee393704b (patch)
tree377e4c9c9dd556f0b4785f3df7b930015778713f /x11
parent0a7250c8120524f20b14e530af6f7eddf2e77d1e (diff)
downloadfreebsd-ports-gnome-41aa99b87f1fc1de75ee54ee38b4782ee393704b.tar.gz
freebsd-ports-gnome-41aa99b87f1fc1de75ee54ee38b4782ee393704b.tar.zst
freebsd-ports-gnome-41aa99b87f1fc1de75ee54ee38b4782ee393704b.zip
Say hello to the linux mega patch, it consolidates our linux bits a
little bit and allows to proceed to a more recent linux_base from a stable (read as: the major bugs should be ironed out or identified and most linux ports build just fine) source. It also allows to ship 4.11 with a working linuxolator (the EOLed linux_base is marked forbidden because of a security hole). This is a major update, please read UPDATING (and CHANGES if you develop linux ports). Changes: - change the default linux_base from v7 to v8 - add a newer freetype to linux_base-8 for nicer fonts display [1] - don't let cpio use hardlinks in the linux_base-8 port to quiet some warnings in some cases [2] - fix a cut&past error in the linux_base-8 pkg-install script [3] - convert the binary knob "USE_LINUX" to a version specifier, e.g. USE_LINUX=<value> specifies a dependency upon emulators/linux_base-<value>, exceptions are a value of "7" (which does what you want and adds a dependency to linux_base) and any value without a corresponding port in PORTSDIR/emulators/linux_base-<value> (which adds a dependency to the default linux_base) - don't implicitly add USE_LINUX with the USE_LINUX_PREFIX knob, this allows us to use the USE_LINUX_PREFIX knob for linux_base and paves the way for splitting up future linux base ports into individual pieces - remove RESTRICTED from some GPL licensed ports, even when we only distribute binaries, we get them from official linux sites, so anyone can grab them there if he needs to - add a dependency upon the linux X11 bits where necessary (based upon guesswork) - don't use USE_X_PREFIX in some linux ports since it adds a dependency to the FreeBSD X11 libs, as a workaround use PREFIX?= (the clean solution would be to remove the implicit USE_XLIB from USE_X_PREFIX) - bump the portrevision of the linux ports ("better safe than sorry" algorithm) - pass maintainership of the important linux infrastructure to a mailinglist, hijack freebsd-emulation@ for this purpose (if somebody doesn't like this: tell us your bikeshed color at freebsd-emulation@, my color would be "linuxolator@" in case someone cares...) - add a pkg-install script for linux-fontconfig, but don't use it; everything should work without it (the FreeBSD fc-cache program should do all the work), but in case we need it we just need to decomment the pkg-install part in the Makefile - fix some dependencies - fix some bugs - add some static plists - unbreak the ports with dependecies to more than one linux_base This also fixes some ports which are marked BROKEN because of dependencies to v7 and v8 of linux_base at the same time. Known bugs: - the linux-mesa and linux-devtools ports install libGL*.so symlinks - some "minor" plist bugs (e.g. ld.so.{conf,cache} are modified by the linux X11 port, so linx_Base-8 moans at deinstall time) Future work (interested souls should coordinate with freebsd-emulation@): - add some kind of USE_LINUX_X11 knob to streamline the X11 dependencies, or modify the behavior of USE_XLIB in the USE_LINUX case AFAIK trevor has some patches. - make USE_XLIB and USE_X_PREFIX orthogonal to be able to get rid of the PREFIX?= workaround in some linux ports Should be discussed/coordinated on/with x11@. - move the RPM bits from x11-toolkits/linux-gtk/Makefile to PORTSDIR/Mk/ - update to a more recent linux base PR: 69997, 70539 (and maybe others) Discussed with/on: java@, x11@, trevor, portmgr Tested by: mezz, portmgr, pointyhat RPM hunted down by: Joseph Gelinas <scirocco@tasam.com> [1] Requested by: portmgr [2] Submitted by: kris [3] Approved by: portmgr
Diffstat (limited to 'x11')
-rw-r--r--x11/linux-XFree86-libs/Makefile18
-rw-r--r--x11/linux-XFree86-libs/files/pkg-install.in12
-rw-r--r--x11/linux-gnomelibs/Makefile4
-rw-r--r--x11/nvidia-driver/Makefile3
4 files changed, 26 insertions, 11 deletions
diff --git a/x11/linux-XFree86-libs/Makefile b/x11/linux-XFree86-libs/Makefile
index 15140ae435e5..6fecf8acd1ec 100644
--- a/x11/linux-XFree86-libs/Makefile
+++ b/x11/linux-XFree86-libs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= XFree86-libs
PORTVERSION= 4.3.99.902
+PORTREVISION= 1
CATEGORIES= x11 linux
MASTER_SITES= ${MASTER_SITE_SUSE} \
ftp://ftp.in2p3.fr/pub/linux/suse/update/9.1/rpm/i586/ \
@@ -18,20 +19,22 @@ EXTRACT_SUFX=
DIST_SUBDIR= rpm/i386/suse
EXTRACT_ONLY=
-MAINTAINER= trevor@FreeBSD.org
-COMMENT= XFree86 libraries, Linux/i386 binary
+MAINTAINER= freebsd-emulation@FreeBSD.org
+COMMENT= XFree86 libraries, Linux binary
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-RUN_DEPENDS=${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig
CONFLICTS= linux_base-6* linux_base-7* linux_base-deb* linux_base-gentoo*
+USE_LINUX= yes
+USE_LINUX_PREFIX=yes
MD5_FILE= ${MASTERDIR}/distinfo.i386
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
ONLY_FOR_ARCHS= amd64 i386
+PKGINSTALL= ${WRKDIR}/pkg-install
PLIST= ${WRKDIR}/plist
PLIST_DIRS= usr/X11R6/lib/X11
-PREFIX= ${LINUXBASE}
pre-install:
@${RM} -f ${PLIST}
@@ -46,10 +49,9 @@ pre-install:
${FIND} -d usr/X11R6/lib/X11/locale -type d | \
${SED} -e 's:^:@dirrm :' >> ${PLIST}
post-install:
- @${RM} -f ${LINUXBASE}/etc/ld.so.cache
- @${FIND} ${LINUXBASE} -name lib -type d | ${SED} 's:${LINUXBASE}::g' \
- > ${LINUXBASE}/etc/ld.so.conf
- @chroot ${LINUXBASE} sbin/ldconfig
+ @${SED} -e 's|%%LINUXBASE%%|${LINUXBASE}|g ; s|%%PREFIX%%|${PREFIX}|g' \
+ < ${FILESDIR}/pkg-install.in > ${PKGINSTALL}
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
do-install:
@rpm -U --ignorearch --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm \
diff --git a/x11/linux-XFree86-libs/files/pkg-install.in b/x11/linux-XFree86-libs/files/pkg-install.in
new file mode 100644
index 000000000000..1be02068a889
--- /dev/null
+++ b/x11/linux-XFree86-libs/files/pkg-install.in
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+PATH=/bin:/sbin:/usr/bin:/usr/sbin
+export PATH
+
+if [ "$2" = "POST-INSTALL" ]; then
+ rm -f %%LINUXBASE%%/etc/ld.so.cache
+ ( find %%LINUXBASE%% -name lib -type d | sed -e 's:%%LINUXBASE%%::g'; \
+ find %%PREFIX%% -name lib -type d | sed -e 's:%%PREFIX%%::g' ) \
+ | sort -u >%%LINUXBASE%%/etc/ld.so.conf
+ chroot %%LINUXBASE%% /sbin/ldconfig
+fi
diff --git a/x11/linux-gnomelibs/Makefile b/x11/linux-gnomelibs/Makefile
index 5c9d0fd95974..2abe16032092 100644
--- a/x11/linux-gnomelibs/Makefile
+++ b/x11/linux-gnomelibs/Makefile
@@ -7,10 +7,10 @@
PORTNAME= gnomelibs
PORTVERSION= 1.2.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 linux
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of gnome-libs
RPM_SET= gnome-libs-${PORTVERSION}-11.${MACHINE_ARCH}.rpm
diff --git a/x11/nvidia-driver/Makefile b/x11/nvidia-driver/Makefile
index bb1cd4c9ad6f..b607238c7c23 100644
--- a/x11/nvidia-driver/Makefile
+++ b/x11/nvidia-driver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nvidia-driver
PORTVERSION= 1.0.${NVVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= http://download.nvidia.com/freebsd/1.0-${NVVERSION}/ \
ftp://download.nvidia.com/freebsd/1.0-${NVVERSION}/ \
@@ -42,6 +42,7 @@ PLIST_SUB= XSERVVERSION=${XSERVVERSION} XLIBVERSION=${XLIBVERSION} \
.if !defined(WITHOUT_LINUX)
USE_LINUX= yes
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
PLIST_SUB+= LINUX=""
.else
PLIST_SUB+= LINUX="@comment "