aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-11-01 23:08:09 +0800
committerbsam <bsam@FreeBSD.org>2013-11-01 23:08:09 +0800
commit47b0cfe1069396ffe86d6a852fc7d93a285f9e0b (patch)
tree0281583f421a502dfffd54f838f884cd6e0f99d2 /x11
parent7de8e754d7c0665697927a5097c47aade918ac50 (diff)
downloadfreebsd-ports-gnome-47b0cfe1069396ffe86d6a852fc7d93a285f9e0b.tar.gz
freebsd-ports-gnome-47b0cfe1069396ffe86d6a852fc7d93a285f9e0b.tar.zst
freebsd-ports-gnome-47b0cfe1069396ffe86d6a852fc7d93a285f9e0b.zip
. support STAGE;
. convert USE_GMAKE to USES; . simplify Makefile and remove bsd.port.options.mk. PR: ports/183553 Submitted by: bsam (me) Approved by: nemysis (maintainer)
Diffstat (limited to 'x11')
-rw-r--r--x11/fbpanel/Makefile21
-rw-r--r--x11/fbpanel/pkg-plist1
2 files changed, 7 insertions, 15 deletions
diff --git a/x11/fbpanel/Makefile b/x11/fbpanel/Makefile
index 0dec922e3641..1ec9e7ebaf38 100644
--- a/x11/fbpanel/Makefile
+++ b/x11/fbpanel/Makefile
@@ -14,13 +14,10 @@ COMMENT= Lightweight, NETWM compliant X11 desktop panel
LICENSE= MIT
USE_BZIP2= yes
-USES= pkgconfig
+USES= gmake pkgconfig
USE_GNOME= gtk20
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
-USE_GMAKE= yes
-
-MAN1= ${PORTNAME}.1
PORTDOCS= CHANGELOG CREDITS NOTES README
@@ -29,21 +26,15 @@ OPTIONS_DEFINE= DOCS
DESKTOP_ENTRIES="${PORTNAME}" "${PORTNAME} NETWM compliant X11 desktop panel" \
"${PORTNAME}" "${PORTNAME}" "System;" false
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/scripts/install.sh
@${REINPLACE_CMD} -e 's|@DATADIR@|${DATADIR}|' \
- ${WRKSRC}/data/man/${MAN1}.in
+ ${WRKSRC}/data/man/${PORTNAME}.1.in
post-install:
- ${INSTALL_MAN} ${WRKSRC}/data/man/${MAN1} ${MAN1PREFIX}/man/man1
- ${LN} -sf ${DATADIR}/images/logo.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
-
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ ${INSTALL_MAN} ${WRKSRC}/data/man/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${LN} -sf ${DATADIR}/images/logo.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/x11/fbpanel/pkg-plist b/x11/fbpanel/pkg-plist
index 5d6698194dc1..404249a7e0ec 100644
--- a/x11/fbpanel/pkg-plist
+++ b/x11/fbpanel/pkg-plist
@@ -22,6 +22,7 @@ lib/fbpanel/tray.so
lib/fbpanel/volume.so
lib/fbpanel/wincmd.so
libexec/fbpanel/make_profile
+man/man1/fbpanel.1.gz
%%DATADIR%%/default
%%DATADIR%%/images/battery_0.png
%%DATADIR%%/images/battery_1.png