aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2004-09-30 06:21:49 +0800
committercy <cy@FreeBSD.org>2004-09-30 06:21:49 +0800
commit631f84c8b8d4dce36bda0039409ef0f7f8c604e0 (patch)
treea63303f6d9f2b72264bb8299b770bf6183975821 /x11
parent7618d31eb7ef5a635ebe3b41fca774a772d5c9e8 (diff)
downloadfreebsd-ports-gnome-631f84c8b8d4dce36bda0039409ef0f7f8c604e0.tar.gz
freebsd-ports-gnome-631f84c8b8d4dce36bda0039409ef0f7f8c604e0.tar.zst
freebsd-ports-gnome-631f84c8b8d4dce36bda0039409ef0f7f8c604e0.zip
Buffer addressing bugfix.
Noticed by: Nicolas Rachinsky <nicolas@rachinsky.de> Approved by: portmgr (marcus)
Diffstat (limited to 'x11')
-rw-r--r--x11/xcut/Makefile1
-rw-r--r--x11/xcut/files/patch-xcut.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11/xcut/Makefile b/x11/xcut/Makefile
index 238a5356fe5c..de51d3a1f7a2 100644
--- a/x11/xcut/Makefile
+++ b/x11/xcut/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xcut
PORTVERSION= 0.2
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://download.sourceforge.net/xcut/ \
http://acsys.anu.edu.au/~tpot/xcut/
diff --git a/x11/xcut/files/patch-xcut.c b/x11/xcut/files/patch-xcut.c
new file mode 100644
index 000000000000..7c41a1529fde
--- /dev/null
+++ b/x11/xcut/files/patch-xcut.c
@@ -0,0 +1,11 @@
+--- xcut.c.orig Mon Sep 20 22:55:33 1999
++++ xcut.c Wed Sep 29 09:50:24 2004
+@@ -94,7 +94,7 @@
+ /* Send data to stdout */
+
+ do {
+- num_written += write(STDOUT_FILENO, buffer, nbytes - num_written);
++ num_written += write(STDOUT_FILENO, buffer + num_written, nbytes - num_written);
+ } while (num_written < nbytes);
+
+ /* Clean up */