aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2005-12-24 09:55:20 +0800
committeradamw <adamw@FreeBSD.org>2005-12-24 09:55:20 +0800
commit907e31cf9d4a33979f68a80d546eb9fa31d53c8d (patch)
tree3aa2156a95352a987961b0ad5ba856d5315a2990 /x11
parent3f48aa64ef82b9b252db89d569f5a735e5e08d01 (diff)
downloadfreebsd-ports-gnome-907e31cf9d4a33979f68a80d546eb9fa31d53c8d.tar.gz
freebsd-ports-gnome-907e31cf9d4a33979f68a80d546eb9fa31d53c8d.tar.zst
freebsd-ports-gnome-907e31cf9d4a33979f68a80d546eb9fa31d53c8d.zip
Add ${PTHREAD_CFLAGS}/${PTHREAD_LIBS} to the CONFIGURE_ENV. There
appears to be some debate as to whether the root of this problem is the libtool 1.5.22 update, but adding pthread stuff here fixes the build problems I've been getting on 5-STABLE.
Diffstat (limited to 'x11')
-rw-r--r--x11/libgnome/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index 9c95010e7c45..7d9e96acb640 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -29,8 +29,8 @@ USE_GNOME= gnomeprefix gnomehack intlhack esound \
USE_BISON= yes
INSTALLS_SHLIB= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
SUB_FILES= pkg-deinstall