aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /x11
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'x11')
-rw-r--r--x11/p5-Clipboard/Makefile1
-rw-r--r--x11/p5-Clipboard/pkg-plist3
-rw-r--r--x11/p5-X11-GUITest/Makefile1
-rw-r--r--x11/p5-X11-GUITest/pkg-plist8
-rw-r--r--x11/p5-X11-IdleTime/Makefile1
-rw-r--r--x11/p5-X11-IdleTime/pkg-plist8
-rw-r--r--x11/p5-X11-Protocol/Makefile1
-rw-r--r--x11/p5-X11-Protocol/pkg-plist7
-rw-r--r--x11/p5-X11-Resolution/Makefile1
-rw-r--r--x11/p5-X11-Resolution/pkg-plist4
-rw-r--r--x11/xfce4-conf/Makefile6
-rw-r--r--x11/xfce4-conf/pkg-plist18
12 files changed, 16 insertions, 43 deletions
diff --git a/x11/p5-Clipboard/Makefile b/x11/p5-Clipboard/Makefile
index 3ff8ed171d8d..15aa936178f5 100644
--- a/x11/p5-Clipboard/Makefile
+++ b/x11/p5-Clipboard/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Clipboard
PORTVERSION= 0.13
+PORTREVISION= 1
CATEGORIES= x11 perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:KING
diff --git a/x11/p5-Clipboard/pkg-plist b/x11/p5-Clipboard/pkg-plist
index a775463ec7ac..6c947cc53e30 100644
--- a/x11/p5-Clipboard/pkg-plist
+++ b/x11/p5-Clipboard/pkg-plist
@@ -8,11 +8,8 @@ bin/clipjoin
%%SITE_PERL%%/Clipboard/MacPasteboard.pm
%%SITE_PERL%%/Clipboard/Win32.pm
%%SITE_PERL%%/Clipboard/Xclip.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Clipboard/.packlist
man/man1/clipaccumulate.1.gz
man/man1/clipbrowse.1.gz
man/man1/clipedit.1.gz
man/man1/clipfilter.1.gz
man/man1/clipjoin.1.gz
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Clipboard
-@dirrmtry %%SITE_PERL%%/Clipboard
diff --git a/x11/p5-X11-GUITest/Makefile b/x11/p5-X11-GUITest/Makefile
index 162d29cfa4ef..f7b135bf1ee7 100644
--- a/x11/p5-X11-GUITest/Makefile
+++ b/x11/p5-X11-GUITest/Makefile
@@ -3,6 +3,7 @@
PORTNAME= X11-GUITest
PORTVERSION= 0.28
+PORTREVISION= 1
CATEGORIES= x11 perl5
MASTER_SITES= CPAN \
SF/x11guitest/x11guitest/${PORTVERSION}
diff --git a/x11/p5-X11-GUITest/pkg-plist b/x11/p5-X11-GUITest/pkg-plist
index 01cb02eee475..3ab41b2009f3 100644
--- a/x11/p5-X11-GUITest/pkg-plist
+++ b/x11/p5-X11-GUITest/pkg-plist
@@ -1,7 +1,3 @@
%%PERL5_MAN3%%/X11::GUITest.3.gz
-%%SITE_PERL%%/%%PERL_ARCH%%/X11/GUITest.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/GUITest/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/GUITest/GUITest.so
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/GUITest
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/X11
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/X11
+%%SITE_ARCH%%/X11/GUITest.pm
+%%SITE_ARCH%%/auto/X11/GUITest/GUITest.so
diff --git a/x11/p5-X11-IdleTime/Makefile b/x11/p5-X11-IdleTime/Makefile
index 47f15e7984f4..e0e033f2db9b 100644
--- a/x11/p5-X11-IdleTime/Makefile
+++ b/x11/p5-X11-IdleTime/Makefile
@@ -3,6 +3,7 @@
PORTNAME= X11-IdleTime
PORTVERSION= 0.5
+PORTREVISION= 1
CATEGORIES= x11 perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/x11/p5-X11-IdleTime/pkg-plist b/x11/p5-X11-IdleTime/pkg-plist
index b4115f63d660..661e9979a824 100644
--- a/x11/p5-X11-IdleTime/pkg-plist
+++ b/x11/p5-X11-IdleTime/pkg-plist
@@ -1,7 +1,3 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/X11/IdleTime.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/IdleTime/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/IdleTime/IdleTime.so
+%%SITE_ARCH%%/X11/IdleTime.pm
+%%SITE_ARCH%%/auto/X11/IdleTime/IdleTime.so
%%PERL5_MAN3%%/X11::IdleTime.3.gz
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/IdleTime
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/X11
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/X11
diff --git a/x11/p5-X11-Protocol/Makefile b/x11/p5-X11-Protocol/Makefile
index ee12127baae7..44403bc25ff1 100644
--- a/x11/p5-X11-Protocol/Makefile
+++ b/x11/p5-X11-Protocol/Makefile
@@ -3,6 +3,7 @@
PORTNAME= X11-Protocol
PORTVERSION= 0.56
+PORTREVISION= 1
CATEGORIES= x11 perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/x11/p5-X11-Protocol/pkg-plist b/x11/p5-X11-Protocol/pkg-plist
index 0557aaa70fe1..f5230893953e 100644
--- a/x11/p5-X11-Protocol/pkg-plist
+++ b/x11/p5-X11-Protocol/pkg-plist
@@ -31,10 +31,3 @@
%%SITE_PERL%%/X11/Protocol/Ext/SHAPE.pm
%%SITE_PERL%%/X11/Protocol/Ext/XC_MISC.pm
%%SITE_PERL%%/X11/Protocol/Ext/XFree86_Misc.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/Protocol/.packlist
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/Protocol
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/X11
-@dirrmtry %%SITE_PERL%%/X11/Protocol/Ext
-@dirrmtry %%SITE_PERL%%/X11/Protocol/Connection
-@dirrmtry %%SITE_PERL%%/X11/Protocol
-@dirrmtry %%SITE_PERL%%/X11
diff --git a/x11/p5-X11-Resolution/Makefile b/x11/p5-X11-Resolution/Makefile
index cff62dba23ac..00297b98ad23 100644
--- a/x11/p5-X11-Resolution/Makefile
+++ b/x11/p5-X11-Resolution/Makefile
@@ -3,6 +3,7 @@
PORTNAME= X11-Resolution
PORTVERSION= 0.0.0
+PORTREVISION= 1
CATEGORIES= x11 perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/x11/p5-X11-Resolution/pkg-plist b/x11/p5-X11-Resolution/pkg-plist
index 45a73a8f2a78..6c8f2c301797 100644
--- a/x11/p5-X11-Resolution/pkg-plist
+++ b/x11/p5-X11-Resolution/pkg-plist
@@ -1,6 +1,2 @@
%%PERL5_MAN3%%/X11::Resolution.3.gz
%%SITE_PERL%%/X11/Resolution.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/Resolution/.packlist
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/Resolution
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/X11
-@dirrmtry %%SITE_PERL%%/X11
diff --git a/x11/xfce4-conf/Makefile b/x11/xfce4-conf/Makefile
index 221546d60cd0..3dc54da86567 100644
--- a/x11/xfce4-conf/Makefile
+++ b/x11/xfce4-conf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xfce4-conf
PORTVERSION= 4.10.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DISTNAME= xfconf-${PORTVERSION}
@@ -57,8 +57,4 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-post-install:
-.if ${PORT_OPTIONS:MPERL}
- @${RM} ${STAGEDIR}${PREFIX}/lib/perl5/${PERL_VER}/${PERL_ARCH}/perllocal.pod
-.endif
.include <bsd.port.mk>
diff --git a/x11/xfce4-conf/pkg-plist b/x11/xfce4-conf/pkg-plist
index bbb8f70791f2..03f867c80525 100644
--- a/x11/xfce4-conf/pkg-plist
+++ b/x11/xfce4-conf/pkg-plist
@@ -73,18 +73,12 @@ share/dbus-1/services/org.xfce.Xfconf.service
%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfconf.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfconf.mo
%%PERLBIND%%%%PERL5_MAN3%%/Xfce4::Xfconf.3.gz
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Xfce4/Xfconf/Xfconf.so
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Xfce4/Xfconf/.packlist
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf/Install/Files.pm
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf/Install/xfconfperl.h
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf/Install/xfconfperl-autogen.h
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf/Install/xfconfperl.typemap
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf.pm
-%%PERLBIND%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Xfce4/Xfconf
-%%PERLBIND%%@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Xfce4
-%%PERLBIND%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf/Install
-%%PERLBIND%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf
-%%PERLBIND%%@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Xfce4
+%%PERLBIND%%%%SITE_ARCH%%/auto/Xfce4/Xfconf/Xfconf.so
+%%PERLBIND%%%%SITE_ARCH%%/Xfce4/Xfconf/Install/Files.pm
+%%PERLBIND%%%%SITE_ARCH%%/Xfce4/Xfconf/Install/xfconfperl.h
+%%PERLBIND%%%%SITE_ARCH%%/Xfce4/Xfconf/Install/xfconfperl-autogen.h
+%%PERLBIND%%%%SITE_ARCH%%/Xfce4/Xfconf/Install/xfconfperl.typemap
+%%PERLBIND%%%%SITE_ARCH%%/Xfce4/Xfconf.pm
%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ur_PK
%%NLS%%@dirrmtry share/locale/ur/LC_MESSAGES