aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-06-23 02:33:20 +0800
committerantoine <antoine@FreeBSD.org>2015-06-23 02:33:20 +0800
commita271c81a691520343b54826252aba0c2600e31ab (patch)
treebdb6dbf3e5d4ada04784a3327eb91e0145530524 /x11
parent19ea8e358e68f9d94cca6a73917529e296948d19 (diff)
downloadfreebsd-ports-gnome-a271c81a691520343b54826252aba0c2600e31ab.tar.gz
freebsd-ports-gnome-a271c81a691520343b54826252aba0c2600e31ab.tar.zst
freebsd-ports-gnome-a271c81a691520343b54826252aba0c2600e31ab.zip
Convert to USES=jpeg
Diffstat (limited to 'x11')
-rw-r--r--x11/aterm/Makefile4
-rw-r--r--x11/dgs/Makefile5
-rw-r--r--x11/eaglemode/Makefile5
-rw-r--r--x11/kde4-runtime/Makefile3
-rw-r--r--x11/kde4-workspace/Makefile3
-rw-r--r--x11/kdelibs4/Makefile3
-rw-r--r--x11/mrxvt-devel/Makefile2
-rw-r--r--x11/mrxvt/Makefile4
-rw-r--r--x11/nxcomp/Makefile5
-rw-r--r--x11/slim/Makefile3
-rw-r--r--x11/xloadimage/Makefile4
-rw-r--r--x11/xscreensaver-gnome/Makefile5
-rw-r--r--x11/xscreensaver/Makefile5
13 files changed, 21 insertions, 30 deletions
diff --git a/x11/aterm/Makefile b/x11/aterm/Makefile
index cfd7328d9f9d..1fd77a602f81 100644
--- a/x11/aterm/Makefile
+++ b/x11/aterm/Makefile
@@ -41,8 +41,8 @@ BSDEL_CONFIGURE_OFF= --disable-backspace-key --disable-delete-key
BSDEL_CONFIGURE_ON= --enable-backspace-key --enable-delete-key
MOUSE_CONFIGURE_ENABLE= mousewheel
BGIMG_LIB_DEPENDS= libAfterImage.so:${PORTSDIR}/graphics/libafterimage \
- libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+ libpng.so:${PORTSDIR}/graphics/png
+BGIMG_USES= jpeg
BGIMG_CONFIGURE_ON= --with-afterimage-config --with-png --with-jpeg
BGIMG_CONFIGURE_OFF= --without-afterimage-config --with-png=no --with-jpeg=no
KANJI_CONFIGURE_ENABLE= kanji
diff --git a/x11/dgs/Makefile b/x11/dgs/Makefile
index b33a1b616936..fd463ae09e89 100644
--- a/x11/dgs/Makefile
+++ b/x11/dgs/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= GNU/../old-gnu/dgs
MAINTAINER= ports@FreeBSD.org
COMMENT= Display ghostscript system
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
MAKE_JOBS_UNSAFE= yes
@@ -19,7 +18,7 @@ MAKE_JOBS_UNSAFE= yes
USE_GHOSTSCRIPT_RUN= yes
USE_XORG= xt sm ice xext x11
USE_GNOME= glib12
-USES= gmake libtool makeinfo
+USES= gmake jpeg libtool makeinfo
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-0.5.9
diff --git a/x11/eaglemode/Makefile b/x11/eaglemode/Makefile
index d8056b9bb453..6ddaaead2a79 100644
--- a/x11/eaglemode/Makefile
+++ b/x11/eaglemode/Makefile
@@ -11,12 +11,11 @@ COMMENT= Futuristic zoomable user environment
LICENSE= GPLv3
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff \
libfreetype.so:${PORTSDIR}/print/freetype2
-USES= compiler:features perl5 pkgconfig shebangfix tar:bzip2
+USES= compiler:features jpeg perl5 pkgconfig shebangfix tar:bzip2
USE_PERL5= build
USE_XORG= x11 xext xxf86vm
SUB_FILES= eaglemode.sh
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 0642ea140663..0c591036024c 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -10,7 +10,6 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Runtime components for KDE Plasma Desktop
LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libexiv2.so:${PORTSDIR}/graphics/exiv2 \
libwebp.so:${PORTSDIR}/graphics/webp \
libslp.so:${PORTSDIR}/net/openslp \
@@ -24,7 +23,7 @@ RUN_DEPENDS= cagibid:${PORTSDIR}/net/cagibi
USE_KDE4= kactivities kdelibs kdeprefix oxygen \
attica automoc4 pimlibs strigi nepomuk-core
-USES= cmake:outsource gettext gmake shared-mime-info shebangfix tar:xz
+USES= cmake:outsource gettext gmake jpeg shared-mime-info shebangfix tar:xz
USE_QT4= corelib dbus declarative designer_build gui phonon \
network qtestlib script svg webkit xml \
moc_build qmake_build rcc_build uic_build
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 51f2c750a439..16b3078d0a7b 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -21,7 +21,6 @@ LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libxcb-render-util.so:${PORTSDIR}/x11/xcb-util-renderutil \
libxcb-image.so:${PORTSDIR}/x11/xcb-util-image \
libxcb-keysyms.so:${PORTSDIR}/x11/xcb-util-keysyms
@@ -45,7 +44,7 @@ USE_GL= glu
USE_GNOME= glib20
USE_KDE4= kactivities kdelibs kdeprefix nepomuk-core oxygen \
pimlibs akonadi automoc4 ontologies qimageblitz soprano strigi
-USES= cmake:outsource compiler:c++11-lib gettext gmake iconv \
+USES= cmake:outsource compiler:c++11-lib gettext gmake iconv jpeg \
pkgconfig tar:xz
USE_QT4= corelib dbus declarative designer_build gui network \
opengl phonon qtestlib script sql webkit xml \
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 02327477f41b..a33eabdfe2b5 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
libenchant.so:${PORTSDIR}/textproc/enchant \
libgif.so:${PORTSDIR}/graphics/giflib \
libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libhal.so:${PORTSDIR}/sysutils/hal \
libqca.so:${PORTSDIR}/devel/qca \
libHUpnp.so:${PORTSDIR}/net/hupnp \
@@ -36,7 +35,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicol
USE_GNOME= libxml2 libxslt
USE_KDE4= kdeprefix oxygen \
attica automoc4 ontologies soprano strigi
-USES= cmake:outsource fam gettext perl5 shared-mime-info shebangfix tar:xz
+USES= cmake:outsource fam gettext jpeg perl5 shared-mime-info shebangfix tar:xz
USE_OPENSSL= yes
USE_QT4= corelib dbus declarative designer_build gui \
network opengl phonon qt3support \
diff --git a/x11/mrxvt-devel/Makefile b/x11/mrxvt-devel/Makefile
index ff016a627263..dd1663bd0ebc 100644
--- a/x11/mrxvt-devel/Makefile
+++ b/x11/mrxvt-devel/Makefile
@@ -69,7 +69,7 @@ CONFIGURE_ARGS+= --disable-xpm
.if ! ${PORT_OPTIONS:MJPEG} || ! ${PORT_OPTIONS:MBACKGROUND}
CONFIGURE_ARGS+= --disable-jpeg
.else
-LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
+USES+= jpeg
.endif
.if ! ${PORT_OPTIONS:MPNG} || ! ${PORT_OPTIONS:MBACKGROUND}
diff --git a/x11/mrxvt/Makefile b/x11/mrxvt/Makefile
index fc12071c1f26..b00d875433d1 100644
--- a/x11/mrxvt/Makefile
+++ b/x11/mrxvt/Makefile
@@ -11,12 +11,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Tabbed version of rxvt
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
CONFLICTS= mrxvt-0.5.*
GNU_CONFIGURE= yes
+USES= jpeg
USE_XORG= x11
OPTIONS_DEFINE= DOCS JAPANESE XFT
diff --git a/x11/nxcomp/Makefile b/x11/nxcomp/Makefile
index 39af0bdc3b08..25519a51e37e 100644
--- a/x11/nxcomp/Makefile
+++ b/x11/nxcomp/Makefile
@@ -11,12 +11,11 @@ COMMENT= NX X11 protocol compression libraries
WRKSRC= ${WRKDIR}/nx-libs-${PORTVERSION}/${PORTNAME}
-USES= gmake
+USES= gmake jpeg
USE_AUTOTOOLS= autoconf
USE_XORG= xproto
GNU_CONFIGURE= yes
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
post-patch:
@${REINPLACE_CMD} -e "s,libdir}/nx,libdir},g" ${WRKSRC}/Makefile.in
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index 67768e773327..5604f34a66e5 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -15,12 +15,11 @@ LICENSE= GPLv2
LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
-USES= cmake pkgconfig
+USES= cmake jpeg pkgconfig
USE_XORG= ice sm x11 xau xcb xdmcp xext xft xmu xorg-server xrandr \
xrender xt
USE_RC_SUBR= slim
diff --git a/x11/xloadimage/Makefile b/x11/xloadimage/Makefile
index 804c2e6473a7..6efd88728b3b 100644
--- a/x11/xloadimage/Makefile
+++ b/x11/xloadimage/Makefile
@@ -15,8 +15,7 @@ COMMENT= X11 Image Loading Utility
LICENSE= MIT
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
CONFLICTS_INSTALL= xli-*
@@ -27,6 +26,7 @@ PATCH_STRIP= -p1
VERSION= ${PORTVERSION:R}
REVISION= ${PORTVERSION:E}
+USES= jpeg
USE_XORG= x11
GNU_CONFIGURE= yes
diff --git a/x11/xscreensaver-gnome/Makefile b/x11/xscreensaver-gnome/Makefile
index f5c89ce39390..8fc4f4dc3e77 100644
--- a/x11/xscreensaver-gnome/Makefile
+++ b/x11/xscreensaver-gnome/Makefile
@@ -12,8 +12,7 @@ DISTNAME= xscreensaver-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Save your screen while you entertain your cat (for GNOME users)
-LIB_DEPENDS= libgle.so:${PORTSDIR}/graphics/gle \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libgle.so:${PORTSDIR}/graphics/gle
#CONFLICTS?= xscreensaver-[0-9]* xscreensaver-gnome-hacks-[0-9]*
@@ -21,7 +20,7 @@ USE_XORG= x11 xpm
USE_GL= gl
USE_PERL5= run
USE_GNOME= libglade2
-USES+= dos2unix gettext gmake perl5 pathfix pkgconfig
+USES+= dos2unix gettext gmake jpeg perl5 pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk --with-gl --with-gle --with-pixbuf --with-xpm \
--with-jpeg=${LOCALBASE} --with-xshm-ext --with-xdbe-ext \
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 407336b94440..4356026658bb 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -12,14 +12,13 @@ COMMENT= Save your screen while you entertain your cat
RUN_DEPENDS= p5-libwww>0:${PORTSDIR}/www/p5-libwww \
giftopnm:${PORTSDIR}/graphics/netpbm
-LIB_DEPENDS= libgle.so:${PORTSDIR}/graphics/gle \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libgle.so:${PORTSDIR}/graphics/gle
DESTDIRNAME= install_prefix
CONFLICTS= xscreensaver-gnome-[0-9]* xscreensaver-gnome-hacks-[0-9]*
-USES= pkgconfig gettext gmake perl5
+USES= gettext gmake jpeg perl5 pkgconfig
USE_AUTOTOOLS= autoconf
USE_GL= yes
USE_GNOME= gdkpixbuf2 gtk20 intltool libglade2 libxml2