aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-05-12 15:11:22 +0800
committertobik <tobik@FreeBSD.org>2018-05-12 15:11:22 +0800
commitacb10854a451185cc5c78d4e218a0ef0f5208442 (patch)
tree2038bfdcb4508440c6a5c49e31354e21fc540dc3 /x11
parent8b1070a42c1396ecd93fba3970c3b7a76be21219 (diff)
downloadfreebsd-ports-gnome-acb10854a451185cc5c78d4e218a0ef0f5208442.tar.gz
freebsd-ports-gnome-acb10854a451185cc5c78d4e218a0ef0f5208442.tar.zst
freebsd-ports-gnome-acb10854a451185cc5c78d4e218a0ef0f5208442.zip
x11/polybar: Disable ALSA by default
It's broken on FreeBSD. - More modules have been tested; update pkg-message accordingly - Add TESTS option to build and run the unit tests - Fix IPC_DESC. It's built-in IPC and not i3 related. - Sort LIB_DEPENDS PR: 226507 Submitted by: Alexandre C. GuimarĂ£es <lebarondemerde@privacychain.ch> (based on) Approved by: capt_redbeard@protonmail.com (maintainer timeout, 2 months) Differential Revision: https://reviews.freebsd.org/D14644
Diffstat (limited to 'x11')
-rw-r--r--x11/polybar/Makefile21
-rw-r--r--x11/polybar/pkg-message18
2 files changed, 23 insertions, 16 deletions
diff --git a/x11/polybar/Makefile b/x11/polybar/Makefile
index 26aa9d8a04f9..a66d4ff53c28 100644
--- a/x11/polybar/Makefile
+++ b/x11/polybar/Makefile
@@ -2,7 +2,7 @@
PORTNAME= polybar
DISTVERSION= 3.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MAINTAINER= capt_redbeard@protonmail.com
@@ -14,13 +14,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= xcb-proto>=1.9:x11/xcb-proto
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
- libxcb-xrm.so:x11/xcb-util-xrm \
+ libinotify.so:devel/libinotify \
libxcb-cursor.so:x11/xcb-util-cursor \
libxcb-ewmh.so:x11/xcb-util-wm \
libxcb-icccm.so:x11/xcb-util-wm \
- libxcb-util.so:x11/xcb-util \
libxcb-image.so:x11/xcb-util-image \
- libinotify.so:devel/libinotify
+ libxcb-util.so:x11/xcb-util \
+ libxcb-xrm.so:x11/xcb-util-xrm
USES= cmake:outsource localbase:ldflags pkgconfig python:2.7,build
USE_GITHUB= yes
@@ -30,15 +30,16 @@ GH_TUPLE= jaagr:i3ipcpp:v0.7.1:i3ipcpp/lib/i3ipcpp \
USE_GNOME= cairo
USE_XORG= xcb
-OPTIONS_DEFINE= ALSA CURL EXAMPLES I3 IPC MPD
-OPTIONS_DEFAULT= ALSA CURL I3 IPC MPD
+OPTIONS_DEFINE= ALSA CURL EXAMPLES I3 IPC MPD TESTS
+OPTIONS_DEFAULT= CURL I3 IPC MPD
OPTIONS_SUB= yes
ALSA_DESC= Volume control
CURL_DESC= Github support
I3_DESC= i3wm support
+IPC_DESC= Built-in IPC support
MPD_DESC= Support for controlling MPD
-IPC_DESC= i3 IPC support
+TESTS_DESC= Build testsuite
ALSA_CMAKE_BOOL= ENABLE_ALSA
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
@@ -55,7 +56,13 @@ IPC_CMAKE_BOOL= BUILD_IPC_MSG
MPD_CMAKE_BOOL= ENABLE_MPD
MPD_LIB_DEPENDS= libmpdclient.so:audio/libmpdclient
+TESTS_CMAKE_BOOL= BUILD_TESTS
+
post-patch:
@${REINPLACE_CMD} -e 's|python2|${PYTHON_CMD}|g' ${WRKSRC_xpp}/CMakeLists.txt
+do-test-TESTS-on:
+ cd ${TEST_WRKSRC} && ${SETENV} BUILD_TESTS=ON \
+ ${SH} ${WRKSRC}/common/travis/tests.sh
+
.include <bsd.port.mk>
diff --git a/x11/polybar/pkg-message b/x11/polybar/pkg-message
index 9f55d43750a1..6fca0b6858ec 100644
--- a/x11/polybar/pkg-message
+++ b/x11/polybar/pkg-message
@@ -3,27 +3,27 @@ not function in FreeBSD.
Working modules:
- bspwm
-- cpu
- date
+- github
- i3
-- memory
+- ipc (polybar-msg method does not seem to work)
+- menu
+- mpd
- script
- text
- xkeyboard
- xwindow
+- xworkspaces (not extensively tested)
Broken modules:
+- cpu
- filesystem
+- memory
- network (requires wireless_tools)
- temperature (requires /sys/class/thermal/* in sysfs)
- volume (requires full alsa, not a wrapper)
-- menu (does not show up)
-- xbacklight
-- xworkspaces
-Not tested:
+Unknown:
- backlight
- battery
-- github
-- ipc
-- mpd
+- xbacklight