aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-25 23:18:27 +0800
committertijl <tijl@FreeBSD.org>2014-09-25 23:18:27 +0800
commitb20f32bb38994e1bb5de05cecc229f10659e0f49 (patch)
treec350c4abc20ce22bda0b7dba0636816742669bc8 /x11
parent20be128769eb36776631a3639656f9528820a14c (diff)
downloadfreebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.tar.gz
freebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.tar.zst
freebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.zip
- Set CPPFLAGS and LIBS in a number of ports so configure can find libintl.h
and libintl.so. This fixes a problem where DATADIRNAME gets an incorrect value which causes locale files to be installed in the wrong place. - The only configure checks that still need to be patched are related to intltool so move DATADIRNAME patching from USES=pathfix to USE_GNOME=intlhack. - games/klavaro: remove excessive dependencies - japanese/libskk: add INSTALL_TARGET=install-strip - math/libqalculate: add INSTALL_TARGET=install-strip and remove pthread patching - multimedia/freetuxtv: remove excessive dependencies - science/gramps: fix shared-mime-info use Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'x11')
-rw-r--r--x11/avant-window-navigator/Makefile2
-rw-r--r--x11/avant-window-navigator/files/patch-configure11
-rw-r--r--x11/mate-dialogs/Makefile6
-rw-r--r--x11/workrave/Makefile2
-rw-r--r--x11/xkeyboard-config/Makefile2
5 files changed, 17 insertions, 6 deletions
diff --git a/x11/avant-window-navigator/Makefile b/x11/avant-window-navigator/Makefile
index fe51b3256d0c..11f7872613e3 100644
--- a/x11/avant-window-navigator/Makefile
+++ b/x11/avant-window-navigator/Makefile
@@ -24,7 +24,7 @@ USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_XORG= x11 xproto xcomposite xrender
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
AWN_DESKTOP?= agnostic
diff --git a/x11/avant-window-navigator/files/patch-configure b/x11/avant-window-navigator/files/patch-configure
new file mode 100644
index 000000000000..664411230ee7
--- /dev/null
+++ b/x11/avant-window-navigator/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2009-05-02 19:05:57 UTC
++++ configure
+@@ -21567,6 +21567,8 @@
+ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+
+ # save current global flags
++ ac_save_LIBS="$LIBS"
++ ac_save_CPPFLAGS="$CPPFLAGS"
+ LIBS="$ac_save_LIBS $PYTHON_LDFLAGS"
+ CPPFLAGS="$ac_save_CPPFLAGS $PYTHON_CPPFLAGS"
+ cat >conftest.$ac_ext <<_ACEOF
diff --git a/x11/mate-dialogs/Makefile b/x11/mate-dialogs/Makefile
index cd4760c9833b..8bf7f52e816c 100644
--- a/x11/mate-dialogs/Makefile
+++ b/x11/mate-dialogs/Makefile
@@ -14,12 +14,12 @@ BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
PORTSCOUT= limitw:1,even
-USES= gettext gmake pathfix pkgconfig tar:xz
-USE_GNOME= gnomehier gtk20 intlhack
+USES= gettext gmake pkgconfig tar:xz
+USE_GNOME= gnomehier gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk=2.0
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -I${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= NOTIFY
OPTIONS_DEFAULT=NOTIFY
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index 8b4ae36c812d..b03f83be924f 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS= --disable-silent-rules --enable-gconf --disable-gnome3 \
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= GNOME GSTREAMER PULSEAUDIO
OPTIONS_DEFAULT= GSTREAMER
diff --git a/x11/xkeyboard-config/Makefile b/x11/xkeyboard-config/Makefile
index 469fa64f66bb..119c6f097ea6 100644
--- a/x11/xkeyboard-config/Makefile
+++ b/x11/xkeyboard-config/Makefile
@@ -22,7 +22,7 @@ INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --with-xkb-base=${PREFIX}/share/X11/xkb \
--with-xkb-rules-symlink=xorg
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= ETERSOFT
ETERSOFT_DESC= Add pre-1918 Russian letters to typographic layout