aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1998-09-04 15:17:26 +0800
committertg <tg@FreeBSD.org>1998-09-04 15:17:26 +0800
commitbb7a5d874c1b8e6472b536cc0ffb818f47b35a12 (patch)
tree768f5f74281b28b93d219cead78e839d3a237be4 /x11
parent6d04143432392d6c768755706ea4a254b71e0746 (diff)
downloadfreebsd-ports-gnome-bb7a5d874c1b8e6472b536cc0ffb818f47b35a12.tar.gz
freebsd-ports-gnome-bb7a5d874c1b8e6472b536cc0ffb818f47b35a12.tar.zst
freebsd-ports-gnome-bb7a5d874c1b8e6472b536cc0ffb818f47b35a12.zip
New port wdm, the WINGs Display Manager. This is an xdm replacement
which uses an external login program instead of xdm's standard greeter. I still need to find out why you can't change the logo for now. When this works some BSD pixmaps would be nice to have. Any artists among us?
Diffstat (limited to 'x11')
-rw-r--r--x11/wdm/Makefile40
-rw-r--r--x11/wdm/distinfo2
-rw-r--r--x11/wdm/files/patch-ab18
-rw-r--r--x11/wdm/pkg-comment1
-rw-r--r--x11/wdm/pkg-descr8
-rw-r--r--x11/wdm/pkg-plist26
6 files changed, 95 insertions, 0 deletions
diff --git a/x11/wdm/Makefile b/x11/wdm/Makefile
new file mode 100644
index 000000000000..d6466b6894e5
--- /dev/null
+++ b/x11/wdm/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: wdm
+# Version required: 0.11
+# Date created: August 31, 1998
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+
+DISTNAME= wdm-0.11
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.windowmaker.org/pub/contrib/srcs/utils/ \
+ ftp://ftp.io.com/pub/mirror/windowmaker/contrib/srcs/utils/ \
+ http://www.de.freebsd.org/de/gif/bsd/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DAEMONPIC}
+
+MAINTAINER= ports@FreeBSD.ORG
+
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm \
+ jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
+ png\\.2\\.:${PORTSDIR}/graphics/png \
+ tiff34\\.1:${PORTSDIR}/graphics/tiff34 \
+ PropList\\.0\\.8:${PORTSDIR}/x11-wm/windowmaker
+
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+DIST_SUBDIR= wdm
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= X11BASE=${X11BASE} CPPFLAGS=-I${PREFIX}/include
+CONFIGURE_ARGS= --with-gfx-libs="-L${PREFIX}/lib -L${LOCALBASE}/lib" \
+ --with-gfx-incs="-I${LOCALBASE}/include/tiff34 -I${LOCALBASE}/include" \
+ --with-logdir=/var/log --with-runlockdir=/var/run \
+ --with-WDMDIR=${PREFIX}/lib/X11/wdm
+
+MAN1= wdm.1 wdmLogin.1
+
+DAEMONPIC= daemon1-HQ-1280x960.jpg
+
+post-install:
+ ${INSTALL_DATA} ${_DISTDIR}/${DAEMONPIC} ${PREFIX}/lib/X11/wdm/pixmaps
+
+.include <bsd.port.mk>
diff --git a/x11/wdm/distinfo b/x11/wdm/distinfo
new file mode 100644
index 000000000000..8735eecb487a
--- /dev/null
+++ b/x11/wdm/distinfo
@@ -0,0 +1,2 @@
+MD5 (wdm/wdm-0.11.tar.gz) = 3975cbb775bac15612eb282c0ed123fe
+MD5 (wdm/daemon1-HQ-1280x960.jpg) = b38f175cf6b7167484afac423837ed1a
diff --git a/x11/wdm/files/patch-ab b/x11/wdm/files/patch-ab
new file mode 100644
index 000000000000..6fdf1fd9f62d
--- /dev/null
+++ b/x11/wdm/files/patch-ab
@@ -0,0 +1,18 @@
+--- src/config/wdm-config.in.orig Wed Aug 19 19:20:59 1998
++++ src/config/wdm-config.in Thu Sep 3 18:54:01 1998
+@@ -21,12 +21,11 @@
+ DisplayManager*session: #configdir#/Xsession
+ DisplayManager*authComplain: false
+ DisplayManager*wdmLogin: #bindir#/wdmLogin
+-DisplayManager*wdmBg: solid:RoyalBlue
++DisplayManager*wdmBg: pixmap:#configdir#/pixmaps/daemon1-HQ-1280x960.jpg
+ ! DisplayManager*wdmBg: dgradient:RoyalBlue,FireBrick,Black
+-! DisplayManager*wdmLogo: #configdir#/pixmaps/Eagle.xpm
+-DisplayManager*wdmWm: wmaker:afterstep
++DisplayManager*wdmLogo: #configdir#/pixmaps/Earth200x130.xpm
++DisplayManager*wdmWm: wmaker:afterstep:ctwm:enlightenment:fvwm:fvwm2:fvwm95:olvwm:qvwm:tvtwm
+ DisplayManager*wdmReboot: #SHUTDOWN# -t3 -r now
+ DisplayManager*wdmHalt: #SHUTDOWN# -t3 -h now
+ DisplayManager*wdmVerify: true
+ DisplayManager*wdmRoot: false
+-
diff --git a/x11/wdm/pkg-comment b/x11/wdm/pkg-comment
new file mode 100644
index 000000000000..0d4a7c99dccf
--- /dev/null
+++ b/x11/wdm/pkg-comment
@@ -0,0 +1 @@
+WINGs Display Manager; an xdm replacement.
diff --git a/x11/wdm/pkg-descr b/x11/wdm/pkg-descr
new file mode 100644
index 000000000000..a16e6ff7bd34
--- /dev/null
+++ b/x11/wdm/pkg-descr
@@ -0,0 +1,8 @@
+wdm -- WINGs Display Manager
+
+wdm was initially called DisplayMaker.
+
+This is a modification of XFree86's xdm package for graphically
+handling authentication and system login. Most of xdm has been
+preserved (XFree86 3.3.2) with the Login interface based on a WINGs
+implementation using Tom Rothamel's "external greet" interface.
diff --git a/x11/wdm/pkg-plist b/x11/wdm/pkg-plist
new file mode 100644
index 000000000000..fc824e7cdc44
--- /dev/null
+++ b/x11/wdm/pkg-plist
@@ -0,0 +1,26 @@
+bin/wdm
+bin/wdmLogin
+lib/X11/wdm/GiveConsole
+lib/X11/wdm/TakeConsole
+lib/X11/wdm/Xaccess
+lib/X11/wdm/Xclients
+lib/X11/wdm/Xresources
+lib/X11/wdm/Xservers
+lib/X11/wdm/Xservers.fs
+lib/X11/wdm/Xservers.ws
+lib/X11/wdm/Xsession
+lib/X11/wdm/Xsetup_0
+lib/X11/wdm/pixmaps/Eagle.xpm
+lib/X11/wdm/pixmaps/Earth.jpg
+lib/X11/wdm/pixmaps/Earth200x130.xpm
+lib/X11/wdm/pixmaps/GnuLinux-logo.jpg
+lib/X11/wdm/pixmaps/README
+lib/X11/wdm/pixmaps/Stars.jpg
+lib/X11/wdm/pixmaps/StarsLogo.jpg
+lib/X11/wdm/pixmaps/daemon1-HQ-1280x960.jpg
+lib/X11/wdm/pixmaps/gnuLogo.xpm
+lib/X11/wdm/wdm-config
+@dirrm lib/X11/wdm/pixmaps
+@unexec rmdir %D/lib/X11/wdm/authdir/authfiles 2>/dev/null || true
+@dirrm lib/X11/wdm/authdir
+@dirrm lib/X11/wdm