aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-09-04 02:22:24 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-09-04 02:22:24 +0800
commitbb86f29b9d4eb3e09ec420fddc9b3f208bf29140 (patch)
treee8e835c137c036941c21ebd7f5b57c5d5bec9bde /x11
parent2bdd080781610fe6c209f35239b3cfe8c2c70f70 (diff)
downloadfreebsd-ports-gnome-bb86f29b9d4eb3e09ec420fddc9b3f208bf29140.tar.gz
freebsd-ports-gnome-bb86f29b9d4eb3e09ec420fddc9b3f208bf29140.tar.zst
freebsd-ports-gnome-bb86f29b9d4eb3e09ec420fddc9b3f208bf29140.zip
- Make luit wide character conversion support optionsl [1]
- Don't pass CPPFLAGS to CONFIGURE_ENV it is already passed in CONFIGURE_ENV via bsd.port.mk Submitted by: Alex Kozlov <spam@rm-rf.kiev.ua> [1] (via mail)
Diffstat (limited to 'x11')
-rw-r--r--x11/xterm/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/x11/xterm/Makefile b/x11/xterm/Makefile
index ac2e392fb7fb..36ae27b419d6 100644
--- a/x11/xterm/Makefile
+++ b/x11/xterm/Makefile
@@ -15,24 +15,29 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Terminal emulator for the X Window System
-BUILD_DEPENDS= luit:${PORTSDIR}/x11/luit
-
USE_XORG= xaw xft
USE_GNOME= desktopfileutils
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+=--with-utempter --enable-narrowproto
OPTIONS= WIDE_CHARS "enable wide-character support" on \
+ LUIT "use LUIT for locale convertion from/to UTF-8" on \
256_COLOR "enable 256-color support" off \
DEC_LOCATOR "enable DECterm Locator support" off \
PCRE "use PCRE for regular-expressions" off
+CPPFLAGS+= -I${LOCALBASE}/include
+
.include <bsd.port.options.mk>
+.if defined(WITH_LUIT)
+CONFIGURE_ARGS+= --enable-luit
+BUILD_DEPENDS= luit:${PORTSDIR}/x11/luit
+.endif
+
.if defined(WITH_WIDE_CHARS)
-CONFIGURE_ARGS+= --enable-wide-chars --enable-luit
+CONFIGURE_ARGS+= --enable-wide-chars
.endif
.if defined(WITH_256_COLOR)