aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-07-04 22:22:41 +0800
committerwg <wg@FreeBSD.org>2013-07-04 22:22:41 +0800
commitc1fecb474880c3dd8fed9e1bd37eced94a1ddf39 (patch)
tree149d060494eea3efe84eaf44356e1e54aa57f2b3 /x11
parent92ffdf389dff5741926b24467cf2005384bc6846 (diff)
downloadfreebsd-ports-gnome-c1fecb474880c3dd8fed9e1bd37eced94a1ddf39.tar.gz
freebsd-ports-gnome-c1fecb474880c3dd8fed9e1bd37eced94a1ddf39.tar.zst
freebsd-ports-gnome-c1fecb474880c3dd8fed9e1bd37eced94a1ddf39.zip
x11/fbpanel: minor fixes
- Remove unnecessary PORTDCOS from pkg-plist - Mute mkdir - Trim desktop entry and replace command PR: ports/180112 Submitted by: nemysis <nemysis@gmx.ch> (maintainer)
Diffstat (limited to 'x11')
-rw-r--r--x11/fbpanel/Makefile19
-rw-r--r--x11/fbpanel/pkg-plist5
2 files changed, 6 insertions, 18 deletions
diff --git a/x11/fbpanel/Makefile b/x11/fbpanel/Makefile
index d3f545d1788c..f779c34073ab 100644
--- a/x11/fbpanel/Makefile
+++ b/x11/fbpanel/Makefile
@@ -14,11 +14,11 @@ COMMENT= Lightweight, NETWM compliant X11 desktop panel
LICENSE= MIT
USE_BZIP2= yes
+USES= pkgconfig
+USE_GNOME= gtk20
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
USE_GMAKE= yes
-USE_GNOME= gtk20
-USES= pkgconfig
MAN1= ${PORTNAME}.1
@@ -27,28 +27,21 @@ PORTDOCS= CHANGELOG CREDITS NOTES README
OPTIONS_DEFINE= DOCS
DESKTOP_ENTRIES="${PORTNAME}" "${PORTNAME} NETWM compliant X11 desktop panel" \
- "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
- "${PORTNAME}" "System;" false
+ "${PORTNAME}" "${PORTNAME}" "System;" false
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-PLIST_SUB+= PORTDOCS=""
-.else
-PLIST_SUB+= PORTDOCS="@comment "
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e 's|bash|sh|' ${WRKSRC}/scripts/install.sh
+ @${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/scripts/install.sh
@${REINPLACE_CMD} -e 's|@DATADIR@|${DATADIR}|' \
${WRKSRC}/data/man/${MAN1}.in
post-install:
- ${INSTALL_MAN} ${WRKSRC}/data/man/${MAN1} ${MAN1PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/data/man/${MAN1} ${MAN1PREFIX}/man/man1
${LN} -sf ${DATADIR}/images/logo.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
diff --git a/x11/fbpanel/pkg-plist b/x11/fbpanel/pkg-plist
index af6e2d8863e4..5d6698194dc1 100644
--- a/x11/fbpanel/pkg-plist
+++ b/x11/fbpanel/pkg-plist
@@ -22,10 +22,6 @@ lib/fbpanel/tray.so
lib/fbpanel/volume.so
lib/fbpanel/wincmd.so
libexec/fbpanel/make_profile
-%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
-%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/NOTES
-%%PORTDOCS%%%%DOCSDIR%%/README
%%DATADIR%%/default
%%DATADIR%%/images/battery_0.png
%%DATADIR%%/images/battery_1.png
@@ -55,6 +51,5 @@ libexec/fbpanel/make_profile
share/pixmaps/fbpanel.png
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm libexec/fbpanel
@dirrm lib/fbpanel