aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-02-06 04:56:24 +0800
committerlofi <lofi@FreeBSD.org>2007-02-06 04:56:24 +0800
commite66bdb544bf6fe96d5a45c95518a6422775271b4 (patch)
treefb8cebf6a9ce568966bd68c924e5e2d54e27be82 /x11
parent1ceef0896292eb830cc1ce993a41b8fea4d719f8 (diff)
downloadfreebsd-ports-gnome-e66bdb544bf6fe96d5a45c95518a6422775271b4.tar.gz
freebsd-ports-gnome-e66bdb544bf6fe96d5a45c95518a6422775271b4.tar.zst
freebsd-ports-gnome-e66bdb544bf6fe96d5a45c95518a6422775271b4.zip
Add qt4, a multiplatform C++ application framework
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile2
-rw-r--r--x11/qt4-inputmethods/Makefile66
-rw-r--r--x11/qt4-inputmethods/distinfo3
-rw-r--r--x11/qt4-inputmethods/pkg-descr12
-rw-r--r--x11/qt4-inputmethods/pkg-plist3
-rw-r--r--x11/qt4-opengl/Makefile76
-rw-r--r--x11/qt4-opengl/distinfo3
-rw-r--r--x11/qt4-opengl/pkg-descr12
-rw-r--r--x11/qt4-opengl/pkg-plist25
9 files changed, 202 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 1df2ff6033d6..84fa166b57ae 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -192,6 +192,8 @@
SUBDIR += printext
SUBDIR += props
SUBDIR += qrash
+ SUBDIR += qt4-inputmethods
+ SUBDIR += qt4-opengl
SUBDIR += randrext
SUBDIR += rendercheck
SUBDIR += renderext
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
new file mode 100644
index 000000000000..6aebf51e26cf
--- /dev/null
+++ b/x11/qt4-inputmethods/Makefile
@@ -0,0 +1,66 @@
+# -*-mode: makefile-*-
+# New ports collection makefile for: qt40
+# Date created: Wed Jun 29 11:49:42 CEST 2005
+# Whom: lofi@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= inputmethods
+PORTVERSION= 4.2.2
+CATEGORIES?= x11
+MASTER_SITES= ${MASTER_SITE_QT}
+PKGNAMEPREFIX= qt4-
+DISTNAME= qt-x11-opensource-src-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt input method plugins
+
+BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+ qmake-qt4:${PORTSDIR}/devel/qmake4
+LIB_DEPENDS= QtCore:${PORTSDIR}/devel/qt4-corelib \
+ QtGui:${PORTSDIR}/x11-toolkits/qt4-gui
+
+CONFLICTS= linguist-0.* qt-2.* qt-3.0.* \
+ qt-3.1.* qt-3.2.* qt-designer-2.* xfmail-1.5.[0-5] \
+ xfmail-1.5.5_[1-2]
+
+HAS_CONFIGURE= yes
+
+CONFIGURE_ARGS= -fast -no-exceptions \
+ -platform ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
+ -qt-gif -release -system-libjpeg -system-libpng \
+ -system-zlib -prefix ${PREFIX} \
+ -plugindir ${PREFIX}/lib/plugins -bindir ${PREFIX}/bin \
+ -confirm-license
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+ PATH=${WRKSRC}/bin:$$PATH
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
+ --exclude '${DISTNAME}/mkspecs' --exclude '${DISTNAME}/qmake' \
+ --exclude '${DISTNAME}/demos' --exclude '${DISTNAME}/examples' \
+ --exclude '${DISTNAME}/src/network' --exclude '${DISTNAME}/src/xml' \
+ --exclude '${DISTNAME}/src/opengl' --exclude '${DISTNAME}/src/qt3support' \
+ --exclude '${DISTNAME}/src/sql' \
+ --exclude '${DISTNAME}/src/tools/moc' --exclude '${DISTNAME}/src/tools/uic' \
+ --exclude '${DISTNAME}/src/tools/rcc' --exclude '${DISTNAME}/src/tools/uic3' \
+ --exclude '${DISTNAME}/tools/assistant' \
+ --exclude '${DISTNAME}/tools/linguist' --exclude '${DISTNAME}/tools/porting' \
+ --exclude '${DISTNAME}/tools/qtconfig' --exclude '${DISTNAME}/tools/qvfb'
+WRKSRC= ${WRKDIR}/${DISTNAME}/src/plugins/${PORTNAME}
+CONFIGURE_WRKSRC=${WRKSRC}/../../..
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
+ ${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib/plugins/inputmethods|g' \
+ ${WRKSRC}/imsw-multi/imsw-multi.pro
+ ${MKDIR} ${WRKSRC}/../../../mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../../bin/moc
+
+.include <bsd.port.post.mk>
diff --git a/x11/qt4-inputmethods/distinfo b/x11/qt4-inputmethods/distinfo
new file mode 100644
index 000000000000..5f51cf7b1256
--- /dev/null
+++ b/x11/qt4-inputmethods/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 19f6374fe7924e33775cb87ee02669cb
+SHA256 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = e790d227fa7958f2b0c0b0facd8ca880190121ed2b9c99ca70643baf7a0cd24c
+SIZE (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 37636491
diff --git a/x11/qt4-inputmethods/pkg-descr b/x11/qt4-inputmethods/pkg-descr
new file mode 100644
index 000000000000..efc79b9aaf24
--- /dev/null
+++ b/x11/qt4-inputmethods/pkg-descr
@@ -0,0 +1,12 @@
+Qt is a C++ toolkit for application development. It lets application
+developers target all major operating systems with a single application
+source code.
+
+Qt provides a platform-independent API to all central platform functionality:
+GUI, database access, networking, file handling, etc. The Qt library
+encapsulates the different APIs of different operating systems, providing
+the application programmer with a single, common API for all operating systems.
+The native C APIs are encapsulated in a set of well-designed, fully
+object-oriented C++ classes.
+
+WWW: http://www.trolltech.com/products/qt/index.html
diff --git a/x11/qt4-inputmethods/pkg-plist b/x11/qt4-inputmethods/pkg-plist
new file mode 100644
index 000000000000..a74e769e120c
--- /dev/null
+++ b/x11/qt4-inputmethods/pkg-plist
@@ -0,0 +1,3 @@
+lib/plugins/inputmethods/libqimsw-multi.so
+lib/plugins/inputmethods/libqimsw-multi.so.debug
+@dirrm lib/plugins/inputmethods
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
new file mode 100644
index 000000000000..cc2e519581d4
--- /dev/null
+++ b/x11/qt4-opengl/Makefile
@@ -0,0 +1,76 @@
+# -*-mode: makefile-*-
+# New ports collection makefile for: qt40
+# Date created: Wed Jun 29 11:49:42 CEST 2005
+# Whom: lofi@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= opengl
+PORTVERSION= 4.2.2
+CATEGORIES?= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_QT}
+PKGNAMEPREFIX= qt4-
+DISTNAME= qt-x11-opensource-src-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt OpenGL library
+
+BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+ qmake-qt4:${PORTSDIR}/devel/qmake4
+LIB_DEPENDS?= QtCore:${PORTSDIR}/devel/qt4-corelib \
+ QtGui:${PORTSDIR}/x11-toolkits/qt4-gui
+
+CONFLICTS= linguist-0.* qt-2.* qt-3.0.* \
+ qt-3.1.* qt-3.2.* qt-designer-2.* xfmail-1.5.[0-5] \
+ xfmail-1.5.5_[1-2]
+
+HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
+NO_FILTER_SHLIBS=yes
+USE_XLIB= yes
+
+CONFIGURE_ARGS= -fast -no-exceptions \
+ -platform ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
+ -qt-gif -release -system-libjpeg -system-libpng \
+ -system-zlib -prefix ${PREFIX} \
+ -plugindir ${PREFIX}/lib/plugins -bindir ${PREFIX}/bin \
+ -no-nas-sound -confirm-license
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+ PATH=${WRKSRC}/bin:$$PATH
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
+ --exclude '${DISTNAME}/mkspecs' --exclude '${DISTNAME}/qmake' \
+ --exclude '${DISTNAME}/demos' --exclude '${DISTNAME}/examples' \
+ --exclude '${DISTNAME}/src/network' \
+ --exclude '${DISTNAME}/src/xml' --exclude '${DISTNAME}/src/qt3support' \
+ --exclude '${DISTNAME}/src/sql' --exclude '${DISTNAME}/src/plugins' \
+ --exclude '${DISTNAME}/src/3rdparty' --exclude '${DISTNAME}/src/tools/moc' \
+ --exclude '${DISTNAME}/src/tools/rcc' \
+ --exclude '${DISTNAME}/src/tools/uic' --exclude '${DISTNAME}/src/tools/uic3' \
+ --exclude '${DISTNAME}/tools/assistant' \
+ --exclude '${DISTNAME}/tools/linguist' --exclude '${DISTNAME}/tools/porting' \
+ --exclude '${DISTNAME}/tools/qtconfig' --exclude '${DISTNAME}/tools/qvfb'
+WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
+CONFIGURE_WRKSRC=${WRKSRC}/../../
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
+ ${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
+ -e 's|flat_headers.path.*|flat_headers.path=${PREFIX}/include/Qt|g' \
+ -e 's|targ_headers.path.*|targ_headers.path=${PREFIX}/include/$$$$TARGET|g' \
+ ${WRKSRC}/${PORTNAME}.pro ${WRKSRC}/../qt_install.pri
+ ${MKDIR} ${WRKSRC}/../../mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../bin/moc
+
+post-configure:
+ ${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtOpenGL.pc|${PREFIX}/libdata/pkgconfig/QtOpenGL.pc|g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.post.mk>
diff --git a/x11/qt4-opengl/distinfo b/x11/qt4-opengl/distinfo
new file mode 100644
index 000000000000..5f51cf7b1256
--- /dev/null
+++ b/x11/qt4-opengl/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 19f6374fe7924e33775cb87ee02669cb
+SHA256 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = e790d227fa7958f2b0c0b0facd8ca880190121ed2b9c99ca70643baf7a0cd24c
+SIZE (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 37636491
diff --git a/x11/qt4-opengl/pkg-descr b/x11/qt4-opengl/pkg-descr
new file mode 100644
index 000000000000..efc79b9aaf24
--- /dev/null
+++ b/x11/qt4-opengl/pkg-descr
@@ -0,0 +1,12 @@
+Qt is a C++ toolkit for application development. It lets application
+developers target all major operating systems with a single application
+source code.
+
+Qt provides a platform-independent API to all central platform functionality:
+GUI, database access, networking, file handling, etc. The Qt library
+encapsulates the different APIs of different operating systems, providing
+the application programmer with a single, common API for all operating systems.
+The native C APIs are encapsulated in a set of well-designed, fully
+object-oriented C++ classes.
+
+WWW: http://www.trolltech.com/products/qt/index.html
diff --git a/x11/qt4-opengl/pkg-plist b/x11/qt4-opengl/pkg-plist
new file mode 100644
index 000000000000..ba0f14409a79
--- /dev/null
+++ b/x11/qt4-opengl/pkg-plist
@@ -0,0 +1,25 @@
+include/Qt/QtOpenGL
+include/Qt/qgl.h
+include/Qt/qglcolormap.h
+include/Qt/qglframebufferobject.h
+include/Qt/qglpixelbuffer.h
+include/QtOpenGL/QGLColormap
+include/QtOpenGL/QGLContext
+include/QtOpenGL/QGLFormat
+include/QtOpenGL/QGLFramebufferObject
+include/QtOpenGL/QGLPixelBuffer
+include/QtOpenGL/QGLWidget
+include/QtOpenGL/QtOpenGL
+include/QtOpenGL/qgl.h
+include/QtOpenGL/qglcolormap.h
+include/QtOpenGL/qglframebufferobject.h
+include/QtOpenGL/qglpixelbuffer.h
+lib/libQtOpenGL.la
+lib/libQtOpenGL.prl
+lib/libQtOpenGL.so
+lib/libQtOpenGL.so.4
+lib/libQtOpenGL.so.4.2
+lib/libQtOpenGL.so.4.2.2
+lib/libQtOpenGL.so.4.2.2.debug
+libdata/pkgconfig/QtOpenGL.pc
+@dirrm include/QtOpenGL