aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-07-26 14:47:04 +0800
committerbapt <bapt@FreeBSD.org>2013-07-26 14:47:04 +0800
commitf5a3d9aa334306dc0911e30675e3c2ad5cb92604 (patch)
treeccbec4670156f69d1163aa4a91664ba36dd7f8b9 /x11
parent8e8c0ff2cfbb82f02ce7565116af71e2bd25dec6 (diff)
downloadfreebsd-ports-gnome-f5a3d9aa334306dc0911e30675e3c2ad5cb92604.tar.gz
freebsd-ports-gnome-f5a3d9aa334306dc0911e30675e3c2ad5cb92604.tar.zst
freebsd-ports-gnome-f5a3d9aa334306dc0911e30675e3c2ad5cb92604.zip
Fix build with linker that does not copy the dt_need from libraries it links
with like recent binutils.
Diffstat (limited to 'x11')
-rw-r--r--x11/xvattr/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11/xvattr/Makefile b/x11/xvattr/Makefile
index 918086f7ba8f..f6bcfa0fd508 100644
--- a/x11/xvattr/Makefile
+++ b/x11/xvattr/Makefile
@@ -38,9 +38,9 @@ post-extract:
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} ${PORTNAME}.c -o ${PORTNAME} \
- `pkg-config --cflags --libs xv`
+ `pkg-config --cflags --libs xv x11`
cd ${WRKSRC} && ${CC} ${CFLAGS} g${PORTNAME}.c -o g${PORTNAME} \
- `pkg-config --cflags --libs ${GTK_PC} xv`
+ `pkg-config --cflags --libs ${GTK_PC} xv x11`
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin