aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2007-08-03 06:08:32 +0800
committerthierry <thierry@FreeBSD.org>2007-08-03 06:08:32 +0800
commitf7bec0a60889d39376e4a9a13050951960059bb2 (patch)
tree36dac8d662aa9b8ba11c39814e0dd4ad21478f69 /x11
parent4a0539d1d4f92822740dd512897b69116f3a781a (diff)
downloadfreebsd-ports-gnome-f7bec0a60889d39376e4a9a13050951960059bb2.tar.gz
freebsd-ports-gnome-f7bec0a60889d39376e4a9a13050951960059bb2.tar.zst
freebsd-ports-gnome-f7bec0a60889d39376e4a9a13050951960059bb2.zip
Enable AfterImage's support by default.
Diffstat (limited to 'x11')
-rw-r--r--x11/rxvt-unicode/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index 0b8bb0d5b165..cc1590e46459 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rxvt-unicode
PORTVERSION= 8.3
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://dist.schmorp.de/rxvt-unicode/%SUBDIR%/
MASTER_SITE_SUBDIR= . Attic
@@ -24,6 +25,7 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
USE_X_PREFIX= yes
USE_XPM= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include"
CONFIGURE_ARGS= --enable-shared --enable-everything --with-term=rxvt \
--x-includes=${X11BASE}/include --x-libraries=${X11BASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -131,12 +133,12 @@ PLIST_SUB+= TERMINFO=""
.endif
# enable integration with libAfterImage for background images
-#.if defined(WITHOUT_AFTERIMAGE)
+.if defined(WITHOUT_AFTERIMAGE)
CONFIGURE_ARGS+= --disable-afterimage # To be upgraded
-#.else
-#LIB_DEPENDS+= AfterImage.0:${PORTSDIR}/graphics/libafterimage
-#CONFIGURE_ARGS+= --enable-afterimage
-#.endif
+.else
+LIB_DEPENDS+= AfterImage.0:${PORTSDIR}/graphics/libafterimage
+CONFIGURE_ARGS+= --enable-afterimage
+.endif
CONFIGURE_ENV+= LIBS="-lutil"
@@ -185,7 +187,7 @@ pre-everything::
@${ECHO_MSG} "WITHOUT_SMART_RESIZE disable smart growth/shrink behaviour"
@${ECHO_MSG} "WITHOUT_IMLOCALE_FIX disable imlocale encoding conversion fix"
@${ECHO_MSG} "WITHOUT_TERMINFO don't register urxvt in the terminfo database"
- #@${ECHO_MSG} "WITHOUT_AFTERIMAGE disable integration with libAfterImage for background images"
+ @${ECHO_MSG} "WITHOUT_AFTERIMAGE disable integration with libAfterImage for background images"
@${ECHO_MSG}
.ifndef(WITH_ENCODING)
@${ECHO_MSG} "==> You can compile in support for additional codeset groups by setting the WITH_ENCODING variable"