aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2012-11-27 21:10:41 +0800
committermadpilot <madpilot@FreeBSD.org>2012-11-27 21:10:41 +0800
commitff9e6152846341c22016d873a54141073d0ae4c5 (patch)
treebc05742ea761776593dd34348f4ccdd55f36bf4b /x11
parent390bf48840dcbf9e5bed7ad42dafca813271c11f (diff)
downloadfreebsd-ports-gnome-ff9e6152846341c22016d873a54141073d0ae4c5.tar.gz
freebsd-ports-gnome-ff9e6152846341c22016d873a54141073d0ae4c5.tar.zst
freebsd-ports-gnome-ff9e6152846341c22016d873a54141073d0ae4c5.zip
- Update to 0.3
- Use new options framework for DOCS - Trim Makefile headers PR: ports/173941 Submitted by: Matthew Donovan <kitche@kitchetech.com> (maintainer) Feature safe: yes
Diffstat (limited to 'x11')
-rw-r--r--x11/sterm/Makefile16
-rw-r--r--x11/sterm/distinfo4
-rw-r--r--x11/sterm/files/patch-Makefile10
-rw-r--r--x11/sterm/files/patch-config.mk26
4 files changed, 23 insertions, 33 deletions
diff --git a/x11/sterm/Makefile b/x11/sterm/Makefile
index 1f6797452874..24fe1909dae4 100644
--- a/x11/sterm/Makefile
+++ b/x11/sterm/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: sterm
-# Date created: April 01, 2011
-# Whom: Matthew Donovan <kitchetech@gmail.com>
-#
+# Created by: Matthew Donovan <kitchetech@gmail.com>
# $FreeBSD$
-#
PORTNAME= sterm
-PORTVERSION= 0.2.1
+PORTVERSION= 0.3
CATEGORIES= x11
MASTER_SITES= http://dl.suckless.org/st/
DISTNAME= st-${PORTVERSION}
@@ -16,14 +12,18 @@ COMMENT= A simple X terminal
LICENSE= BSD
+LIB_DEPENDS= fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ freetype:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${LOCALBASE}/share/misc/terminfo.db:${PORTSDIR}/devel/ncurses
-USE_XORG= x11
+USE_XORG= x11 xext xft
MAN1= st.1
PLIST_FILES= bin/st
PORTDOCS= README
+.include <bsd.port.options.mk>
+
pre-everything::
@${ECHO_MSG} "You can build st with your own config.h using the ST_CONF knob:"
@${ECHO_MSG} "make ST_CONF=/path/to/st/config.h install clean"
@@ -42,7 +42,7 @@ post-patch:
${WRKSRC}/config.mk
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
diff --git a/x11/sterm/distinfo b/x11/sterm/distinfo
index a2dcb28bbf81..baa6cae85e91 100644
--- a/x11/sterm/distinfo
+++ b/x11/sterm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (st-0.2.1.tar.gz) = 4bf5817483d3274fae9a205e692b308a5fd0cfcb55ed9f3761d2c564b4f7d897
-SIZE (st-0.2.1.tar.gz) = 19804
+SHA256 (st-0.3.tar.gz) = 6d6ca8e8a110530caf97538eab96f0ec28ad2dc419054afeea91e8187b940e34
+SIZE (st-0.3.tar.gz) = 24424
diff --git a/x11/sterm/files/patch-Makefile b/x11/sterm/files/patch-Makefile
index e078cce28b9b..ccb4965174e8 100644
--- a/x11/sterm/files/patch-Makefile
+++ b/x11/sterm/files/patch-Makefile
@@ -1,9 +1,9 @@
---- Makefile.orig 2011-04-06 14:22:13.614498469 +0200
-+++ Makefile 2011-04-06 14:23:02.470588628 +0200
-@@ -48,7 +48,7 @@
- @mkdir -p ${DESTDIR}${MANPREFIX}/man1
- @sed "s/VERSION/${VERSION}/g" < st.1 > ${DESTDIR}${MANPREFIX}/man1/st.1
+--- Makefile.orig 2012-11-02 20:09:49.000000000 +0100
++++ Makefile 2012-11-26 21:33:04.882099791 +0100
+@@ -50,7 +50,7 @@
@chmod 644 ${DESTDIR}${MANPREFIX}/man1/st.1
+ @echo If things do not seem to work, be sure that there is no \
+ floating st terminfo in the .terminfo directory in your home dir.
- @tic -s st.info
+ @tic -s -o ${LOCALBASE}/share/misc st.info
diff --git a/x11/sterm/files/patch-config.mk b/x11/sterm/files/patch-config.mk
index 2745d9a21f59..9b764c43d099 100644
--- a/x11/sterm/files/patch-config.mk
+++ b/x11/sterm/files/patch-config.mk
@@ -1,21 +1,11 @@
---- config.mk.orig 2011-01-23 12:30:01.000000000 +0100
-+++ config.mk 2011-04-06 14:25:05.291720015 +0200
-@@ -5,6 +5,7 @@
+--- config.mk.orig 2012-11-02 20:09:49.000000000 +0100
++++ config.mk 2012-11-26 22:28:12.270095047 +0100
+@@ -11,7 +11,7 @@
+ X11LIB = /usr/X11R6/lib
- # paths
- PREFIX = /usr/local
-+LOCALBASE= /usr/local
- MANPREFIX = ${PREFIX}/share/man
-
- X11INC = /usr/X11R6/include
-@@ -16,8 +17,8 @@
+ # includes and libs
+-INCS = -I. -I/usr/include -I${X11INC} -I/usr/include/freetype2
++INCS = -I. -I/usr/include -I${X11INC} -I${X11INC}/freetype2
+ LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 -lutil -lXext -lXft -lfontconfig
# flags
- CPPFLAGS = -DVERSION=\"${VERSION}\"
--CFLAGS += -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
--LDFLAGS += -s ${LIBS}
-+CFLAGS += -std=c99 -pedantic -Wall ${INCS} ${CPPFLAGS}
-+LDFLAGS += ${LIBS}
-
- # compiler and linker
- CC ?= cc