aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
committerstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
commit08bfa7c4aa027efa35afd531304e476e4f713b80 (patch)
tree31b7120f0eb5ff46ed252641018a5ff19ff41fc3 /x11
parent982434000a36499258eff52f7032254355edca7a (diff)
downloadfreebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.gz
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.zst
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.zip
- Chase libusb20 rename in r189585.
- Mark sane-backends broken on current due to changes in USB stack. Reviewed by: thompsa (old version), miwi Tested by: miwi
Diffstat (limited to 'x11')
-rw-r--r--x11/kde4-workspace/Makefile11
-rw-r--r--x11/kdebase3/Makefile7
-rw-r--r--x11/kdebase4-workspace/Makefile11
3 files changed, 21 insertions, 8 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 9380d226f5fb..84a6296334cc 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -16,8 +16,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Basic applications for the KDE system
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb \
- qimageblitz.4:${PORTSDIR}/x11/qimageblitz\
+LIB_DEPENDS= qimageblitz.4:${PORTSDIR}/x11/qimageblitz\
dbus-1.3:${PORTSDIR}/devel/dbus \
hal.1:${PORTSDIR}/sysutils/hal \
xklavier.12:${PORTSDIR}/x11/libxklavier
@@ -52,6 +51,12 @@ CMAKE_ARGS+= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
#Xmms and Googlegadgets could be enabled,
#QEdje has not been ported yet.
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -74,4 +79,4 @@ post-install:
@${MV} ${PREFIX}/lib/kde4/libexec/kdm_greet ${PREFIX}/lib/kde4/libexec/kdm-bin_greet
@${INSTALL_SCRIPT} ${WRKDIR}/kdm ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index eb8b7f5785f8..7bf87dee6da4 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -23,8 +23,7 @@ BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake \
bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
LIB_DEPENDS= sasl2:${PORTSDIR}/security/cyrus-sasl2 \
- smbclient:${PORTSDIR}/net/samba-libsmbclient \
- usb-0.1:${PORTSDIR}/devel/libusb
+ smbclient:${PORTSDIR}/net/samba-libsmbclient
CONFLICTS= kdeartwork-3.[2-3]* kdelibs-3.[0-4]* kdeutils-3.[0-2]*
@@ -59,6 +58,10 @@ OPTIONS= ARTSWRAPPER "Suid wrapper for aRts, req'd for realtime prio" on \
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+.endif
+
.if !defined(WITHOUT_ARTSWRAPPER)
RUN_DEPENDS+= artswrapper:${PORTSDIR}/audio/artswrapper
.endif
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index 9380d226f5fb..84a6296334cc 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -16,8 +16,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Basic applications for the KDE system
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb \
- qimageblitz.4:${PORTSDIR}/x11/qimageblitz\
+LIB_DEPENDS= qimageblitz.4:${PORTSDIR}/x11/qimageblitz\
dbus-1.3:${PORTSDIR}/devel/dbus \
hal.1:${PORTSDIR}/sysutils/hal \
xklavier.12:${PORTSDIR}/x11/libxklavier
@@ -52,6 +51,12 @@ CMAKE_ARGS+= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
#Xmms and Googlegadgets could be enabled,
#QEdje has not been ported yet.
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -74,4 +79,4 @@ post-install:
@${MV} ${PREFIX}/lib/kde4/libexec/kdm_greet ${PREFIX}/lib/kde4/libexec/kdm-bin_greet
@${INSTALL_SCRIPT} ${WRKDIR}/kdm ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>