aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2017-09-15 17:38:58 +0800
committercpm <cpm@FreeBSD.org>2017-09-15 17:38:58 +0800
commit15787285b1e5f1aed9515784b59649331e5f14d4 (patch)
treeab38ff38ec219e5fab601b9c14464fa820944033 /x11
parent69300bd753b4e2a68fe0019c1ebeadc368d81eff (diff)
downloadfreebsd-ports-gnome-15787285b1e5f1aed9515784b59649331e5f14d4.tar.gz
freebsd-ports-gnome-15787285b1e5f1aed9515784b59649331e5f14d4.tar.zst
freebsd-ports-gnome-15787285b1e5f1aed9515784b59649331e5f14d4.zip
x11/altyo: unbreak build with vala 0.36
gmake[1]: Entering directory '/wrkdirs/usr/ports/x11/altyo/work/AltYo-debian-0.4_rc19-linvinus1' glib-compile-resources --sourcedir=./data --generate-source ./data/altyo.gresource.xml #test -e ./altyo && rm ./altyo valac -o altyo -v --disable-warnings -X -DGETTEXT_PACKAGE=\"altyo\" -X -DAY_GIT_HASH=\"\" -X -DAY_CHANGELOG_TAG=\"\" --vapidir ./vapi --pkg gtk+-3.0 --pkg gdk-x11-3.0 --pkg cairo --pkg posix --pkg gmodule-2.0 -D VTE_2_91 --pkg vte-2.91 vapi/config.vapi vapi/xkb.vapi main.vala hvbox.vala altyo_terminal.vala altyo_window.vala altyo_hotkey.vala altyo_config.vala altyo_settings.vala data/altyo.c altyo_window.vala:2892.99-2892.119: error: Argument 1: Cannot convert from `uint' to `int' string s = ( tab.tbutton.tab_title != null ? tab.tbutton.tab_title : _("index %d").printf(tab.tbutton.tab_index) ); ^^^^^^^^^^^^^^^^^^^^^ altyo_settings.vala:1609.107-1609.110: error: Argument 1: Cannot convert from `uint' to `int' string msg=_("New style will not be saved!\nin line %d at position %d\nerror:%s").printf(line,pos,S); ^^^^ altyo_settings.vala:704.24-704.27: error: Argument 1: Cannot pass value to reference or output parameter store.remove(iter); ^^^^ altyo_settings.vala:738.24-738.27: error: Argument 1: Cannot pass value to reference or output parameter store.remove(iter); ^^^^ altyo_settings.vala:772.24-772.27: error: Argument 1: Cannot pass value to reference or output parameter store.remove(iter); ^^^^ altyo_settings.vala:959.59-959.62: error: Argument 1: Cannot convert from `uint' to `int' msg=_("in line %d at position %d error:%s").printf(line,pos,S); ^^^^ While I'm here, pet portlint, DISTVERSIONSUFFIX appears out-of-order. PR: 222016 Submitted by: cpm Approved by: nivit (maintainer)
Diffstat (limited to 'x11')
-rw-r--r--x11/altyo/Makefile2
-rw-r--r--x11/altyo/files/patch-altyo__settings.vala56
-rw-r--r--x11/altyo/files/patch-altyo__window.vala11
3 files changed, 68 insertions, 1 deletions
diff --git a/x11/altyo/Makefile b/x11/altyo/Makefile
index fff3cd715980..f8053b39b71d 100644
--- a/x11/altyo/Makefile
+++ b/x11/altyo/Makefile
@@ -4,8 +4,8 @@
PORTNAME= altyo
DISTVERSIONPREFIX= debian/
DISTVERSION= 0.4_rc19
-PORTREVISION= 1
DISTVERSIONSUFFIX= -${GH_ACCOUNT}1
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= nivit@FreeBSD.org
diff --git a/x11/altyo/files/patch-altyo__settings.vala b/x11/altyo/files/patch-altyo__settings.vala
new file mode 100644
index 000000000000..7353d38df2c3
--- /dev/null
+++ b/x11/altyo/files/patch-altyo__settings.vala
@@ -0,0 +1,56 @@
+--- altyo_settings.vala.orig 2016-04-19 20:55:59 UTC
++++ altyo_settings.vala
+@@ -701,7 +701,11 @@ public class AYSettings : AYTab{
+ view.get_cursor(out path,out s_column);
+ if(store.get_iter(out iter,path))
+ if(!store.iter_has_child(iter)){
++#if VALA_0_36
++ store.remove(ref iter);
++#else
+ store.remove(iter);
++#endif
+ if(store.get_iter(out iter,path))
+ view.set_cursor(path,null,false);
+ else if(path.prev())
+@@ -735,7 +739,11 @@ public class AYSettings : AYTab{
+ view.get_cursor(out path,out s_column);
+ if(store.get_iter(out iter,path))
+ if(!store.iter_has_child(iter)){
++#if VALA_0_36
++ store.remove(ref iter);
++#else
+ store.remove(iter);
++#endif
+ if(store.get_iter(out iter,path))
+ view.set_cursor(path,null,false);
+ else if(path.prev())
+@@ -769,7 +777,11 @@ public class AYSettings : AYTab{
+ view.get_cursor(out path,out s_column);
+ if(store.get_iter(out iter,path))
+ if(!store.iter_has_child(iter)){
++#if VALA_0_36
++ store.remove(ref iter);
++#else
+ store.remove(iter);
++#endif
+ if(store.get_iter(out iter,path))
+ view.set_cursor(path,null,false);
+ else if(path.prev())
+@@ -956,7 +968,7 @@ public class AYSettings : AYTab{
+ string msg="";
+ uint line,pos;
+ if(!this.check_css(B.buffer.text,ref S,out line,out pos)){
+- msg=_("in line %d at position %d error:%s").printf(line,pos,S);
++ msg=_("in line %d at position %d error:%s").printf((int)line,(int)pos,S);
+ debug("on_check_css_button_activate %s",msg);
+ TextIter where;
+ B.buffer.get_iter_at_line_offset(out where,(int)line,(int)pos);
+@@ -1606,7 +1618,7 @@ public class AYSettings : AYTab{
+ string S="";
+ uint line,pos;
+ if(!this.check_css(s,ref S,out line,out pos)){
+- string msg=_("New style will not be saved!\nin line %d at position %d\nerror:%s").printf(line,pos,S);
++ string msg=_("New style will not be saved!\nin line %d at position %d\nerror:%s").printf((int)line,(int)pos,S);
+ debug("on config apply css error %s",msg);
+ this.ayobject.main_window.show_message_box(_("AltYo CSS style error"),msg);
+ }else{//looks good
diff --git a/x11/altyo/files/patch-altyo__window.vala b/x11/altyo/files/patch-altyo__window.vala
new file mode 100644
index 000000000000..f3bc23255784
--- /dev/null
+++ b/x11/altyo/files/patch-altyo__window.vala
@@ -0,0 +1,11 @@
+--- altyo_window.vala.orig 2016-04-19 20:55:59 UTC
++++ altyo_window.vala
+@@ -2889,7 +2889,7 @@ public class AYObject :Object{
+ for (item_it = this.children_removed.last(); item_it != null; item_it = item_it.prev) {
+ AYTab tab = item_it.data;
+ tab.stop_remove_timer();//disable timer while popup shown
+- string s = ( tab.tbutton.tab_title != null ? tab.tbutton.tab_title : _("index %d").printf(tab.tbutton.tab_index) );
++ string s = ( tab.tbutton.tab_title != null ? tab.tbutton.tab_title : _("index %d").printf((int)tab.tbutton.tab_index) );
+ menuitem = new Gtk.MenuItem.with_label ("%d: %s".printf(index,s));
+ menuitem.activate.connect(()=>{
+ debug("trying to restore tab %s",menuitem.label);