aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-23 14:43:40 +0800
committeredwin <edwin@FreeBSD.org>2004-12-23 14:43:40 +0800
commit1c9d7860f08089912252d926795059c709ca686a (patch)
treec69fb5ef6f5d971478cd4d987831e33f978cd5a3 /x11
parent69394ed40b202dd450e0f4f36be0dc50654ce767 (diff)
downloadfreebsd-ports-gnome-1c9d7860f08089912252d926795059c709ca686a.tar.gz
freebsd-ports-gnome-1c9d7860f08089912252d926795059c709ca686a.tar.zst
freebsd-ports-gnome-1c9d7860f08089912252d926795059c709ca686a.zip
New port: x11/xbelld
BellD is a small daemon for replacing the standard X Window System terminal bell with a more interesting set of sounds. This is useful for systems where the terminal bell is handled by the "PC Speaker," or where different sounds are desired for different classes of X clients. XBellD works by intercepting terminal bell requests on the server side, and then playing user-specified sounds through a PCM capable soundcard. The resource class of the client making a terminal bell request is used to match a corresponding sound file which should be played when such a request is made. WWW: http://www.meowfishies.com/xbelld.rhtml PR: ports/71815 Submitted by: Nosov Artem <chip-set@mail.ru>
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xbelld/Makefile31
-rw-r--r--x11/xbelld/distinfo2
-rw-r--r--x11/xbelld/pkg-descr16
-rw-r--r--x11/xbelld/pkg-message14
5 files changed, 64 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index eb3f7779a874..c56e49ac0545 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -194,6 +194,7 @@
SUBDIR += xautomation
SUBDIR += xballoon
SUBDIR += xbanner
+ SUBDIR += xbelld
SUBDIR += xbindkeys
SUBDIR += xbindkeys_config
SUBDIR += xcb
diff --git a/x11/xbelld/Makefile b/x11/xbelld/Makefile
new file mode 100644
index 000000000000..1e0a5247eb12
--- /dev/null
+++ b/x11/xbelld/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xbelld
+# Date created: 17 September 2004
+# Whom: Nosov Artem <chip-set@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xbelld
+PORTVERSION= 0.2b2
+CATEGORIES= x11
+MASTER_SITES= http://www.meowfishies.com/code/
+DISTNAME= ${PORTNAME}-0.2beta2
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= chip-set@mail.ru
+COMMENT= XBellD is a small daemon for replacing the standard X terminal bell
+
+LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
+
+USE_IMAKE= yes
+USE_GNOME= esound
+
+PLIST_FILES= bin/xbelld \
+ lib/X11/app-defaults/XBellD
+MAN1= xbelld.1
+XFREE86_HTML_MAN=no
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11/xbelld/distinfo b/x11/xbelld/distinfo
new file mode 100644
index 000000000000..7f9616727c32
--- /dev/null
+++ b/x11/xbelld/distinfo
@@ -0,0 +1,2 @@
+MD5 (xbelld-0.2beta2.tgz) = 35b43c4bebd0fb763427ff94e6dcdd30
+SIZE (xbelld-0.2beta2.tgz) = 16031
diff --git a/x11/xbelld/pkg-descr b/x11/xbelld/pkg-descr
new file mode 100644
index 000000000000..52b67de395e2
--- /dev/null
+++ b/x11/xbelld/pkg-descr
@@ -0,0 +1,16 @@
+XBellD is a small daemon for replacing the standard X Window
+System terminal bell with a more interesting set of sounds.
+This is useful for systems where the terminal bell is handled
+by the "PC Speaker," or where different sounds are desired for
+different classes of X clients.
+
+XBellD works by intercepting terminal bell requests on the
+server side, and then playing user-specified sounds through a
+PCM capable soundcard. The resource class of the client making
+a terminal bell request is used to match a corresponding sound
+file which should be played when such a request is made.
+
+WWW: http://www.meowfishies.com/xbelld.rhtml
+
+- Nosov Artem
+<chip-set@mail.ru>
diff --git a/x11/xbelld/pkg-message b/x11/xbelld/pkg-message
new file mode 100644
index 000000000000..8f7730528693
--- /dev/null
+++ b/x11/xbelld/pkg-message
@@ -0,0 +1,14 @@
++-----------------------------------------------------------------
+
+You need to have an X server with the "DEC-XTRAP" module loaded.
+In example, an XFree86 configuration file might contain the
+following "Modules" section:
+
+ Section "Module"
+ ...
+
+ # DEC-XTRAP extension module.
+ Load "xtrap"
+ EndSection
+
+-----------------------------------------------------------------+