aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-07-03 21:40:04 +0800
committertobik <tobik@FreeBSD.org>2017-07-03 21:40:04 +0800
commit20b88888b91435aee08fff87ba0b09a12d9442ef (patch)
tree7ed999168d33eae7199b98af1fb62a088c016a42 /x11
parent2a2d74982c1680e148eaccf36b4bc8521c91f1b3 (diff)
downloadfreebsd-ports-gnome-20b88888b91435aee08fff87ba0b09a12d9442ef.tar.gz
freebsd-ports-gnome-20b88888b91435aee08fff87ba0b09a12d9442ef.tar.zst
freebsd-ports-gnome-20b88888b91435aee08fff87ba0b09a12d9442ef.zip
Update to 1.3.1
- Remove I3 option: i3 has had native EWMH support for a while now so the i3 workarounds are no longer needed with rofi >= 1.2.0 Changes: https://github.com/DaveDavenport/rofi/releases PR: 218397 Approved by: mat (mentor), nomoo@nomoo.ru (maintainer) Differential Revision: https://reviews.freebsd.org/D11437
Diffstat (limited to 'x11')
-rw-r--r--x11/rofi/Makefile36
-rw-r--r--x11/rofi/distinfo5
-rw-r--r--x11/rofi/files/patch-source_i3-support.c24
-rw-r--r--x11/rofi/pkg-plist25
4 files changed, 47 insertions, 43 deletions
diff --git a/x11/rofi/Makefile b/x11/rofi/Makefile
index 8490d726a197..f243332e7869 100644
--- a/x11/rofi/Makefile
+++ b/x11/rofi/Makefile
@@ -1,8 +1,9 @@
# $FreeBSD$
PORTNAME= rofi
-PORTVERSION= 0.15.12
+PORTVERSION= 1.3.1
CATEGORIES= x11
+MASTER_SITES= https://github.com/DaveDavenport/rofi/releases/download/${PORTVERSION}/
MAINTAINER= nomoo@nomoo.ru
COMMENT= Window switcher, run dialog and dmenu replacement
@@ -10,24 +11,25 @@ COMMENT= Window switcher, run dialog and dmenu replacement
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification
+LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
+ libxcb-ewmh.so:x11/xcb-util-wm \
+ libxcb-icccm.so:x11/xcb-util-wm \
+ libxcb-util.so:x11/xcb-util \
+ libxcb-xrm.so:x11/xcb-util-xrm \
+ libxkbcommon-x11.so:x11/libxkbcommon
-USE_GITHUB= yes
-GH_ACCOUNT= DaveDavenport
+USES= gmake pkgconfig shebangfix
+USE_GNOME= cairo pango
+USE_XORG= xcb
GNU_CONFIGURE= yes
-USES= autoreconf gmake pkgconfig shebangfix
-SHEBANG_FILES= ${WRKSRC}/script/rofi-sensible-terminal
-USE_XORG= x11 xinerama xft
-USE_GNOME= pango
-
-OPTIONS_DEFINE= I3
-
-I3_DESC= I3 support
-I3_BUILD_DEPENDS= i3:x11-wm/i3
-I3_CFLAGS= -I${LOCALBASE}/include
-
-PLIST_FILES= bin/rofi bin/rofi-sensible-terminal man/man1/rofi.1.gz \
- man/man1/rofi-sensible-terminal.1.gz
+SHEBANG_FILES= script/get_git_rev.sh \
+ script/rofi-sensible-terminal
+bash_CMD= /bin/sh
+
+post-patch:
+# Fix rofi-theme-selector which assumes we have GNU sed
+ @${REINPLACE_CMD} 's|$${SED} -i |$${SED} -i "" |' \
+ ${WRKSRC}/script/rofi-theme-selector
.include <bsd.port.mk>
diff --git a/x11/rofi/distinfo b/x11/rofi/distinfo
index e3c63dcf7a23..510c39291447 100644
--- a/x11/rofi/distinfo
+++ b/x11/rofi/distinfo
@@ -1,2 +1,3 @@
-SHA256 (DaveDavenport-rofi-0.15.12_GH0.tar.gz) = e5e6b0ed01fd1186652af2488ca2e7780cbde5f0750d9482eb816bae447f4e84
-SIZE (DaveDavenport-rofi-0.15.12_GH0.tar.gz) = 966863
+TIMESTAMP = 1498373936
+SHA256 (rofi-1.3.1.tar.gz) = da61d2da7e5f4f354da2bfb50ec06b0613d6aba6cf09346a86177f3351db2326
+SIZE (rofi-1.3.1.tar.gz) = 281690
diff --git a/x11/rofi/files/patch-source_i3-support.c b/x11/rofi/files/patch-source_i3-support.c
deleted file mode 100644
index e9012e3caf1a..000000000000
--- a/x11/rofi/files/patch-source_i3-support.c
+++ /dev/null
@@ -1,24 +0,0 @@
-# Description: Use correct namelen when connecting to i3 socket
-# Pull Request: https://github.com/DaveDavenport/rofi/pull/330
---- source/i3-support.c.orig 2015-12-27 18:45:50 UTC
-+++ source/i3-support.c
-@@ -50,7 +50,7 @@ char *i3_socket_path = NULL;
- void i3_support_focus_window ( Window id )
- {
- i3_ipc_header_t head;
-- int s, len;
-+ int s;
- ssize_t t;
- struct sockaddr_un remote;
- size_t upm = sizeof ( remote.sun_path );
-@@ -68,9 +68,8 @@ void i3_support_focus_window ( Window id
-
- remote.sun_family = AF_UNIX;
- g_strlcpy ( remote.sun_path, i3_socket_path, upm );
-- len = strlen ( remote.sun_path ) + sizeof ( remote.sun_family );
-
-- if ( connect ( s, ( struct sockaddr * ) &remote, len ) == -1 ) {
-+ if ( connect ( s, ( struct sockaddr * ) &remote, sizeof ( struct sockaddr_un ) ) == -1 ) {
- fprintf ( stderr, "Failed to connect to I3 (%s): %s\n", i3_socket_path, strerror ( errno ) );
- close ( s );
- return;
diff --git a/x11/rofi/pkg-plist b/x11/rofi/pkg-plist
new file mode 100644
index 000000000000..dce94933db60
--- /dev/null
+++ b/x11/rofi/pkg-plist
@@ -0,0 +1,25 @@
+bin/rofi
+bin/rofi-sensible-terminal
+bin/rofi-theme-selector
+man/man1/rofi-sensible-terminal.1.gz
+man/man1/rofi.1.gz
+%%DATADIR%%/themes/Adapta-Nokto.theme
+%%DATADIR%%/themes/Arc.theme
+%%DATADIR%%/themes/DarkBlue.theme
+%%DATADIR%%/themes/Indego.theme
+%%DATADIR%%/themes/Monokai.theme
+%%DATADIR%%/themes/Paper.theme
+%%DATADIR%%/themes/android_notification.theme
+%%DATADIR%%/themes/blue.theme
+%%DATADIR%%/themes/c64.theme
+%%DATADIR%%/themes/glue_pro_blue.theme
+%%DATADIR%%/themes/gruvbox-dark-hard.theme
+%%DATADIR%%/themes/gruvbox-dark-soft.theme
+%%DATADIR%%/themes/gruvbox-dark.theme
+%%DATADIR%%/themes/gruvbox-light-hard.theme
+%%DATADIR%%/themes/gruvbox-light-soft.theme
+%%DATADIR%%/themes/gruvbox-light.theme
+%%DATADIR%%/themes/lb.theme
+%%DATADIR%%/themes/purple.theme
+%%DATADIR%%/themes/solarized.theme
+%%DATADIR%%/themes/solarized_alternate.theme